Tâche #8853
Distribution EOLE - Scénario #8770: Finalisation AmonEcole 2.4 Alpha
Erreur lors de la restauration des bases de données par Bacula sur AmonEcole 2.4
100%
Description
J'ai essayé de faire passer les tests Squash "Sauvegarde et restauration" mais mes bases de données n'ont pas été restaurées...
En étudiant les logs, je vois :
ClientRunBeforeJob: pre mysql Ready to read from volume "amonecole-dir-full-0002" on device "FileStorage" (/mnt/sauvegardes). Forward spacing Volume "amonecole-dir-full-0002" to file:block 0:217. drwxr-xr-x 38 root root 4096 2014-09-10 13:27:13 /home/ End of Volume at file 0 on device "FileStorage" (/mnt/sauvegardes), Volume "amonecole-dir-full-0002" Ready to read from volume "amonecole-dir-inc-0004" on device "FileStorage" (/mnt/sauvegardes). -rw------- 1 root root 20832 2014-09-11 17:20:12 /home/backup/sql/roundcube.sql -rw------- 1 root root 1435 2014-09-11 17:20:12 /home/backup/sql/testsquash.sql -rw------- 1 root root 541795 2014-09-11 17:20:12 /home/backup/sql/mysql.sql -rw------- 1 root root 941128 2014-09-11 17:20:12 /home/backup/sql/sympa.sql drwx------ 2 root root 4096 2014-09-11 17:20:12 /home/backup/sql/ drwx------ 4 root root 4096 2014-09-11 17:20:09 /home/backup/ Forward spacing Volume "amonecole-dir-inc-0004" to file:block 0:608517. shell command: run ClientAfterJob "/usr/share/eole/sbin/bacularestore.py --mysql post" ClientAfterJob: ERROR 1045 (28000): Access denied for user 'debian-sys-maint'@'localhost' (using password: YES) ClientAfterJob: ERROR 1045 (28000): Access denied for user 'debian-sys-maint'@'localhost' (using password: YES) ClientAfterJob: ERROR 1045 (28000): Access denied for user 'root'@'192.0.2.1' (using password: YES) ClientAfterJob: post mysql ClientAfterJob: restauration de /home/backup/sql/roundcube.sql ClientAfterJob: restauration de /home/backup/sql/testsquash.sql ClientAfterJob: restauration de /home/backup/sql/mysql.sql ClientAfterJob: restauration de /home/backup/sql/sympa.sql
Révisions associées
Changement de mot de passe avec config alternative
- scripts/mysql_pwd.py (mysql_root_passwd) : possibilité de choisir un fichier
`debian.cnf` alternatif pour modifier le mot de passe root de mysql
Ref #8853 @30m
Correction sur la restauration des bases MySQL
- bacula/restore/mysql.py
- restauration du fichier /etc/mysql/debian.cnf
- utilisation de l'ancien debian.cnf pour la maj du mot de passe
- restauration du dump de la bdd mysql en dernier
Fixes #8853 @1h
Dépendance versionnée sur python-eolesql
Ref #8853 @10m
Historique
#1 Mis à jour par Daniel Dehennin il y a environ 12 ans
- Description mis à jour (diff)
- Restant à faire (heures) mis à 4.0
#2 Mis à jour par Joël Cuissinat il y a environ 12 ans
Visiblement le problème est que la restauration de la base mysql restaure des mots de passe et il y a un problème avec la ou les bases restaurées ensuite.
#3 Mis à jour par Joël Cuissinat il y a environ 12 ans
- Assigné à mis à Joël Cuissinat
#4 Mis à jour par Joël Cuissinat il y a environ 12 ans
- Statut changé de Nouveau à Résolu
- % réalisé changé de 0 à 100
Appliqué par commit 4b4d83e2f3ea356455e1c25c0b21b79074925203.
#5 Mis à jour par Joël Cuissinat il y a environ 12 ans
"Cas de test : SR-T03-002 - Restauration Complete" enrichi et adapté pour être compatible avec AmonEcole 2.4
#6 Mis à jour par Joël Cuissinat il y a environ 12 ans
- Restant à faire (heures)
4.0supprimé
#7 Mis à jour par Benjamin Bohard il y a environ 12 ans
- Statut changé de Résolu à Fermé
Paquet testé : 2.4.1-1