Project

General

Profile

Anomalie #7900

TestFirewall est toujours en erreur

Added by Daniel Dehennin about 7 years ago. Updated almost 7 years ago.

Status:
Fermé
Priority:
Haut
Assigned To:
Category:
-
Start date:
04/08/2014
Due date:
04/18/2014
% Done:

100%

Spent time:
Distribution:
EOLE 2.4

Description

Le grep renvoi toujours la valeur 141.

Associated revisions

Revision 0ad37479 (diff)
Added by Daniel Dehennin about 7 years ago

TestFirewall est toujours en erreur

Le problème vient de l’utilisation de « grep -q » qui se termine à la
première occurrence trouvée alors que la commande « iptables-save »
continue d’écrire dans le pipe.

  • lib/eole/diagnose.sh (TestFirewall): Utilisation d’une redirection
    vers « /dev/null » au lieu d’utiliser l’option « -q ».

Fixes: #7900 @45m

History

#1 Updated by Daniel Dehennin about 7 years ago

  • Due date set to 04/18/2014

#2 Updated by Daniel Dehennin about 7 years ago

  • Assigned To set to Daniel Dehennin

#3 Updated by Daniel Dehennin about 7 years ago

  • Status changed from Nouveau to Résolu
  • % Done changed from 0 to 100

#4 Updated by Philippe Caseiro almost 7 years ago

  • Status changed from Résolu to Fermé

Sur un Amon 2.4.0 je lance :

# . /usr/lib/eole/diagnose.sh
# TestFirewall 

Résultat :

.                    Pare-feu => Ok

Avec un diagnose même résultat :

Sur l'interface réseau eth0
.                    Pare-feu => Ok
.                         SSH => Ok
.                  EAD Server => Ok
.                     EAD Web => Ok

Sur un Scribe :

Sur l'interface réseau eth0
.                    Pare-feu => Ok
.                         SSH => Ok
.                  EAD Server => Ok
.                     EAD Web => Ok

Also available in: Atom PDF