Project

General

Profile

Evolution #6969

Migration 2.3->2.4: supprimer le script de configuration Grub

Added by Joël Cuissinat over 10 years ago. Updated over 10 years ago.

Status:
Fermé
Priority:
Normal
Assigned To:
Category:
-
Start date:
01/22/2014
Due date:
01/24/2014
% Done:

100%

Estimated time:
1.00 h
Spent time:
Distribution:
EOLE 2.4

Description

Generating grub.cfg ...
Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.

En 2.3, il y avait des choses fournies par le projet project:eole-kernel-version

cf. http://dev-eole.ac-dijon.fr/projects/eole-kernel-version/repository/revisions/master/entry/grub.d/90_eole_default_kernel


Related issues

Related to eole-preseed - Evolution #3987: Utiliser debconf pour gérer /etc/default/grub Fermé 09/03/2012 01/24/2014

Associated revisions

Revision 734a293c (diff)
Added by Daniel Dehennin over 10 years ago

Le paquet « eole-kernel-version » n’est plus utile

  • debian/control: « eole-server » remplace complètement
    « eole-kernel-version ».

Ref: #6969

Revision f156ebfb (diff)
Added by Daniel Dehennin over 10 years ago

Mise à niveau de la configuration Grub

Le paramètre « GRUB_HIDDEN_TIMEOUT » ne doit pas être défini lorsque
« GRUB_TIMEOUT » n’est pas 0.

  • debian/eole-server.postinst: Tester si le fichier de configuration
    Grub est présent, ce qui n’est pas le cas lors de l’installation CD.
    Forcer « GRUB_HIDDEN_TIMEOUT » en commentaire.

Fixes: #6969 @15m
Ref: #3987

History

#1 Updated by Joël Cuissinat over 10 years ago

  • Subject changed from Warnig grub à l'étape to Warnig grub à l'étape "Mise à jour de la configuration Grub"
  • Description updated (diff)

#2 Updated by Daniel Dehennin over 10 years ago

  • Status changed from Nouveau to Accepté
  • Assigned To set to Daniel Dehennin

#3 Updated by Daniel Dehennin over 10 years ago

  • Target version changed from Eole 2.4-RC2 to Eole 2.4-RC1

#4 Updated by Daniel Dehennin over 10 years ago

Il faut virer le paquet project:eole-kernel-version qui fourni ce script lors d’un ugrade 2.3->2.4.

#5 Updated by Daniel Dehennin over 10 years ago

  • Project changed from creole to eole-common
  • Subject changed from Warnig grub à l'étape "Mise à jour de la configuration Grub" to Migration 2.3->2.4: supprimer le script de configuration Grub

Il faut que le paquet eole-kernel-version soit supprimé car il n’est plus utile en 2.4.

#6 Updated by Daniel Dehennin over 10 years ago

Je propose que le paquet eole-server ait les Provides/Replaces/Breaks sur project:eole-kernel-version.

#7 Updated by Daniel Dehennin over 10 years ago

  • Due date set to 01/24/2014
  • Status changed from Accepté to Résolu
  • Start date set to 01/22/2014
  • % Done changed from 0 to 100

À tester sur une migration.

#8 Updated by Joël Cuissinat over 10 years ago

  • Status changed from Résolu to À valider
  • Target version changed from Eole 2.4-RC1 to Eole 2.4-RC2
  • % Done changed from 100 to 80

Sur un serveur migré ou une installation 2.4 plus ancienne (testé avec beta2 + maj), il reste un warning :

root@scribe:~# update-grub
Generating grub.cfg ...
Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Found linux image: /boot/vmlinuz-3.8.0-35-generic
Found initrd image: /boot/initrd.img-3.8.0-35-generic
Found linux image: /boot/vmlinuz-3.8.0-33-generic
Found initrd image: /boot/initrd.img-3.8.0-33-generic
Found memtest86+ image: /memtest86+.bin
done

Mais OK sur une fraîche installation 2.4-RC1.

#9 Updated by Daniel Dehennin over 10 years ago

  • Status changed from À valider to Résolu
  • % Done changed from 80 to 100

#10 Updated by Gilles Grandgérard over 10 years ago

  • Status changed from Résolu to Fermé

ok

Also available in: Atom PDF