Project

General

Profile

Evolution #4963

Version des smbldap-tools sur Eole-2.4

Added by Joël Cuissinat almost 7 years ago. Updated almost 7 years ago.

Status:
Fermé
Priority:
Normal
Assigned To:
Category:
-
Start date:
03/11/2013
Due date:
03/15/2013
% Done:

100%

Estimated time:
1.50 h
Spent time:
Distribution:
EOLE 2.4

Description

La version fournie de base sur precise est : 0.9.7-1ubuntu1

En 2.3, nous avons monté de version, notamment pour le multi-étab : 0.9.9-eole1

De plus, je constate qu'avec la version nativement fournie :
  1. ça affiche un warning Perl :
    Use of qw(...) as parentheses is deprecated at /usr/share/perl5/smbldap_tools.pm line 1423, <DATA> line 522.
    
  2. il manque des attributs aux utilisateurs créés (sambaHomeDrive, sambaHomePath, sambaLogonScript, sambaPrimaryGroupSID) :
    Le backend a renvoyé une erreur lors de l'exécution de la requête :
    Traceback: <type 'exceptions.KeyError'>: 'sambaHomeDrive'
    

Related issues

Precedes eole-fichier - Evolution #5051: Mise à niveau du fichier smbldap.conf Fermé 03/18/2013 03/22/2013

Associated revisions

Revision 56ddbf02 (diff)
Added by Joël Cuissinat almost 7 years ago

Intégration des sources récupérées sur "lucid32"

Ref #4963 @20m

Revision 6bcb7e1d (diff)
Added by Joël Cuissinat almost 7 years ago

Intégration du packaging récupéré sur "lucid32"

Ref #4963 @15m

Revision 2d9feca4 (diff)
Added by Joël Cuissinat almost 7 years ago

  • debian/control : suppression dependence : libdigest-sha1-perl

Ref #4963 @5m

Revision a3becde8 (diff)
Added by Joël Cuissinat almost 7 years ago

Restore sources from official tarball

Ref #4963 @10m

History

#1 Updated by Daniel Dehennin almost 7 years ago

  • Status changed from Nouveau to Accepté
  • Assigned To set to developpeurs_eole
  • Target version set to Eole 2.4-dev-2

Dans la mesure où les smbldap-tools sont nécessaires pour samba3…

#2 Updated by Daniel Dehennin almost 7 years ago

  • Assigned To changed from developpeurs_eole to Daniel Dehennin

#3 Updated by Joël Cuissinat almost 7 years ago

  • Project changed from Paquets deb to smbldap-tools
  • Due date set to 03/15/2013
  • Assigned To changed from Daniel Dehennin to Joël Cuissinat
  • Start date set to 03/11/2013
  • Estimated time set to 1.50 h

#4 Updated by Joël Cuissinat almost 7 years ago

  • Status changed from Accepté to Résolu
  • % Done changed from 0 to 100

=> paquet unstable : smbldap-tools_0.9.9.1-1_all.deb

#5 Updated by Joël Cuissinat almost 7 years ago

  • Status changed from Résolu to Fermé

Bugs non constatés avec :

root@scribe:~# dpkg -l smbldap-tools 
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                         Version                     Description
+++-===========================-===========================-======================================================================
ii  smbldap-tools               0.9.9.1-1                   Scripts to manage Unix and Samba accounts stored on LDAP

Also available in: Atom PDF