Project

General

Profile

Tâche #30192

Scénario #30169: Identifier les paquets python 2.7 restant sur EOLE 2.8.0

Corriger les dépendances pour Focal

Added by Daniel Dehennin about 1 month ago. Updated 24 days ago.

Status:
Fermé
Priority:
Normal
Assigned To:
Start date:
05/28/2020
Due date:
% Done:

100%

Remaining (hours):
0.0

Description

  • squid3 est remplacé par squid en version 4.10
  • courier-imap-ssl est remplacé par courier-imap
  • courier-pop-ssl est remplacé par courier-pop
  • libssl1.0.0 est une dépendance de libpam-cas-eole
  • php-gettext et php-php-gettext sont des dépendances de bareos-webui
  • libffi6 est une dépendance de opennebula-rubygems
  • libvirt-bin est remplacé par libvirt-daemon-system

Related issues

Related to Distribution EOLE - Scénario #29476: Faire en sorte que le module Scribe s'installe (pb sympa) Terminé (Sprint) 05/29/2020 06/12/2020

Associated revisions

Revision d6812e72 (diff)
Added by Daniel Dehennin about 1 month ago

Squid3 is a transitional package

Ref: #30192

Revision bfe2dc80 (diff)
Added by Daniel Dehennin about 1 month ago

Courier ssl packages are transitional

Ref: #30192

Revision 104ed440 (diff)
Added by Daniel Dehennin about 1 month ago

New build for EOLE 2.8

Ref: #30192

Revision ae6449b9 (diff)
Added by Daniel Dehennin about 1 month ago

Libvirt-bin is now libvirt-daemon-system

Ref: #30192

Revision b18bbf78 (diff)
Added by Daniel Dehennin about 1 month ago

No bareos-webui for now

Ref: #30192

Revision b89211db (diff)
Added by Daniel Dehennin about 1 month ago

Require a new build for proftpd ABI on Focal

Ref: #30192

Revision 77052560 (diff)
Added by Daniel Dehennin about 1 month ago

Python2: package can't be produced because of dependencies

On focal, there is no libmysqlclient20, so python-mysqldb is
uninstallable.

Ref: #30192

Revision 88711098 (diff)
Added by Daniel Dehennin about 1 month ago

Update debhelper compatibility version

Ref: #30192

Revision fc5b0984 (diff)
Added by Daniel Dehennin about 1 month ago

Python2: python-eolesql can't be installed

We remove this package from eolesql since it's python-mysqldb
dependency can't be installed anymore.

Ref: #30192

Revision 63751bd8 (diff)
Added by Daniel Dehennin about 1 month ago

No bareos-webui for now

Ref: #30192

Revision c6a86e54 (diff)
Added by Daniel Dehennin about 1 month ago

debhelper 12 requires some modification to build rules

And fix debian/control mess.

Ref: #30192

Revision 86883577 (diff)
Added by Daniel Dehennin about 1 month ago

Sympa can't be installed with dbconfig-no-thanks

Ref: #30192

Revision 8cfff40f (diff)
Added by Daniel Dehennin about 1 month ago

Sympa can't be used with dbconfig-no-thanks

We need to configure softwares with sqlite3 database by default.

  • preseed/classes/dbconfig-common/preseed: do not disable dbconfig.
  • preseed/classes/sympa/preseed: select sqlite3 database type.
  • preseed/classes/bareos-database-common/preseed: ditoo.
  • preseed/classes/eole/2.8/subclasses: use “sympa” and
    “bareos-database-common” subclasses.

Ref: #30192

History

#1 Updated by Daniel Dehennin about 1 month ago

  • Status changed from Nouveau to En cours
  • Assigned To set to Daniel Dehennin

#2 Updated by Daniel Dehennin about 1 month ago

  • Related to Scénario #29476: Faire en sorte que le module Scribe s'installe (pb sympa) added

#3 Updated by Daniel Dehennin about 1 month ago

  • Status changed from En cours to Résolu
  • % Done changed from 0 to 100

#4 Updated by Daniel Dehennin 24 days ago

  • Status changed from Résolu to Fermé
  • Remaining (hours) set to 0.0

Also available in: Atom PDF