Project

General

Profile

Tâche #24360

Scénario #24291: EOLE 2.7.0 : Le module Hâpy doit s'instancier

Le service oned ne fonctionne pas

Added by Daniel Dehennin almost 3 years ago. Updated over 2 years ago.

Status:
Fermé
Priority:
Normal
Assigned To:
Start date:
06/26/2018
Due date:
% Done:

100%

Estimated time:
4.00 h
Spent time:
Remaining (hours):
0.0

Associated revisions

Revision 9aed48df (diff)
Added by Daniel Dehennin almost 3 years ago

OpenNebula daemon does not start without ruby-xmlrpc

We provide the package in our own repositories.

  • debian/control (Depends): add ruby-xmlrpc.

Ref: #24360

Revision 251fca22 (diff)
Added by Daniel Dehennin almost 3 years ago

The “onenode” service is provided by the master package

  • debian/rules: rename the package

Ref: #24360

History

#1 Updated by Scrum Master almost 3 years ago

  • Status changed from Nouveau to En cours

#2 Updated by Scrum Master almost 3 years ago

  • Assigned To set to Daniel Dehennin

#3 Updated by Daniel Dehennin almost 3 years ago

Le daemon ne démarre pas à cause d’une lib ruby manquante :

root@hapy:~# /usr/lib/one/mads/one_vmm_exec.rb -t 15 -r 0 kvm
Traceback (most recent call last):
    11: from /usr/lib/one/mads/one_vmm_exec.rb:36:in `<main>'
    10: from /usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
     9: from /usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
     8: from /usr/lib/one/ruby/VirtualMachineDriver.rb:16:in `<top (required)>'
     7: from /usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
     6: from /usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
     5: from /usr/lib/one/ruby/opennebula.rb:28:in `<top (required)>'
     4: from /usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
     3: from /usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
     2: from /usr/lib/one/ruby/opennebula/client.rb:17:in `<top (required)>'
     1: from /usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
/usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require': cannot load such file -- xmlrpc/client (LoadError)

#4 Updated by Scrum Master almost 3 years ago

  • Status changed from En cours to Résolu

#5 Updated by Daniel Dehennin almost 3 years ago

  • % Done changed from 0 to 100
  • Remaining (hours) changed from 4.0 to 0.25

#6 Updated by Daniel Dehennin over 2 years ago

  • Status changed from Résolu to Fermé
  • Remaining (hours) changed from 0.25 to 0.0

Also available in: Atom PDF