Project

General

Profile

Tâche #24082

Scénario #23988: Tests et qualification (23-25)

Maj-Release 2.6.0 -> 2.6.2 en erreur

Added by Joël Cuissinat about 2 years ago. Updated about 2 years ago.

Status:
Fermé
Priority:
Normal
Assigned To:
Start date:
06/04/2018
Due date:
% Done:

100%

Estimated time:
4.00 h
Spent time:
Remaining (hours):
0.0

Description

Plusieurs tests jenkins signalent un problème :

L'erreur signalée est la suivante :

Mise à jour des fichiers de configuration
Erreur de chargement lors du chargement des configurations : impossible de redéfinir l'objet inexistant eole_lv_names

Mais elle pourrait s'expliquer par le message suivant visible plus haut :

Les paquets suivants ont été conservés :
   eole-server


Related issues

Copied to Distribution EOLE - Tâche #24446: Maj-Release 2.6.0 -> 2.6.1 en erreur Fermé 07/16/2018

Associated revisions

Revision fedf6bb5 (diff)
Added by Daniel Dehennin about 2 years ago

Better dependencies ordering

Specific dependencies must be installed before any generic ones.

  • debian/control: reorder dependencies.

Ref: #24082

Revision 7d66abcb (diff)
Added by Daniel Dehennin about 2 years ago

Better dependencies ordering

Specific dependencies must be installed before any generic ones.

  • debian/control: reorder dependencies.

Ref: #24082

Revision 3853a96d (diff)
Added by Daniel Dehennin about 2 years ago

Better dependencies ordering

Specific dependencies must be installed before any generic ones.

  • debian/control: reorder dependencies.

Ref: #24082

Revision f521ca06 (diff)
Added by Daniel Dehennin about 2 years ago

Better dependencies ordering

Specific dependencies must be installed before any generic ones.

  • debian/control: reorder dependencies.

Ref: #24082

Revision 2ad31764 (diff)
Added by Daniel Dehennin about 2 years ago

fix broken dependencies list

Specific dependencies must be installed before any generic ones.

  • debian/control: reorder dependencies.

Ref: #24082

Revision 0f2f8bea (diff)
Added by Daniel Dehennin about 2 years ago

Better dependencies ordering

Specific dependencies must be installed before any generic ones.

  • debian/control: reorder dependencies.

Ref: #24082

Revision 93d80dfe (diff)
Added by Daniel Dehennin about 2 years ago

Better dependencies ordering

Specific dependencies must be installed before any generic ones.

  • debian/control: reorder dependencies.

Ref: #24082

Revision f8734249 (diff)
Added by Daniel Dehennin about 2 years ago

Better dependencies ordering

Specific dependencies must be installed before any generic ones.

  • debian/control: reorder dependencies.

Ref: #24082

Revision 71b47601 (diff)
Added by Daniel Dehennin about 2 years ago

Better dependencies ordering

Specific dependencies must be installed before any generic ones.

  • debian/control: reorder dependencies.

Ref: #24082

Revision c0f36743 (diff)
Added by Daniel Dehennin about 2 years ago

Broken dependencies list

  • debian/control: add missing comma.

Ref: #24082

Revision d93c7bd8 (diff)
Added by Daniel Dehennin about 2 years ago

Better dependencies ordering

Specific dependencies must be installed before any generic ones.

  • debian/control: reorder dependencies.

Ref: #24082

Revision ce4e923b (diff)
Added by Daniel Dehennin about 2 years ago

Better dependencies ordering

Specific dependencies must be installed before any generic ones.

  • debian/control: reorder dependencies.

Ref: #24082

Revision 40f8f1ba (diff)
Added by Daniel Dehennin about 2 years ago

Refine dependencies for eole-lxc-controller installation

Ref: #24082

Revision 37dbce2d (diff)
Added by Daniel Dehennin about 2 years ago

Accept nginx-full as an alternative to nginx-ligth

Ref: #24082

Revision d821c7ed (diff)
Added by Daniel Dehennin about 2 years ago

Better dependencies ordering

Specific dependencies must be installed before any generic ones.

  • debian/control: reorder dependencies.

Ref: #24082

Revision 5c83688a (diff)
Added by Daniel Dehennin about 2 years ago

Break circle dependencies with eole-server

  • debian/control (Depends): remove eole-server.

Ref: #24082

Revision 4e8ac7db (diff)
Added by Daniel Dehennin about 2 years ago

Install GenConfig before EAD3

This may resolve the dist-upgrade issue between nginx-light and
nginx-full.

Ref: #24082

Revision 6424d851 (diff)
Added by Daniel Dehennin about 2 years ago

Force nginx-full to resolve conflict when upgrading ead3

Ref: #24082

History

#1 Updated by Joël Cuissinat about 2 years ago

root@sphynx:~# apt-get -o Debug::pkgProblemResolver=true -o Debug::pkgDepCache::AutoInstall=true dist-upgrade -s 
   [ ... ]
Starting pkgProblemResolver with broken count: 2
Starting 2 pkgProblemResolver with broken count: 2
Investigating (0) nginx-light [ amd64 ] < 1.10.3-0ubuntu0.16.04.2 > ( universe/httpd )
Broken nginx-light:amd64 Est en conflit avec on nginx-full [ amd64 ] < none -> 1.10.3-0ubuntu0.16.04.2 > ( universe/httpd )
  Considering nginx-full:amd64 0 as a solution to nginx-light:amd64 1
  Added nginx-full:amd64 to the remove list
  Conflicts//Breaks against version 1.9.15-0ubuntu1 for nginx-full but that is not InstVer, ignoring
  Fixing nginx-light:amd64 via keep of nginx-full:amd64
Investigating (0) eole-reverseproxy-pkg [ amd64 ] < none -> 2.6.2-12 > ( metapackages )
Broken eole-reverseproxy-pkg:amd64 Dépend on nginx-full [ amd64 ] < none -> 1.10.3-0ubuntu0.16.04.2 > ( universe/httpd )
  Considering nginx-full:amd64 0 as a solution to eole-reverseproxy-pkg:amd64 0
  Holding Back eole-reverseproxy-pkg:amd64 rather than change nginx-full:amd64
Investigating (1) eole-ead3 [ amd64 ] < none -> 2.6.2-10 > ( web )
Broken eole-ead3:amd64 Dépend on nginx-full [ amd64 ] < none -> 1.10.3-0ubuntu0.16.04.2 > ( universe/httpd )
  Considering nginx-full:amd64 0 as a solution to eole-ead3:amd64 2
  Holding Back eole-ead3:amd64 rather than change nginx-full:amd64
Investigating (1) eole-reverseproxy [ amd64 ] < none -> 2.6.2-12 > ( admin )
Broken eole-reverseproxy:amd64 Dépend on eole-reverseproxy-pkg [ amd64 ] < none -> 2.6.2-12 > ( metapackages )
  Considering eole-reverseproxy-pkg:amd64 0 as a solution to eole-reverseproxy:amd64 0
  Holding Back eole-reverseproxy:amd64 rather than change eole-reverseproxy-pkg:amd64
Investigating (2) eole-server [ amd64 ] < 2.6.0-131 -> 2.6.2-70 > ( admin )
Broken eole-server:amd64 Dépend on eole-ead3 [ amd64 ] < none -> 2.6.2-10 > ( web )
  Considering eole-ead3:amd64 2 as a solution to eole-server:amd64 3
  Holding Back eole-server:amd64 rather than change eole-ead3:amd64
 Try to Re-Instate (3) eole-server:amd64

#2 Updated by Daniel Dehennin about 2 years ago

  • Status changed from Nouveau to En cours

#3 Updated by Daniel Dehennin about 2 years ago

  • Assigned To set to Daniel Dehennin

#4 Updated by Daniel Dehennin about 2 years ago

  • Status changed from En cours to Résolu
  • % Done changed from 0 to 100
  • Remaining (hours) changed from 4.0 to 0.0

C’est finalement réglé.

#5 Updated by Fabrice Barconnière about 2 years ago

Synchro dépôts, annonce, journaux, mails
https://dev-eole.ac-dijon.fr/news/437

#6 Updated by Joël Cuissinat about 2 years ago

  • Status changed from Résolu to Fermé

OK

#7 Updated by Joël Cuissinat almost 2 years ago

  • Copied to Tâche #24446: Maj-Release 2.6.0 -> 2.6.1 en erreur added

Also available in: Atom PDF