Tâche #22068
Scénario #21866: Traitement express MEN (46-48)
une erreur récurrente apparait dans les logs de sunstone. De plus, à la connexion d'un utilisateur, une popup rouge apparait
100%
Description
log de sunstone
Révisions associées
We don't want annoying request from the web interface
The “support” tab in Sunstone check for subscription to the commercial
OpenNebula support:
http://docs.opennebula.org/5.4/deployment/sunstone_setup/sunstone.html#commercial-support-integration
The “upgrade” tab check for new version in OpenNebula.
- tmpl/admin.yaml (enabled_tabs): disable “support-tab” and
“upgrade-top-tab”.
- tmpl/admin_vcenter.yaml (enabled_tabs): ditoo.
Ref: #22068
The OneFlow route must always be active to avoid error in cloud view
The cloud view always makes request to “/service” even when the
OneFlow provisionning tab is disable.
When the OneFlow service is disable and the route is active, Sunstone
just reply a “503 Service Unavailable”.
- tmpl/sunstone-server.conf: do not disable OneFlow route.
Ref: #22068
Historique
#1 Mis à jour par Thierry Bertrand il y a presque 9 ans
- Projet changé de Distribution EOLE à EOLE OpenNebula
- Sujet changé de une erreur récurrente apparait dans les logs de sunstone De plus, à la connexion d'un utilisateur, une popup roouge apparait à une erreur récurrente apparait dans les logs de sunstoneDe plus, à la connexion d'un utilisateur, une popup roouge apparait
Log de sunstone :
Tue Nov 14 10:45:38 2017 [I]: 172.26.46.249 - - [14/Nov/2017:10:45:38 +0100] "GET /support/request?timeout=false&pool_filter=-2&csrftoken=ebdc41a78a9e5364ee09d1d838beeb28 HTTP/1.1" 500 - 0.0026 Tue Nov 14 10:45:48 2017 [I]: 172.26.46.249 - - [14/Nov/2017:10:45:48 +0100] "GET /support/request?timeout=false&pool_filter=-2&csrftoken=ebdc41a78a9e5364ee09d1d838beeb28 HTTP/1.1" 500 - 0.0024 Tue Nov 14 10:45:58 2017 [I]: 172.26.46.249 - - [14/Nov/2017:10:45:58 +0100] "GET /support/request?timeout=false&pool_filter=-2&csrftoken=ebdc41a78a9e5364ee09d1d838beeb28 HTTP/1.1" 500 - 0.0013 Tue Nov 14 10:46:08 2017 [I]: 172.26.46.249 - - [14/Nov/2017:10:46:08 +0100] "GET /support/request?timeout=false&pool_filter=-2&csrftoken=ebdc41a78a9e5364ee09d1d838beeb28 HTTP/1.1" 500 - 0.0019
Message d'erreur popup :
Error: service resource not supported
#2 Mis à jour par Daniel Dehennin il y a presque 9 ans
- Statut changé de Nouveau à En cours
- Assigné à mis à Daniel Dehennin
- Temps estimé mis à 3.00 h
- Restant à faire (heures) mis à 3.0
Les deux sont dissociés mais lié à la gestion des vues :
- Le message d’erreur 500 sur
/requestvient de l’ongletSupport, l’interface tente de se connecter sur le service de support d’OpenNebula ⮕ la solution est de désactiver le support dans les vuesadmin* - La popup d’erreur vient du fait que l’interface cloud fait toujours une requête sur le service OneFlow
/servicemais que l’on désactive cette route Sunstone en même temps que le service OneFlow ⮕ la solution est de ne jamais désactivre la route oneflow dans la configuration du serveur Sunstone, dans ce cas le backend Sunstone renvoie un code503 Service Unavailablequi ne génère aucune popup
#3 Mis à jour par Daniel Dehennin il y a presque 9 ans
- Restant à faire (heures) changé de 3.0 à 2.5
#4 Mis à jour par Daniel Dehennin il y a presque 9 ans
- % réalisé changé de 0 à 100
- Restant à faire (heures) changé de 2.5 à 0.5
Nouveau paquet eole-one-frontend 2.6.2-3 dans eole-2.6-unstable.
#5 Mis à jour par Scrum Master il y a presque 9 ans
- Projet changé de EOLE OpenNebula à Distribution EOLE
- Statut changé de En cours à Résolu
#6 Mis à jour par Gérald Schwartzmann il y a presque 9 ans
- Sujet changé de une erreur récurrente apparait dans les logs de sunstoneDe plus, à la connexion d'un utilisateur, une popup roouge apparait à une erreur récurrente apparait dans les logs de sunstone. De plus, à la connexion d'un utilisateur, une popup rouge apparait
#7 Mis à jour par Gérald Schwartzmann il y a presque 9 ans
Thierry peux-tu vérifier si le paquet corrige le problème, merci d'avance.
#8 Mis à jour par Thierry Bertrand il y a presque 9 ans
- Statut changé de Résolu à Fermé
- Restant à faire (heures) changé de 0.5 à 0.0
il n'y a plus d'erreur dans le susnstone, ni dans les logs