Project

General

Profile

Tâche #19601

Scénario #19382: Traitement express MEN (10-12)

Haute dispo : erreur à l'instance si on répond "non" à la question : ". Problème à corriger à partir de 2.4.0

Added by Fabrice Barconnière over 2 years ago. Updated over 2 years ago.

Status:
Fermé
Priority:
Normal
Start date:
01/27/2017
Due date:
% Done:

100%

Estimated time:
2.00 h
Spent time:
Remaining (hours):
0.0

Description

Si on répond non à la question on obtient un code retour 1, le script sort avec ce code retour ce qui interrompt l'intance avec une erreur :

run-parts: executing /usr/share/eole/postservice/00-haute-dispo instance
Attente démarrage corosync.
Attente démarrage pacemaker.
Attente noeud Online...........
WARNING: VIPCluster_on_slave: referenced node sphynxb does not exist
WARNING: arv_rsc: default timeout 20s for stop is smaller than the advised 100
WARNING: arv_rsc: specified timeout 30s for monitor is smaller than the advised 100
WARNING: gw_pingd: default timeout 20s for start is smaller than the advised 60
WARNING: gw_pingd: specified timeout 5s for monitor is smaller than the advised 60
WARNING: ipsec_rsc: default timeout 20s for stop is smaller than the advised 100
WARNING: ipsec_rsc: specified timeout 30s for monitor is smaller than the advised 100
Attente ressources montées.
Migration de la ressource VIPCluster sur sphynx.
Les serveurs maître et esclave doivent pouvoir dialoguer en ssh sur l'interface 2
Voulez-vous synchroniser les noeuds ? [oui/non]
[non] : 
Pour forcer la synchronisation, vous pouvez lancer le script 'synchro-nodes.sh' manuellement une fois les deux noeuds 'Online'
Vous pouvez vérifier leur status à l'aide de la commande 'crm_mon -1'
run-parts: /usr/share/eole/postservice/00-haute-dispo exited with return code 1
Erreur : postservice

Associated revisions

Revision c2e68427 (diff)
Added by Fabrice Barconnière over 2 years ago

L'instance s'interrompait avec une erreur en répondant non pour ne pas synchroniser les nœuds

ref #19601 @15m

History

#1 Updated by Fabrice Barconnière over 2 years ago

  • Status changed from Nouveau to En cours

#2 Updated by Fabrice Barconnière over 2 years ago

  • Subject changed from Haute dispo : erreur à l'instance si on répond "non" à la question : " Problème à corriger à partir de 2.4.0 to Haute dispo : erreur à l'instance si on répond "non" à la question : "Problème à corriger à partir de 2.4.0
  • Status changed from En cours to Résolu
  • % Done changed from 0 to 100

Corrigé en 2.4.0, 2.4.1, 2.4.2 (même paquet que 2.4.1), 2.5.1, 2.5.2, 2.6.0 et 2.6.1.
Journaux complétés pour ces versions en mise à jour en préparation.

#3 Updated by Fabrice Barconnière over 2 years ago

  • Subject changed from Haute dispo : erreur à l'instance si on répond "non" à la question : "Problème à corriger à partir de 2.4.0 to Haute dispo : erreur à l'instance si on répond "non" à la question : ". Problème à corriger à partir de 2.4.0

#4 Updated by Fabrice Barconnière over 2 years ago

  • Remaining (hours) changed from 2.0 to 0.5

#5 Updated by Fabrice Barconnière over 2 years ago

  • Assigned To deleted (Fabrice Barconnière)

#6 Updated by Daniel Dehennin over 2 years ago

  • Assigned To set to Fabrice Barconnière

#7 Updated by Klaas TJEBBES over 2 years ago

  • Status changed from Résolu to Fermé
  • Remaining (hours) changed from 0.5 to 0.0

2.4.2
2.5.2
2.6.1b4
OKs

Also available in: Atom PDF