Project

General

Profile

Tâche #17607

Scénario #17541: Publier la version EOLE 2.6.0 RC

Le paquet libpam-script (tiré par gaspacho-agent) fait planter l'installation du module Eclair

Added by Joël Cuissinat over 3 years ago. Updated over 3 years ago.

Status:
Fermé
Priority:
Normal
Assigned To:
Start date:
10/18/2016
Due date:
% Done:

100%

Estimated time:
2.00 h
Spent time:
Remaining (hours):
0.0

Description

<_l0l0_> le paquet libpam-script ajoute une ligne dans /etc/pam.d/common-password qui empeche l'installeur de mettre le mot de passe

Correction rapide : enlever la dépendance dans eole-eclair-all, le paquet s'installera malgré tout à l'instance car la balise suivante est toujours dans le dictionnaire : 21_gaspacho-agent.xml

            <package>gaspacho-agent</package>

Dans target/etc/pam.d/common-password:
password sufficent pam_script.so

sans cette ligne l'installation se poursuit sans problème

A l'installation au moment de changer le mot de passe root, l'opération échoue avec l'erreur:

cannot stat /usr/share/libpam-script/pam-script-password


Related issues

Related to Distribution EOLE - Scénario #17652: Faire en sorte que l'agent Gaspacho soit installé depuis l'ISO sur Eclair Terminé (Sprint) 11/28/2016 02/10/2017
Related to Eclair - Tâche #21086: eole-gaspacho-agent n'est pas pré-installé sur Eclair >= 2.6.1 Fermé 07/25/2017
Related to Eclair - Tâche #21180: Ne pas pré-installer gaspacho-agent Fermé 07/18/2017

Associated revisions

Revision 7e6f80bd (diff)
Added by Joël Cuissinat over 3 years ago

Suppression de la dépendance sur gaspacho-agent à l'installation

Ref: #17607 @30m

History

#1 Updated by Laurent Flori over 3 years ago

  • Description updated (diff)

#2 Updated by Joël Cuissinat over 3 years ago

  • Status changed from En cours to Résolu

#3 Updated by Joël Cuissinat over 3 years ago

  • % Done changed from 0 to 100
  • Remaining (hours) changed from 2.0 to 0.25

#4 Updated by Joël Cuissinat over 3 years ago

  • Status changed from Résolu to Fermé
  • Remaining (hours) changed from 0.25 to 0.0

Le module 2.6.0 s'installe et les paquets "manquants" sont ajoutés à l'instance.

#5 Updated by Daniel Dehennin almost 3 years ago

  • Related to Tâche #21086: eole-gaspacho-agent n'est pas pré-installé sur Eclair >= 2.6.1 added

#6 Updated by Daniel Dehennin almost 3 years ago

  • Related to Tâche #21180: Ne pas pré-installer gaspacho-agent added

Also available in: Atom PDF