Project

General

Profile

Anomalie #1631

posh ( envole 2.0) ne marche pas avec IE 9

Added by jean-francois bados about 13 years ago. Updated over 12 years ago.

Status:
Fermé
Priority:
Normal
Assigned To:
Start date:
04/05/2011
Due date:
% Done:

100%

Estimated time:
1.00 h
Spent time:
Distribution:

Description

détecté par jean-marc Lehoux .
la correction qui semble marcher ( et qui marche sur le cel du rectorat depuis ce matin)ci dessous.

Envole sous IE9 n est pas compatble a cause de la librairie mootols.js
si on prend le fichier http://mootools.net/download/get/mootools-1.2.5-core-yc.js et qu on le mets a la place de /var/www/html/posh/tools/mootools.js ca marche.
Qui et comment intégrer ce correctif ?

PS: on verifié que cela fonctionait aussi avec les autres navigateurs.


Related issues

Related to Sources posh EOLE 2.2 - Anomalie #1775: Problemes de chargement des pages sous IE Fermé 05/16/2011

Associated revisions

Revision feaa757f (diff)
Added by Joël Cuissinat over 12 years ago

utilisation de mootools-core-1.4.0-full-compat-yc.js (fixes #1631)

History

#1 Updated by Joël Cuissinat almost 13 years ago

  • Project changed from Envole to eole-posh
  • Status changed from Nouveau to Accepté

#2 Updated by Joël Cuissinat almost 13 years ago

  • Target version set to Envole 2.5.1 RC

#3 Updated by Joël Cuissinat over 12 years ago

  • Status changed from Accepté to Résolu
  • Assigned To set to Joël Cuissinat
  • Target version changed from Envole 2.5.1 RC to Rentrée2011 RC
  • % Done changed from 0 to 100
  • Estimated time set to 1.00 h

Paquet candidat : portaneo_2.2.4-eole15

#4 Updated by Christophe Deseure over 12 years ago

La librairie fournie pour la version 1.3.2 est incomplète.
Il manque par exemple la méthode "getHeight" utilisée par posh qui rend inutilisable le bureau car l'Iframe n'est pas redimensionnée.

Voici les composants de la librairie installée :
- packager build Core/Core Core/Element Core/Element.Style Core/Request Core/Request.HTML Core/Request.JSON Core/Cookie Core/DOMReady

Voici les composants de la libraiire plus complète :
- packager build Core/Core Core/Array Core/String Core/Number Core/Function Core/Object Core/Event Core/Browser Core/Class Core/Class.Extras Core/Slick.Parser Core/Slick.Finder Core/Element Core/Element.Style Core/Element.Event Core/Element.Dimensions Core/Fx Core/Fx.CSS Core/Fx.Tween Core/Fx.Morph Core/Fx.Transitions Core/Request Core/Request.HTML Core/Request.JSON Core/Cookie Core/JSON Core/DOMReady Core/Swiff

Sans savoir ce qu'utilise Posh, il vaut mieux je pense être exhaustif sur le sujet.
Il est peut-être aussi intéressant de profiter de la version 1.4.0.

Je propose donc d'utiliser le fichier "MooTools Core 1.4.0 with compatibility" : http://mootools.net/download/get/mootools-core-1.4.0-full-compat-yc.js

#5 Updated by Joël Cuissinat over 12 years ago

  • Status changed from Résolu to Fermé

=> portaneo 1:2.2.4-eole17

#6 Updated by Joël Cuissinat over 12 years ago

  • Project changed from eole-posh to Sources posh EOLE 2.2

Also available in: Atom PDF