Project

General

Profile

Anomalie #1775

Problemes de chargement des pages sous IE

Added by Benoit Vila about 13 years ago. Updated over 12 years ago.

Status:
Fermé
Priority:
Normal
Assigned To:
-
Start date:
05/16/2011
Due date:
% Done:

100%

Distribution:

Description

Des problèmes ont été observés sous IE, des pages ne se chargent pas (page blanche) avec des différences de comportement entre l'application en onglet Envole et l'application en onglet IE.


Related issues

Related to Sources posh EOLE 2.2 - Anomalie #1631: posh ( envole 2.0) ne marche pas avec IE 9 Fermé 04/05/2011

Associated revisions

Revision 6dde13c8 (diff)
Added by Joël Cuissinat over 12 years ago

application du sed pour IE (fixes #1775)

History

#1 Updated by Benoit Vila about 13 years ago

proposition d'ajouter un message au niveau de la mire SSO précisant que des problèmes peuvent être rencontrés sous IE (mais pas sous firefox)

étudier également les réglages de sécurité d'IE qui pourraient être à l'origine de ces problèmes

#2 Updated by Francis Bordes about 13 years ago

Benoit Vila a écrit :

Des problèmes ont été observés sous IE, des pages ne se chargent pas (page blanche) avec des différences de comportement entre l'application en onglet Envole et l'application en onglet IE.

IE9 32/64bits bits sans paramètrages page blanche après connexion
IE8 64 bits sans paramètrages page blanche après connexion

#3 Updated by Benoit Vila about 13 years ago

Francis Bordes a écrit :

IE9 32/64bits bits sans paramètrages page blanche après connexion
IE8 64 bits sans paramètrages page blanche après connexion

c'est tout envole/posh qui ne se charge pas, juste après le SSO ? c'est pas une page particulière ?

#4 Updated by Francis Bordes about 13 years ago

c'est tout envole/posh qui ne se charge pas, juste après le SSO !

J'ai testé en changeant les paramètres de sécurité, tout a bien fonctionné mais je reteste ce soir sur une autre machine.

A essayer: en allant dans option internet/sécurité/personnaliser le niveau et cocher Activé pour la rubrique : afficher un contenu mixte

#5 Updated by Benoit Vila about 13 years ago

solutions proposées :

  • rajouter un message d'alerte sur la mire sso entre la mire et le message de la CNIL

ce message est intégré à la page il n'est pas dans une pop-up et ne s'affiche que pour les utilisateurs d'IE (toutes version)

ce message contient un lien qui renvoie sur une page HTML expliquant la procédure pour autoriser les contenus mixtes dans IE (8 et 9)

cette page web possèdera un lien vers la même doc au format PDF (pour faciliter l'impression et la diffusion)

cette solution utilisera le paquet envole-infos (justement prévu pour diffuser de la documentation facilement accessible, relative au portail Envole)

  • les entêtes html des pages de posh seront modifié pour forcer l'affichage de compatibilité (pour IE 8 et 9)

cette solution fait disparaitre l’icône de compatibilité dans la barre d'adresse d'IE et permet l'affichage automatique des pages sans intervention de l'utilisateur ni alerte

ces modifications seront soit intégrées dans la version Envole 2.0-5 RC en cours de test soit dans une version ultérieure

Francis Bordes se charge de rédiger la documentation et le message d'alerte, revues pas Christelle Le Moine.
Benoit Vila se charge de le conversion de la doc au format HTML, de l’intégration de la page et de la doc dans le paquet envole-infos, et de l’intégration de l'alerte dans la mire SSO avec Bruno Boiget ainsi que de la modification des pages du portail posh pour forcer l'affichage de compatibilité.

#6 Updated by Benoit Vila almost 13 years ago

  • Target version set to Envole pour Eole-2.3 RC 1

#7 Updated by Benoit Vila almost 13 years ago

  • Project changed from Envole to eole-posh

#8 Updated by Joël Cuissinat almost 13 years ago

  • Status changed from Nouveau to En attente d'informations
  • Target version changed from Envole pour Eole-2.3 RC 1 to Mises à jour 2.3 - 02 RC

#9 Updated by Joël Cuissinat almost 13 years ago

  • Target version changed from Mises à jour 2.3 - 02 RC to Envole pour Eole-2.3 RC 2

#10 Updated by Joël Cuissinat over 12 years ago

  • Status changed from En attente d'informations to Résolu
  • Target version changed from Envole pour Eole-2.3 RC 2 to Envole 2.5.1 RC

En-têtes modifiés dans le paquet de développement : portaneo 2.2.4-eole14

#11 Updated by Joël Cuissinat over 12 years ago

  • % Done changed from 0 to 100

#12 Updated by Benoit Vila over 12 years ago

  • % Done changed from 100 to 50

ajout du lien "Informations pour les utilisateurs d'Internet Explorer" sur la mire sso (paquet eole-sso)

ajout de la page informations_ie.php dans envoles-infos (la page doit être completée)

ajout des headers de compatibilité dans portaneo et eole-posh( répertoires plugins et posh-eole-files)

for ff in $(grep -ril "<meta" *) ; do sed -ri "s/<meta[^>]*charset[^>]*>/&\r\n<meta http-equiv=\"X-UA-Compatible\" content=\"IE=EmulateIE7\" \/>/gI" ${ff} ; done

-> voir si il est nécessaire de faire ces opérations en 2.3 (posh 3.1 pourrait ne pas rencontrer le problème de compatibilité mais les informations de certificats et contenus mixte peuvent rester utiles)

#13 Updated by Joël Cuissinat over 12 years ago

  • Target version changed from Envole 2.5.1 RC to Rentrée2011 RC

#14 Updated by Joël Cuissinat over 12 years ago

  • Status changed from Résolu to Fermé
  • % Done changed from 50 to 100

Je n'ai pas de quoi tester mais je fais confiance aux utilisateurs ;)

#15 Updated by Joël Cuissinat over 12 years ago

  • Project changed from eole-posh to Sources posh EOLE 2.2

Also available in: Atom PDF