Project

General

Profile

Tâche #15047

creole - Scénario #14934: Migration Amonecole 2.3 vers 2.4 : Problème Upgrade-Auto

Impossible d’installer eole-lxc-controller

Added by Daniel Dehennin almost 7 years ago. Updated almost 7 years ago.

Status:
Fermé
Priority:
Normal
Assigned To:
Start date:
02/16/2016
Due date:
% Done:

100%

Estimated time:
2.00 h
Spent time:
Remaining (hours):
0.0

Description

Lors de la migration d’un amonecole 2.3 vers 2.4, il est possible que le profile apparmor de LXC ne soit pas chargé.

Dans ce cas la commande « apparmor_parser -R » retourne un code d’erreur « 1 » ce qui plante le postinst du paquet:

Paramétrage de eole-lxc-controller (2.4.2~1-21) ...
apparmor_parser : impossible de supprimer "/usr/bin/lxc-start".  Profil inexistant
dpkg : erreur de traitement de eole-lxc-controller (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 234

Associated revisions

Revision 8a61259e (diff)
Added by Daniel Dehennin almost 7 years ago

Ne pas faire d’erreur sur la désativation apparmor

Lors de la migration d’un amonecole 2.3 vers 2.4, il est possible que le
profile apparmor de LXC ne soit pas chargé.

Dans ce cas la commande « apparmor_parser -R » retourne un code d’erreur
« 1 » ce qui plante le postinst du paquet:

Paramétrage de eole-lxc-controller (2.4.2~1-21) ...
apparmor_parser : impossible de supprimer "/usr/bin/lxc-start".
Profil inexistant
dpkg : erreur de traitement de eole-lxc-controller (--configure) :
le sous-processus script post-installation installé a retourné une
erreur de sortie d'état 234
  • debian/eole-lxc-controller.postinst: Pas d’erreur sur
    « apparmor_parser -R ».

Ref: #15047

Revision 025477aa (diff)
Added by Daniel Dehennin almost 7 years ago

Ne pas faire d’erreur sur la désativation apparmor

Lors de la migration d’un amonecole 2.3 vers 2.4, il est possible que le
profile apparmor de LXC ne soit pas chargé.

Dans ce cas la commande « apparmor_parser -R » retourne un code d’erreur
« 1 » ce qui plante le postinst du paquet:

Paramétrage de eole-lxc-controller (2.4.2~1-21) ...
apparmor_parser : impossible de supprimer "/usr/bin/lxc-start".
Profil inexistant
dpkg : erreur de traitement de eole-lxc-controller (--configure) :
le sous-processus script post-installation installé a retourné une
erreur de sortie d'état 234
  • debian/eole-lxc-controller.postinst: Pas d’erreur sur
    « apparmor_parser -R ».

Cherry picked from 8a61259e0f06bdb1a0b3e6958dc58e91d946536c

Ref: #15047

History

#1 Updated by Daniel Dehennin almost 7 years ago

  • Project changed from creole to eole-common

#2 Updated by Daniel Dehennin almost 7 years ago

  • % Done changed from 0 to 100
  • Remaining (hours) changed from 2.0 to 0.25

Paquets:

  • 2.4.1-88
  • 2.4.2_1-22

Journaux mis à jour.

#3 Updated by Daniel Dehennin almost 7 years ago

  • Assigned To set to Daniel Dehennin

#4 Updated by Scrum Master almost 7 years ago

  • Status changed from Nouveau to En cours

#5 Updated by Scrum Master almost 7 years ago

  • Status changed from En cours to Résolu

#6 Updated by Philippe Caseiro almost 7 years ago

L'UpgradeAuto de 2.3.15 vers 2.4.1 ne fonctionne pas car il n'arrive pas a installer eole-amonecole-module.

Si on remonte la rivère des dépendances on tombe sur un problème d'installation de eole-exim-pkg

#7 Updated by Scrum Master almost 7 years ago

  • Status changed from Résolu to Fermé
  • Remaining (hours) changed from 0.25 to 0.0

Also available in: Atom PDF