Project

General

Profile

Tâche #10786

Scénario #10752: Assistance aux utilisateurs (11-13)

ARV : rechargement de variables muti-évaluées

Added by Karim Ayari over 7 years ago. Updated over 7 years ago.

Status:
Fermé
Priority:
Normal
Target version:
Start date:
03/05/2015
Due date:
% Done:

100%

Estimated time:
3.00 h
Spent time:
Remaining (hours):
0.0

Description

Il semblerait que le rechargement des valeurs à partir du modèle ne fonctionne pas pour les variables multi.

Sphynx 2.3 stable et à jour.
ARV Version: 2.3-eole54

j'ai créé un modèle de réseau basé sur 2 variables suivantes :

adresse_network_vlan_eth3[0] 
adresse_netmask_vlan_eth3[0]

- je me rend ensuite sur la page serveurs rvp
- je sélectionne un serveur et clique sur modifier
- je vois tous les réseaux ainsi que le dernier créé qui a des valeurs vides (ce qui est normal)
- je clique sur recharger les valeurs du modèle..cela mouline (Chargement s'affiche en bas de page...) et puis rien, les valeurs sont toujours vides.

côté serveur ARV j'ai ceci dans le log arv.log :

2015/03/05 11:25:50 CET [HTTPChannel,153,172.29.145.149] get_tmpl_vertices
2015/03/05 11:25:50 CET [HTTPChannel,153,172.29.145.149] <arv.web.childpage.GetTmplVertices instance at 0x25b8248>

mais rien dans error.log

pour m'assurer que la fonctionnalité fonctionne bien :

- j'ai modifié mon nouveau réseau avec les même variables mais cette fois-ci sans l'indice de position :

adresse_network_vlan_eth3
adresse_netmask_vlan_eth3

- j'ai refait la même procédure et ce coup-ci il affiche bien le contenu complet des variable :

192.168.221.0|...|...

ce qui me fait dire qu'il y a un soucis avec les variables multi.

Associated revisions

Revision c328b398 (diff)
Added by Fabrice Barconnière over 7 years ago

arv/lib/usezephir.py : chargement valeurs Zéphir des variables multi OK

fixes #10786 @5h

Revision 97c8df11 (diff)
Added by Fabrice Barconnière over 7 years ago

arv/lib/usezephir.py : chargement valeurs Zéphir des variables multi OK

fixes #10786 @5h

Revision e4316469 (diff)
Added by Fabrice Barconnière over 7 years ago

arv/lib/usezephir.py : chargement valeurs Zéphir des variables multi OK

fixes #10786 @5h

Revision 3e89deec (diff)
Added by Daniel Dehennin over 7 years ago

arv/lib/usezephir.py : chargement valeurs Zéphir des variables multi OK

(cherry-picked from commit:97c8df117c9ea803dfadffa253afaa8fb92deb25)

Ref: #10786

History

#1 Updated by Fabrice Barconnière over 7 years ago

  • Tracker changed from Anomalie to Tâche
  • Estimated time set to 3.00 h
  • Parent task set to #10752
  • Remaining (hours) set to 3.0

Problème reproduit sur un Sphynx 2.4.1

#2 Updated by Fabrice Barconnière over 7 years ago

  • Status changed from Nouveau to En cours

#3 Updated by Fabrice Barconnière over 7 years ago

  • Assigned To set to Fabrice Barconnière

#4 Updated by Karim Ayari over 7 years ago

merci pour ce correctif rapide :)..
je viens de tester cela fonctionne ! j'ai même recréé un modèle de réseau en changeant le numéro d'indice, il a bien récupéré la bonne valeur.

juste pour info si rien n'est renseigné sur zéphir par défaut il affiche seulement le masque de sous-réseau en 255.255.255.0.

#5 Updated by Fabrice Barconnière over 7 years ago

  • Status changed from En cours to Résolu
  • % Done changed from 0 to 100

#6 Updated by Fabrice Barconnière over 7 years ago

  • Remaining (hours) changed from 3.0 to 0.1

#7 Updated by Fabrice Barconnière over 7 years ago

  • Status changed from Résolu to En cours

#8 Updated by Fabrice Barconnière over 7 years ago

  • Remaining (hours) changed from 0.1 to 0.5

#9 Updated by Fabrice Barconnière over 7 years ago

  • Status changed from En cours to Résolu

#10 Updated by Fabrice Barconnière over 7 years ago

  • Remaining (hours) changed from 0.5 to 0.1

#11 Updated by Fabrice Barconnière over 7 years ago

  • Status changed from Résolu to Fermé
  • Remaining (hours) changed from 0.1 to 0.0

Merci pour le test Karim.
"si rien n'est renseigné sur zéphir par défaut il affiche seulement le masque de sous-réseau en 255.255.255.0" car c'est la valeur par défaut dans le dictionnaire. C'est donc un comportement normal.

Also available in: Atom PDF