Projet

Général

Profil

Mise à jour EOLE 2.4 et 2.5 et nouvelle image ISO 2.5.2.2

Un nouveau test diagnose et un nouvel agent Zéphir permet de connaître l’état de maintenance du noyau. Une nouvelle image ISO 2.5.2.2 utilise le dernier noyau Xenial Xerus pour Trusty Tahr.
Ajouté par Daniel Dehennin il y a 5 mois

Depuis la version Lucid Lynx, Ubuntu a mis en place la politique « LTS Enablement Stacks » appelé aussi HWE (Hardware Enablement).

Cela permet aux publications intermédiaires « point releases (12.04.1, 12.04.2, …) » de supporter du matériel plus récent en intégrant un rétroportage des noyaux des versions non LTS à l’image ISO d’installation et ce jusqu’à l’apparition de la « point release .5 », qui elle, fournie le noyau de la version LTS suivante.

Ces noyaux intermédiaires sont aussi ceux sélectionnés automatiquement lors d’une migration d’une version plus ancienne, chez EOLE la présence d'un noyau intermédiaire vient d’un Upgrade-Auto depuis la version 2.3.

Le problème de ces noyaux intermédiaires c'est qu'il ne sont jamais migrés vers une version supérieure pour éviter de modifier l'état de la machine lors d’une mise à jour, en effet un noyau plus récent pourrait mal supporter un type donné de matériel.

Or ces noyaux intermédiaires ne sont pas des noyaux LTS (malgré la présence du mot lts dans le nom du paquet), leur durée de support est bien inférieur à ceux dit LTS, il est donc possible d'avoir des serveurs avec un noyau qui n'est plus maintenu !

Depuis la version 16.04, Ubuntu a corrigé ce fonctionnement, les images ISO d’installation, y compris les versions intermédiaires, n’installe plus que la version LTS du noyau (celui publié à la version de la 16.04.0), c’est à l’administrateur d’installer des versions plus récentes si le besoin se fait sentir.

Nous avons généré une nouvelle image ISO 2.5.2.2 qui est livrée avec un noyau maintenu pour toute la durée de vie de la version 2.5.

Pour déterminer si le noyau de vos serveurs est maintenu par Ubuntu, nous fournissons deux outils de diagnostique :

Si votre noyau n’est plus maintenu, les outils vous indiquent quel paquet installer afin de migrer vers un noyau maintenu par Ubuntu :


Commentaires