Tâche #37503
Mis à jour par Klaas TJEBBES il y a 3 mois
Vérifier que Upower sert à quelque chose et le supprimer s'il ne sert à rien.
Problème rencontré suite à la mise en place d'un contournement pour DirtyFrag :
<pre>
cat /etc/sysctl.d/99-eole-dirtyfrag.conf
user.max_user_namespaces=0
</pre>
<pre>
root@amon:~# systemctl restart upower.service
Job for upower.service failed because the control process exited with error code.
See "systemctl status upower.service" and "journalctl -xeu upower.service" for details.
</pre>
<pre>
root@amon:~# tail log/syslog
2026-06-12T11:45:05.868230+02:00 amon.etb1.lan systemd[1]: Failed to start upower.service - Daemon for power management.
2026-06-12T11:45:06.198841+02:00 amon.etb1.lan (upowerd)[307106]: upower.service: Failed to set up user namespacing: No space left on device
2026-06-12T11:45:06.200804+02:00 amon.etb1.lan systemd[1]: Failed to start upower.service - Daemon for power management.
2026-06-12T11:45:06.454164+02:00 amon.etb1.lan (upowerd)[307112]: upower.service: Failed to set up user namespacing: No space left on device
2026-06-12T11:45:06.456834+02:00 amon.etb1.lan systemd[1]: Failed to start upower.service - Daemon for power management.
2026-06-12T11:45:06.691519+02:00 amon.etb1.lan (upowerd)[307117]: upower.service: Failed to set up user namespacing: No space left on device
2026-06-12T11:45:06.693684+02:00 amon.etb1.lan systemd[1]: Failed to start upower.service - Daemon for power management.
2026-06-12T11:45:06.945037+02:00 amon.etb1.lan (upowerd)[307122]: upower.service: Failed to set up user namespacing: No space left on device
2026-06-12T11:45:06.947243+02:00 amon.etb1.lan systemd[1]: Failed to start upower.service - Daemon for power management.
2026-06-12T11:45:07.171053+02:00 amon.etb1.lan systemd[1]: Failed to start upower.service - Daemon for power management.
</pre>
_"Failed to set up user namespacing: No space left on device"_ vient du fait que _"user.max_user_namespaces=0"_.
Ça génère des erreurs dans le diagnose et donc envoie des alertes Zéphir.
Problème rencontré suite à la mise en place d'un contournement pour DirtyFrag :
<pre>
cat /etc/sysctl.d/99-eole-dirtyfrag.conf
user.max_user_namespaces=0
</pre>
<pre>
root@amon:~# systemctl restart upower.service
Job for upower.service failed because the control process exited with error code.
See "systemctl status upower.service" and "journalctl -xeu upower.service" for details.
</pre>
<pre>
root@amon:~# tail log/syslog
2026-06-12T11:45:05.868230+02:00 amon.etb1.lan systemd[1]: Failed to start upower.service - Daemon for power management.
2026-06-12T11:45:06.198841+02:00 amon.etb1.lan (upowerd)[307106]: upower.service: Failed to set up user namespacing: No space left on device
2026-06-12T11:45:06.200804+02:00 amon.etb1.lan systemd[1]: Failed to start upower.service - Daemon for power management.
2026-06-12T11:45:06.454164+02:00 amon.etb1.lan (upowerd)[307112]: upower.service: Failed to set up user namespacing: No space left on device
2026-06-12T11:45:06.456834+02:00 amon.etb1.lan systemd[1]: Failed to start upower.service - Daemon for power management.
2026-06-12T11:45:06.691519+02:00 amon.etb1.lan (upowerd)[307117]: upower.service: Failed to set up user namespacing: No space left on device
2026-06-12T11:45:06.693684+02:00 amon.etb1.lan systemd[1]: Failed to start upower.service - Daemon for power management.
2026-06-12T11:45:06.945037+02:00 amon.etb1.lan (upowerd)[307122]: upower.service: Failed to set up user namespacing: No space left on device
2026-06-12T11:45:06.947243+02:00 amon.etb1.lan systemd[1]: Failed to start upower.service - Daemon for power management.
2026-06-12T11:45:07.171053+02:00 amon.etb1.lan systemd[1]: Failed to start upower.service - Daemon for power management.
</pre>
_"Failed to set up user namespacing: No space left on device"_ vient du fait que _"user.max_user_namespaces=0"_.
Ça génère des erreurs dans le diagnose et donc envoie des alertes Zéphir.