Project

General

Profile

Tâche #9392

Scénario #9369: Qualification 2.3.15 des modules MEDDE

Qualification de l'eCDL

Added by Emmanuel IHRY over 6 years ago. Updated over 6 years ago.

Status:
Fermé
Priority:
Normal
Assigned To:
Target version:
Start date:
10/27/2014
Due date:
% Done:

100%

Estimated time:
6.00 h
Spent time:
Remaining (hours):
0.0

Description

- Mise à jour de 2.3.13 vers 2.3.15
- nouvelle Installation


Related issues

Blocked by eCDL - Tâche #9509: instanciation eCDL impossible en raison du cache DNS Fermé 11/06/2014

Associated revisions

Revision 5d70066f (diff)
Added by christophe guerinot over 6 years ago

ldap.conf: en 'mode mixte' il est toujours nécessaire de suivre les alias ( ref #9392 @0.30 ).

  • posttemplate/01-ecdlfichier: la variable creole adresse_ip_ldap_distant est plutôt utilisée. Cela permet d'instancier le serveur même si la variable adresse_ip_ldap est mal renseignée

History

#1 Updated by Emmanuel IHRY over 6 years ago

  • Description updated (diff)
  • Estimated time set to 6.00 h
  • Remaining (hours) set to 6.0

#2 Updated by Emmanuel IHRY over 6 years ago

  • Assigned To changed from Michel BALLY to Alain Guichard

#3 Updated by Emmanuel IHRY over 6 years ago

  • Status changed from Nouveau to En cours

#4 Updated by Emmanuel IHRY over 6 years ago

PN constatés le 29/10 :

Sur un serveur 2.3.13 migré 2.3.15 sur zéphirng n° 1543 et sur une VM installée en natif 2.3.15 avec liso du 24/10 et une conf "propre" sur zephir dev n° 5191

*getent passwd
ne remonte pas les comptes LDAP du service, que les comptes local.xxx, ok pour les comptes approuvés
*getent group
à priori OK sur groupes LDAP et domaine approuvé
*exxl_diagnostic
rencontré de manière aléatoire des erreurs sur relations approbation et propriétés compte admin.domaine
*privilege.sh
erreur "Could not connect to server 127.0.0.1
The username or password was not correct.
Connection failed: NT_STATUS_LOGON_FAILURE"

  • le serveur est bien en mode distant mixte, y a-t-il un reste de paramétrage de proxy LDAP??
  • impossible d'intégrer une machine dans le domaine avec compte admin.domaine (semble normal avec pb privilege ci-dessus), par contre OK avec un compte local ajouté au groupe AdminDomain

#5 Updated by Emmanuel IHRY over 6 years ago

  • % Done changed from 0 to 20

Vu avec Christophe :

- manque valeur par défaut pour la variable adresse_ip_ldap_distant dans onglet proxyldap (activer au préalable le mode distant dans service). Erreur à priori de dictionnaire sur le zephir de DEV et dans l'iso utilisée (la prochaine iso ne devrait pas poser de pb)

- pb de perte de configuration réseau due à la nécessité de saisir les paramètres 'configuration réseau minimum' --> pas un bug : fiche technique à créer

- faut il mettre à jour le script 01-ecdlfichier qui n'utilise pas la variable adresse_ip_ldap_distant ??? mais en mode mixte cette variable a par défaut la même valeur que adresse_ip_ldap --> donc en principe ne doit pas poser de pb

- pb dans smb.conf : passdb backend = ldapsam:"ldaps://127.0.0.1:636 ldap://localhost" --> parce-que qu'on est passe un moment dans le zephir en mode proxy
pb quand on passe du distant au proxy celà met 127.0.0.1, mais le retour arrière n'est pas implémenté
Dans ce cas remodifier la valeur de la variable adresse_ip_ldap en saisissant l'adresse des serveur ldap smb

#6 Updated by Alain Guichard over 6 years ago

1) Création configuration eCDL sur zephir-dev.supervision.i2 / n°identifiant : 5196 (@ip : 172.20.44.118 / domaine ddt-101)
Remarque: les mêmes tests indiqués ci-dessous ont également été faits avec une configuration créée sur zephir-ng.eole.i2 / n°identifiant : 3998

2) Installation sur serveur physique
- Installation 2.3.9
- Upgrade en 2.3.13 (Maj-Auto sur debmiroir-02) 36 paquets installés
- Upgrade en 2.3.15 (Maj-Auto -C sur debmiroir-02) 30 paquets installés

3) Constatations

Vérification
La variable "adresse_ip_ldap_distant" est renseignée sur le zephir (elle n'est pas dans le config.eol)

Que ce soit en 2.3.9 ou en 2.3.13, tests positifs pour :
- exxl_diagnostic
- getent passwd
- getent group
- intégration esbl
- intégration poste client XP, acces partage sur esbl
=> le serveur est OK

Après upgrade en 2.3.15, très long pour se connecter à partir du serveur physique après saisie login et pwd (impossible via putty pas d'accès au login timeout).
Après connexion, getent et exxl_diagnostic : NOK !!

Suite à messages d'erreur sur nut, modif dans config.eol "activer_nut" (mis à non) et ensuite reconfigure
=> le reconfigure a été très long au niveau de l'étape " executing /usr/share/eole/pretemplate/01-ecdlfichier reconfigure"
Après reboot, tests OK pour :
- exxl_diagnostic
- getent passwd
- getent group
- privilege.sh (avec compte admin.ddt-101)
- prerequis.sh
Par contre impossible de joindre une machine au domaine (eSBL ou XP) que ce soit avec admin.ddt-101 ou compte créé dans "DomainAdmins" (qui fonctionnait en 2.3.9 et 2.3.13)

Messages d'erreur :
Sur l'eSBL
esbl_samba_join
"...
error setting trust account password: NT_STATUS_UNSUCCESSFUL
Unable to join domain DDT-101.
Résultat : Abandon du traitement"

Sur l'ECDL
/var/log/rsyslog/local/smbd/smbd.err.log
"...
_netr_ServerAuthenticate2: netlogon_creds_server_check failed. Rejecting auth request from client SBL-41-142 machine account SBL-41-142$
rpc_server/srv_netlog_nt.c:714(_netr_ServerAuthenticate3)
...
Pour poste client XP
"...
rpc_server/srv_netlog_nt.c:669(_netr_ServerAuthenticate3)
_netr_ServerAuthenticate: no challenge sent to client VIRTUALXP-PNESR
..."

#7 Updated by Thierry Bertrand over 6 years ago

  • Status changed from En cours to Fermé
  • % Done changed from 20 to 100
  • Remaining (hours) changed from 6.0 to 0.0

Also available in: Atom PDF