Project

General

Profile

Anomalie #8251

Proxy authentifié ne fonctionne pas correctement

Added by Gaetan Mottier almost 6 years ago. Updated almost 6 years ago.

Status:
Fermé
Priority:
Haut
Assigned To:
Category:
-
Start date:
05/19/2014
Due date:
05/28/2014
% Done:

100%

Estimated time:
4.00 h
Spent time:
Distribution:
EOLE 2.4

Description

Sur un eolebase avec eole-proxy. Si on active l'authentification NTLM/SMB. La navigation ne fonctionne pas et aucune demande de mot de passe n'est faite. (windows 7 ou xp)

Les logs de squid donnent "DENIED/407"

J'ai bien rajouté [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa] "LMCompatibilityLevel"=dword:00000001" dans le registre windows pour l'authentification transparente. Mais pas de changement.

en executant la commande /usr/lib/squid3/ntlm_smb_lm_auth -a horus administration/ dans la console
j'obtient "Couldn't grok domain-controller horus"

Le fichier /etc/hosts est bien renseigné, les démons tournent. L'authentification LDAP fonctionne. Juste la partie smb qui semble ne pas fonctionner.


Related issues

Related to eole-fichier - Tâche #8273: Revoir les nouvelles variables Fermé 12/13/2016

Associated revisions

Revision 7d0d7dae (diff)
Added by Emmanuel GARETTE almost 6 years ago

radd == right add il faut inverser l'ajout dans le cas d'une string (ref #8251 @2h)

Revision 9b3074ba (diff)
Added by Emmanuel GARETTE almost 6 years ago

lanman auth est maintenant à 'no' par défaut, il faut le passer à 'yes' pour l'authentification du proxy (ref #8251 @1h)

History

#1 Updated by Gaetan Mottier almost 6 years ago

Après test. Cela fait exactement la même chose avec le module amon 2.4 complet.

#2 Updated by Emmanuel GARETTE almost 6 years ago

  • Assigned To set to Emmanuel GARETTE
  • Priority changed from Normal to Haut
  • Target version set to Eole 2.4.0.1
  • Estimated time set to 4.00 h

Je confirme l'authentification SMB ne fonctionne pas pour 2 raisons :

- le template est mal généré ;
- les options par défaut de samba Scribe 2.4 ont changés et rende impossible l'authentification du proxy (pas de problème avec un Scribe 2.3).

#3 Updated by Emmanuel GARETTE almost 6 years ago

  • Due date set to 05/28/2014
  • Start date set to 05/19/2014
  • % Done changed from 0 to 100

Ajout dans Squash d'un test pour éviter les régressions :

"Cas de test : AM-T03-004 authentification proxy ntlm/smb"

#4 Updated by Emmanuel GARETTE almost 6 years ago

  • Status changed from Nouveau to Résolu

#5 Updated by Emmanuel GARETTE almost 6 years ago

Le 30/05/2014 10:52, Gaëtan Mottier a écrit :
[..]
> La correction fonctionne correctement avec un horus 2.3 et un sambaedu. 
[..]

#6 Updated by Joël Cuissinat almost 6 years ago

  • Status changed from Résolu to Fermé

Also available in: Atom PDF