Tâche #7865
Distribution EOLE - Scénario #15923: Corriger les problèmes identifiés sur Hâpy
diagnose en erreur si interface en mode manuel
100%
Description
La récupération d'une IP si l'interface est en mode manuel (cas de la virtualisation Opennebula) échoue, avec le message
root - Creole error 1: trying to access to an option named: adresse_ip_eth1 with properties ['disabled', 'mandatory']
Du coup le diagnose sort des messages d'erreur lors du test des interfaces et surtout essaie de tester des services sur des interfaces sans IP
Proposition de correction dans /usr/share/eole/diagnose/04-network:
ajout du test [ "$(CreoleGet eth$Cpt'_method')" = "manuel" ] dans les boucles de test des interfaces
Donc deux lignes a ajouter, cf 04-network joint
Christophe
Révisions associées
diagnose : correction de la gestion des interfaces configurées manuellement REF #7865 @1h
diagnose : correction de la gestion des interfaces configurées manuellement REF #7865 @1h
Historique
#1 Mis à jour par Emmanuel GARETTE il y a plus de 12 ans
si je comprends bien, la variable "adresse_ip_eth1" n'a pas de sens c'est cela ? (il n'y a pas d'adresse IP sur le réseau interface 1).
#2 Mis à jour par Christophe LEON il y a plus de 12 ans
Oui, si on définit l'interface eth1 en manuel il n'y a pas d'IP sur l'interface (idem pour eth2,eth3, eth4,..) bref toutes interfaces en manuel n'a pas d'IP
#3 Mis à jour par Joël Cuissinat il y a plus de 12 ans
- Statut changé de Nouveau à A étudier
- Temps estimé mis à 2.00 h
Il s'agit d'une modification spécifique au module OpenNebula mais qui mériterait d'être gérée en partie dans eole-common.
C'est d'ailleurs ce qu'implique ce signalement !
#4 Mis à jour par Klaas TJEBBES il y a plus de 10 ans
- Tâche parente mis à #15923
#5 Mis à jour par Klaas TJEBBES il y a plus de 10 ans
- Début mis à 18/04/2016
- Tâche parente
#15923supprimé - Restant à faire (heures) mis à 2.0
#6 Mis à jour par Klaas TJEBBES il y a plus de 10 ans
- Tracker changé de Tâche à Demande
- Statut changé de A étudier à Nouveau
#7 Mis à jour par Klaas TJEBBES il y a plus de 10 ans
- Tâche parente mis à #15923
#8 Mis à jour par Klaas TJEBBES il y a plus de 10 ans
- Statut changé de Nouveau à En cours
- Assigné à mis à Klaas TJEBBES
- Restant à faire (heures) changé de 2.0 à 0.15
#9 Mis à jour par Christophe LEON il y a plus de 10 ans
Merci :)
tout vient à point à qui sait attendre
#10 Mis à jour par Scrum Master il y a plus de 10 ans
- Statut changé de En cours à Résolu
#11 Mis à jour par Joël Cuissinat il y a plus de 10 ans
- Statut changé de Résolu à Fermé
- % réalisé changé de 0 à 100
- Restant à faire (heures) changé de 0.15 à 0.0
OK :
*** Interfaces hapy1: 192.168.230.14 => Ok eth1: configuration manuelle
Sur l'interface réseau eth0 . SSH => Ok . EAD Server => Ok . EAD Web => Ok