Project

General

Profile

Tâche #6895

Scénario #9379: Consolidation CREOLE

problème de verrou

Added by Karim Ayari over 7 years ago. Updated over 6 years ago.

Status:
Ne sera pas résolu
Priority:
Normal
Assigned To:
-
Start date:
10/28/2014
Due date:
% Done:

100%

Estimated time:
1.50 h
Spent time:
Remaining (hours):
0.0

Description

par moment avant le reconfigure on a ce message :

*** D←but de reconfigure ***
Le verrou (lock) "/var/lock/eolemaj-auto" existe, abandon !

alors qu'il n'y a aucun verrou dans /var/lock

on relance reconfigure quelques secondes plus tard et ça fonctionne.

History

#1 Updated by Karim Ayari about 7 years ago

j'ai modifié le script reconfigure sur notre amon plateforme afin de récupérer la liste des locks au moment ou le problème se pose. je fait un ls /var/lock et je crée un fichier (avant qu'il n'affiche le message "Le verrou (lock)...existe, abandon!"). voici ce qu'on pouvait y trouver au moment T :

root@plateformetest:~# cat lock-fantome.txt 
---
14-01-14--10:31:15
eolemaj-auto
bastion
configure
eolemaj-auto
layer7
lvm
maj
reconfigure
rvp
subsys
uucp
z_stats
root@plateformetest:~#

Par contre impossible de reproduire le problème :s bien que j'ai lancé un certain nombre de reconfigure dans la nuit, des maj-auto manuelle et via l'ead. je vais le laisser tranquille un moment et relancerai un reconfigure quand il s'y attendra pas ^^

#2 Updated by Daniel Dehennin about 7 years ago

  • Project changed from Distribution EOLE to creole

#3 Updated by Karim Ayari almost 7 years ago

je viens de retomber sur ce problème sur notre amon de test, au moment du reconfigure il y a toujours le blocage en raison du lock eolemaj-auto :

Début de reconfigure
Le verrou (lock) "/var/lock/eolemaj-auto" existe, abandon !

et cette fois-ci contrairement à mon 1er message le lock existe bien ou alors il n'a pas eut le temps de disparaitre ?

root@plateformetest:~# ls /var/lock
bastion configure eolemaj-auto layer7 lvm maj reconfigure rvp subsys uucp z_stats

pourtant il y a pas de maj en cours, dernière maj auto faite le 9/05.

Je ne sais pas si cela à un lien, mais c'est arrivé juste après une synchro_zephir pour récupérer toute la conf de la variante.

#4 Updated by Karim Ayari almost 7 years ago

j'ai oublié de préciser que cette fois-ci il a mis du temps à disparaitre tout seul. j'ai lancé au moins 5 fois le reconfigure avant qu'il ne passe.

#5 Updated by Joël Cuissinat over 6 years ago

  • Status changed from Nouveau to En attente d'informations

A tout hasard /var/lock n'est pas dans tes fichiers personnalisés Zéphir ???

#6 Updated by Karim Ayari over 6 years ago

non! :)

#7 Updated by Luc Bourdot over 6 years ago

  • Parent task set to #9379

#8 Updated by Joël Cuissinat over 6 years ago

  • Status changed from En attente d'informations to Nouveau

#9 Updated by Joël Cuissinat over 6 years ago

  • Estimated time set to 1.50 h
  • Remaining (hours) set to 1.5

#10 Updated by Emmanuel GARETTE over 6 years ago

  • Status changed from Nouveau to En cours
  • Start date set to 10/28/2014

#11 Updated by Emmanuel GARETTE over 6 years ago

  • Status changed from En cours to Ne sera pas résolu
  • % Done changed from 0 to 100
  • Remaining (hours) changed from 1.5 to 0.0

Nous n'arrivons pas a reproduire. Ouvrir une nouvelle demande si vous avez une façon de le reproduire en 2.4.

Also available in: Atom PDF