Project

General

Profile

Anomalie #6247

Si pas de node ne devrait pas faire d'erreur

Added by Emmanuel GARETTE over 7 years ago. Updated over 7 years ago.

Status:
Fermé
Priority:
Normal
Assigned To:
-
Category:
-
Start date:
10/12/2013
Due date:
10/18/2013
% Done:

100%

Distribution:
EOLE 2.3

Description

J'ai eu un problème à la configuration de la haute disponibilité.

Je voulais re-instancier. Problème : le script pretemplate vérifie le status de crm.

Si le status est "ok" (puisque démarré) mais je n'ai pas de node.

crm node standby nom_machine

renvoi une erreur parce que je n'ai pas de node.

La dernière commande ayant renvoyer le code retour 1, le script s'arrête avec un code retour 1.

Il faudrait mettre un exit 0 à la fin du script pour éviter ce problème.

Associated revisions

Revision ad6baed2 (diff)
Added by Emmanuel GARETTE over 7 years ago

meilleur vérification pour savoir si le noeud est 'online' + ne pas planter si pas de haute-dispo/pas activé (ref #6247)

Revision 85630963 (diff)
Added by Emmanuel GARETTE over 7 years ago

meilleur vérification pour savoir si le noeud est 'online' + ne pas planter si pas de haute-dispo/pas activé (ref #6247)

History

#1 Updated by Emmanuel GARETTE over 7 years ago

  • Due date set to 10/18/2013
  • Start date set to 10/12/2013
  • % Done changed from 0 to 50

Pas porté en 2.4.

#2 Updated by Fabrice Barconnière over 7 years ago

  • Status changed from Nouveau to Fermé
  • % Done changed from 50 to 100

Also available in: Atom PDF