Project

General

Profile

Anomalie #6041

Message en anglais dans apt-eole

Added by Emmanuel GARETTE over 7 years ago. Updated over 7 years ago.

Status:
Fermé
Priority:
Bas
Assigned To:
Category:
-
Start date:
Due date:
11/08/2013
% Done:

100%

Spent time:
Distribution:
EOLE 2.4

Description

Les messages de apt-eole sont tous en anglais :

Running install for root
No package to install.
Done downloading 

Associated revisions

Revision b62fb940 (diff)
Added by Philippe Caseiro over 7 years ago

  • pyeole/i18n.py : Creation du fichier * pyeole/pkg.py : Ajout de l'utilisation de i18n.py * translation/pkg.pot : Creation du fichier de traduction

Ajout de l'infrastructure pour l'internationalisation de pyeole

ref #6041 @1h

Revision be206ceb (diff)
Added by Philippe Caseiro over 7 years ago

setup.py : Mise à jour pour le support des traductions
translation/fr/pyeole.po: Création du fichier de traduciton

Mise en place de l'internationalisation de pyeole.

fixes #6041 @5h

Revision 4d494025 (diff)
Added by Philippe Caseiro over 7 years ago

setup.py : Mise à jour pour le support des traductions
translation/fr/pyeole.po: Création du fichier de traduciton

Mise en place de l'internationalisation de pyeole.

fixes #6041 @5h

Revision f3a04cda (diff)
Added by Philippe Caseiro over 7 years ago

pyeole/pkg.py : Correction de l'appel à _()
translation/fr/pyeole.po : Mise à jour de la traduction française
translation/pyeole.pot : Mise à jour des chaines à traduire

Pour que gettext traduise il faut utilise _() comme ceci :

print(_('ma chaine {0} : {1}').format(var1, var2))

fixes #6041 @1h

Revision 1f237cf1 (diff)
Added by Philippe Caseiro over 7 years ago

debian/pyeole-pyeole.install : Ajout des traductions dans le paquet

ref #6041 @5m

Revision 1fa91495 (diff)
Added by Joël Cuissinat over 7 years ago

Maj traduction (Fixes #6041 @10m)

History

#1 Updated by Joël Cuissinat over 7 years ago

  • Target version changed from Eole 2.4-alpha2 to Eole 2.4-beta1

#2 Updated by Joël Cuissinat over 7 years ago

  • Target version changed from Eole 2.4-beta1 to Eole 2.4-beta2

#3 Updated by Philippe Caseiro over 7 years ago

  • Project changed from creole to python-pyeole

Pour résoudre cette demande il faut internationaliser pyeole.

#4 Updated by Philippe Caseiro over 7 years ago

  • Status changed from Nouveau to Résolu
  • % Done changed from 0 to 100

#6 Updated by Philippe Caseiro over 7 years ago

  • Status changed from Résolu to Réouvert

Traduction en place mais le message est toujours en anglais

#7 Updated by Philippe Caseiro over 7 years ago

  • % Done changed from 100 to 80

#8 Updated by Philippe Caseiro over 7 years ago

  • Status changed from Réouvert to Résolu
  • % Done changed from 80 to 100

#9 Updated by Joël Cuissinat over 7 years ago

  • Status changed from Résolu to Réouvert
  • Assigned To set to Philippe Caseiro
  • Priority changed from Normal to Bas
  • Target version changed from Eole 2.4-beta2 to Eole 2.4-beta3

Loin de remettre en cause le travail réalisé, je pense qu'on peut encore améliorer l'exemple suivant :

root@amon:~# apt-eole install creole
Action install pour root
Pas de paquet pour install
Done downloading 

"Pas de paquet pour {0}" pourrait être remplacé par "Pas de paquet pour l'action {0}" :)

#10 Updated by Joël Cuissinat over 7 years ago

  • % Done changed from 100 to 90

#11 Updated by Joël Cuissinat over 7 years ago

  • Status changed from Réouvert to Résolu
  • % Done changed from 90 to 100

#12 Updated by Joël Cuissinat over 7 years ago

  • Due date set to 11/08/2013
  • Status changed from Résolu to Fermé
root@scribe:~# apt-eole install creole
Action install pour root
Pas de paquet pour l'action install
Done downloading

Also available in: Atom PDF