Project

General

Profile

Evolution #5876

Templates à corriger pour 2.4

Added by Joël Cuissinat over 6 years ago. Updated over 6 years ago.

Status:
Fermé
Priority:
Normal
Assigned To:
-
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
0.50 h
Distribution:
EOLE 2.3

Description

Si on porte les paquets 2.3 directement sur 2.4, on obtient :

Génération des fichiers de configuration
reconfigure - Erreur lors de l'instanciation du template de /usr/share/eole/mysql/spip/gen/spip-create.sql : 
 object of type 'int' has no len()

Maintenant que les variables Creole sont réellement typées, il faut remplacer la ligne suivante :

%set %%longueurport=len(%%eolesso_port)

par :
%set %%longueurport=len(str(%%eolesso_port))

dans les templates spip-create.sql et spip-update.sql

Cette modification ne devrait pas gêner sur 2.3

Associated revisions

Revision d163b536 (diff)
Added by Arnaud Fornerot over 6 years ago

template pour la 2.4
probleme accent sur libelle etab
fixes #5876 #5873

History

#1 Updated by Arnaud FORNEROT over 6 years ago

  • Target version changed from Envole 4.0 RC to Envole 3.3.5
  • Distribution changed from EOLE 2.4 to EOLE 2.3

#2 Updated by Anonymous over 6 years ago

  • Status changed from Nouveau to Résolu
  • % Done changed from 0 to 100

#3 Updated by Arnaud FORNEROT over 6 years ago

  • Status changed from Résolu to Fermé

Also available in: Atom PDF