Project

General

Profile

Evolution #4491

Modules 2.3 dans un KVM

Added by Daniel Dehennin almost 10 years ago. Updated about 7 years ago.

Status:
Ne sera pas résolu
Priority:
Normal
Assigned To:
Category:
-
Target version:
Start date:
11/26/2012
Due date:
% Done:

80%

Spent time:
Distribution:
EOLE 2.3

Description

Afin de répondre aux demandes de compatibilité matériel, il serait intéressant de fournir les modules EOLE 2.3 dans un KVM :

  • Utilisation d’un système hôte plus récent (noyau) ;
  • À n’utiliser que lorsqu’un module 2.3 ne s’installe pas nativement avec le CD ;
  • Rendre ± transparent aux utilisateurs.

History

#1 Updated by Daniel Dehennin almost 10 years ago

J’ai une image de clef usb qui :

  • Installe une debian wheezy ;
  • Créé un utilisateur eole avec le mot de passe par défaut de l’utilisateur root sur les modules EOLE 2.3 ;
  • Installe OpenSSH server ;
  • Copie une image ISO quelque part dans le système installé.

Il y a plusieurs adaptations possibles :

  • Générer aléatoirement le mot de passe de l’utilisateur EOLE et le stocker dans un fichier .pass dans son $HOME ;
  • Copier un fichier authorized_keys dans le $HOME de l’utilisateur EOLE ;
  • N’autoriser que l’authentification SSH par clef publique.

Ces deux derniers points permettraient d’avoir un niveau de sécurité assez bon sans nécessiter de paramétrage de l’hôte.

#2 Updated by Luc Bourdot over 9 years ago

  • Status changed from Nouveau to Résolu
  • % Done changed from 0 to 100

#3 Updated by Joël Cuissinat over 8 years ago

  • Target version set to Eole 2.4-RC3

Roadmap pour qualification.

Doit-on donner des suites à cette demande (documentation...) ?

#4 Updated by Joël Cuissinat over 8 years ago

  • Project changed from Distribution EOLE to Documentations
  • Status changed from Résolu to À valider
  • Assigned To changed from developpeurs_eole to Luc Bourdot
  • Target version deleted (Eole 2.4-RC3)
  • % Done changed from 100 to 80

#5 Updated by Gérald Schwartzmann over 8 years ago

  • Target version set to Maj doc 2.3.13/2.3.14

#6 Updated by Gérald Schwartzmann over 8 years ago

  • Target version changed from Maj doc 2.3.13/2.3.14 to Maj doc 2.3 - TODO

#7 Updated by Daniel Dehennin about 7 years ago

  • Status changed from À valider to Ne sera pas résolu

Ne s’applique plus grâce à OpenNebula.

Also available in: Atom PDF