Projet

Général

Profil

Tâche #37481

Scénario #36855: Installation des paquets PHP7 pour Envole 9 & 10

Instance AmonEcole en erreur (php8.3-fpm)

Ajouté par Joël Cuissinat il y a 4 mois. Mis à jour il y a 3 mois.

Statut:
Fermé
Priorité:
Normal
Assigné à:
Version cible:
Début:
29/05/2026
Echéance:
% réalisé:

100%

Restant à faire (heures):
0.0

Description

https://dev-eole.ac-dijon.fr/jenkins/job/2.10.0/job/test-instance-etb3amonecole-2.10.0-amd64/

Vérification des paquets pour le conteneur reseau:

Le paquet suivant a été installé automatiquement et n'est plus nécessaire :
  libgnutls-openssl27t64
Veuillez utiliser « apt autoremove » pour le supprimer. 
Les paquets supplémentaires suivants seront installés :
  php-bz2 php8.3-bz2
Les NOUVEAUX paquets suivants seront installés :
  eole-glpi-pkg eole-infosquota-apps php-bz2 php8.3-bz2

Paramétrage de eole-glpi-pkg (2.9.0-2) ...
Traitement des actions différées (« triggers ») pour libapache2-mod-php8.3 (8.3.6-0ubuntu0.24.04.8) ...
Traitement des actions différées (« triggers ») pour php8.3-fpm (8.3.6-0ubuntu0.24.04.8) ...
Job for php8.3-fpm.service failed because the control process exited with error code.
See "systemctl status php8.3-fpm.service" and "journalctl -xeu php8.3-fpm.service" for details.
invoke-rc.d: initscript php8.3-fpm, action "restart" failed.
× php8.3-fpm.service - The PHP 8.3 FastCGI Process Manager
     Loaded: loaded (/usr/lib/systemd/system/php8.3-fpm.service; enabled; preset: enabled)
     Active: failed (Result: exit-code) since Thu 2026-05-28 18:54:31 UTC; 10ms ago
       Docs: man:php-fpm8.3(8)
    Process: 725 ExecStart=/usr/sbin/php-fpm8.3 --nodaemonize --fpm-config /etc/php/8.3/fpm/php-fpm.conf (code=exited, status=78)
    Process: 727 ExecStopPost=/usr/lib/php/php-fpm-socket-helper remove /run/php/php-fpm.sock /etc/php/8.3/fpm/pool.d/www.conf 83 (code=exited, status=0/SUCCESS)
   Main PID: 725 (code=exited, status=78)
        CPU: 59ms
mai 28 18:54:31 reseau systemd[1]: Starting php8.3-fpm.service - The PHP 8.3 FastCGI Process Manager...
mai 28 18:54:31 reseau php-fpm8.3[725]: [28-May-2026 18:54:31] ERROR: unable to bind listening socket for address '/run/php/php8.3-fpm.sock': No such file or directory (2)
mai 28 18:54:31 reseau php-fpm8.3[725]: [28-May-2026 18:54:31] ERROR: FPM initialization failed
mai 28 18:54:31 reseau systemd[1]: php8.3-fpm.service: Main process exited, code=exited, status=78/CONFIG
mai 28 18:54:31 reseau systemd[1]: php8.3-fpm.service: Failed with result 'exit-code'.
mai 28 18:54:31 reseau systemd[1]: Failed to start php8.3-fpm.service - The PHP 8.3 FastCGI Process Manager.
dpkg: erreur de traitement du paquet php8.3-fpm (--configure) :
 le sous-processus paquet php8.3-fpm script post-installation installé a renvoyé un état de sortie d'erreur 1

Demandes liées

Lié à Distribution EOLE - Tâche #25509: Le service Apache2 n’attend pas le démarrage du réseau Fermé 10/10/2018

Révisions associées

Révision d9e7050a (diff)
Ajouté par Joël Cuissinat il y a 4 mois

Forcer la création de /run/php au démarrage de php8.3-fpm

Ref: #37481

Révision 28a8bf62 (diff)
Ajouté par Joël Cuissinat il y a 4 mois

Déploiement de l'override pour php8.3-fpm

Ref: #37481

Révision 1cf880ce (diff)
Ajouté par Joël Cuissinat il y a 4 mois

Cas /run/php existant au démarrage de php8.3-fpm

Ref: #37481

Historique

#1 Mis à jour par Joël Cuissinat il y a 4 mois

Pistes de travail :

Visiblement le répertoire /run/php est nettoyé au reboot et le script d'init ne le re-crée pas (pourrait être corrigé via override ou une config qui dirait de créer le répertoire au démarrage du conteneur ?).

  • redémarrage direct du service : KO
  • redémarrage du service après création du répertoire : OK
    root@reseau:~# mkdir -p /run/php 
    root@reseau:~# systemctl restart  php8.3-fpm
    
  • redémarrage du service après réinstallation du paquet : OK
    apt install --reinstall php8.3-fpm
    systemctl restart  php8.3-fpm
    

#2 Mis à jour par Joël Cuissinat il y a 4 mois

HACK temporaire : CreoleRun "mkdir -p /run/php" web (un mkdir depuis le maître ne fonctionne pas).

#3 Mis à jour par Klaas TJEBBES il y a 4 mois

le dossier /run est sur du tmpfs, c'est pour ça qu'il est effacé au stop/start d'un conteneur :

root@internet:~# mount |grep run
tmpfs on /run type tmpfs (rw,nosuid,nodev,size=1625464k,nr_inodes=819200,mode=755,inode64)

#4 Mis à jour par Joël Cuissinat il y a 4 mois

  • Tâche parente mis à #36855

Proposition, fournir l'override suivant dans eole-web-pkg :

root@reseau:~# cat /etc/systemd/system/php8.3-fpm.service.d/override.conf
[Service]
ExecStartPre=/usr/bin/mkdir /run/php

#5 Mis à jour par Joël Cuissinat il y a 4 mois

  • Lié à Tâche #25509: Le service Apache2 n’attend pas le démarrage du réseau ajouté

#6 Mis à jour par Joël Cuissinat il y a 4 mois

  • Statut changé de Nouveau à En cours
  • Assigné à mis à Joël Cuissinat

#7 Mis à jour par Joël Cuissinat il y a 4 mois

  • Statut changé de En cours à Résolu
  • % réalisé changé de 0 à 100

#8 Mis à jour par Joël Cuissinat il y a 3 mois

  • Statut changé de Résolu à Fermé
  • Restant à faire (heures) mis à 0.0

Formats disponibles : Atom PDF