Project

General

Profile

Tâche #34245

Scénario #34174: évolutions Upgrade-Auto

Le paquet postgresql-10-postgis-2.4 ne peut pas être supprimé pendant l'upgrade-auto

Added by Philippe Carre almost 2 years ago. Updated about 1 year ago.

Status:
Fermé
Priority:
Normal
Assigned To:
Start date:
05/17/2022
Due date:
% Done:

100%

Remaining (hours):
0.0

Description

2022-06-02 10:33:21,921 DEBUG blacklist expr '^postgresql-.*[0-9]\.[0-9].*' matches 'postgresql-10-postgis-2.4'
2022-06-02 10:33:21,922 DEBUG The package 'postgresql-10-postgis-2.4' is marked for removal but it's in the removal blacklist
2022-06-02 10:33:21,938 ERROR Impossible d'évaluer la mise à niveau Un problème insoluble est survenu lors du calcul de la mise à niveau.

Cela a probablement été causé par :
  • des paquets logiciels non officiels qui ne proviennent pas d’Ubuntu.
    Veuillez utiliser la commande « ppa-purge » du paquet
    « ppa-purge » afin de supprimer les paquets d’un
    dépôt PPA Launchpad, puis essayez de relancer la mise à niveau.

Si rien de tout cela ne s'applique, signalez ce bogue à l'aide de la commande « ubuntu-bug ubuntu-release-upgrader-core » dans un terminal. Si vous souhaitez analyser le problème par vous-même, les fichiers journaux contenus dans le répertoire « /var/log/dist-upgrade » contiennent les informations sur la mise à niveau. Plus précisément, veuillez consulter les journaux « main.log » et « apt.log ». (None)
2022-06-02 10:33:21,939 ERROR Dist-upgrade failed: 'Le paquet « postgresql-10-postgis-2.4 » est marqué pour suppression mais il est dans la liste noire des suppressions.'
2022-06-02 10:33:21,954 DEBUG abort called
2022-06-02 10:33:21,964 ERROR view.abort called
2022-06-02 10:33:21,964 DEBUG openCache()
2022-06-02 10:33:26,360 DEBUG Comparing 4.15.0-177 with
2022-06-02 10:33:26,362 DEBUG Comparing 4.15.0-180 with 4.15.0-177
2022-06-02 10:33:26,911 DEBUG /openCache(), new cache size 77526

Associated revisions

Revision bd492121 (diff)
Added by Emmanuel GARETTE almost 2 years ago

gestion de la migration de postgis (ref #34245)

Revision 721927a4 (diff)
Added by Emmanuel GARETTE almost 2 years ago

gestion de la migration de postgis (ref #34245)

History

#1 Updated by Emmanuel GARETTE almost 2 years ago

  • Status changed from Nouveau to Résolu
  • Assigned To set to Emmanuel GARETTE
  • % Done changed from 0 to 100

#2 Updated by Philippe Carre almost 2 years ago

  • Status changed from Résolu to À valider

Apres mise à jour en RC (sur test-eole) d'un Seth 2.7.2 Geomatique + reconfigure + reboot , le pb semble toujours être le même :

------- erreur pendant l'Upgrade-Auto -------------
uthenticate 'focal.tar.gz' against 'focal.tar.gz.gpg'
extracting 'focal.tar.gz'
La cible Packages (Packages) est spécifiée plusieurs fois dans /etc/apt/sources.list.d/DepotIntraPNESR.list:2 et /etc/apt/sources.list.d/additional.list:4
La cible Translations (fr_FR) est spécifiée plusieurs fois dans /etc/apt/sources.list.d/DepotIntraPNESR.list:2 et /etc/apt/sources.list.d/additional.list:4
La cible Translations (fr) est spécifiée plusieurs fois dans /etc/apt/sources.list.d/DepotIntraPNESR.list:2 et /etc/apt/sources.list.d/additional.list:4
La cible Translations (en) est spécifiée plusieurs fois dans /etc/apt/sources.list.d/DepotIntraPNESR.list:2 et /etc/apt/sources.list.d/additional.list:4
La cible Packages (Packages) est spécifiée plusieurs fois dans /etc/apt/sources.list.d/DepotIntraPNESR.list:2 et /etc/apt/sources.list.d/additional.list:4
La cible Translations (fr_FR) est spécifiée plusieurs fois dans /etc/apt/sources.list.d/DepotIntraPNESR.list:2 et /etc/apt/sources.list.d/additional.list:4
La cible Translations (fr) est spécifiée plusieurs fois dans /etc/apt/sources.list.d/DepotIntraPNESR.list:2 et /etc/apt/sources.list.d/additional.list:4
La cible Translations (en) est spécifiée plusieurs fois dans /etc/apt/sources.list.d/DepotIntraPNESR.list:2 et /etc/apt/sources.list.d/additional.list:4
Une erreur est survenue : Impossible d'évaluer la mise à niveau Un problème insoluble est survenu lors du calcul de la mise à niveau.

Cela a probablement été causé par :
  • des paquets logiciels non officiels qui ne proviennent pas d’Ubuntu.
    Veuillez utiliser la commande « ppa-purge » du paquet
    « ppa-purge » afin de supprimer les paquets d’un
    dépôt PPA Launchpad, puis essayez de relancer la mise à niveau.

Si rien de tout cela ne s'applique, signalez ce bogue à l'aide de la commande « ubuntu-bug ubuntu-release-upgrader-core » dans un terminal. Si vous souhaitez analyser le problème par vous-même, les fichiers journaux contenus dans le répertoire « /var/log/dist-upgrade » contiennent les informations sur la mise à niveau. Plus précisément, veuillez consulter les journaux « main.log » et « apt.log ». (None)
Une erreur fatale est survenue. Vous trouverez plus d'informations dans les journaux : /var/log/dist-upgrade/
None
La migration s'est terminée avec une erreur

---------------------------------------------------------
------- /var/log/dist-upgrade/main.log ----------------

2022-06-15 11:14:15,246 DEBUG quirks: running PostDistUpgradeCache
2022-06-15 11:14:15,247 DEBUG running Quirks.PostDistUpgradeCache
2022-06-15 11:14:15,954 DEBUG Comparing 4.15.0-180 with
2022-06-15 11:14:15,954 DEBUG Comparing 4.15.0-184 with 4.15.0-180
2022-06-15 11:14:15,964 DEBUG Comparing 5.4.0-117 with 4.15.0-184
2022-06-15 11:14:16,572 DEBUG blacklist expr '^postgresql-.*[0-9]\.[0-9].*' matches 'postgresql-10-postgis-2.4'
2022-06-15 11:14:16,572 DEBUG The package 'postgresql-10-postgis-2.4' is marked for removal but it's in the removal blacklist
2022-06-15 11:14:16,587 ERROR Impossible d'évaluer la mise à niveau Un problème insoluble est survenu lors du calcul de la mise à niveau.
Cela a probablement été causé par :
  • des paquets logiciels non officiels qui ne proviennent pas d’Ubuntu.
    Veuillez utiliser la commande « ppa-purge » du paquet
    « ppa-purge » afin de supprimer les paquets d’un
    dépôt PPA Launchpad, puis essayez de relancer la mise à niveau.

Si rien de tout cela ne s'applique, signalez ce bogue à l'aide de la commande « ubuntu-bug ubuntu-release-upgrader-core » dans un terminal. Si vous souhaitez analyser le problème par vous-même, les fichiers journaux contenus dans le répertoire « /var/log/dist-upgrade » contiennent les informations sur la mise à niveau. Plus précisément, veuillez consulter les journaux « main.log » et « apt.log ». (None)
2022-06-15 11:14:16,587 ERROR Dist-upgrade failed: 'Le paquet « postgresql-10-postgis-2.4 » est marqué pour suppression mais il est dans la liste noire des suppressions.'
2022-06-15 11:14:16,606 DEBUG abort called
2022-06-15 11:14:16,615 ERROR view.abort called
2022-06-15 11:14:16,616 DEBUG openCache()
2022-06-15 11:14:24,245 DEBUG Comparing 4.15.0-180 with
2022-06-15 11:14:24,246 DEBUG Comparing 4.15.0-184 with 4.15.0-180
2022-06-15 11:14:24,785 DEBUG /openCache(), new cache size 77792


#3 Updated by Emmanuel GARETTE almost 2 years ago

Je viens de backporté en 2.7.2 ...

#4 Updated by Vincent Chavanon about 1 year ago

  • Status changed from À valider to Résolu

#5 Updated by Vincent Chavanon about 1 year ago

  • Status changed from Résolu to Fermé
  • Remaining (hours) set to 0.0

Also available in: Atom PDF