Project

General

Profile

Tâche #33598

Scénario #33486: Scribe AD : erreur dans le conteneur ADDC netplan

Le test d'Upgrade ScribeAD 2.6.2 2.7.2 signale une erreur

Added by Joël Cuissinat over 2 years ago. Updated over 2 years ago.

Status:
Fermé
Priority:
Normal
Assigned To:
Start date:
12/23/2021
Due date:
% Done:

100%

Remaining (hours):
0.0

Description

Un petit mkdir='True' devrait contourner mais c'est potentiellement plus grave que ça ?

from262.txt View - Paquets du conteneur sur un serveur Upgradé (53.3 KB) Joël Cuissinat, 01/03/2022 02:40 PM

Associated revisions

Revision eb1c954d (diff)
Added by Joël Cuissinat over 2 years ago

Explicitly add ubuntu-minimal dependency to eole-ad-pkg

Ref: #33598

Revision 58ee745f (diff)
Added by Joël Cuissinat over 2 years ago

Explicitly add ubuntu-minimal dependency to eole-ad-pkg

Ref: #33598

Revision 09f8a396 (diff)
Added by Joël Cuissinat over 2 years ago

Explicitly add ubuntu-minimal dependency to eole-ad-pkg

Ref: #33598

History

#1 Updated by Emmanuel GARETTE over 2 years ago

Dans https://dev-eole.ac-dijon.fr/jenkins/job/2.7.2/job/test-upgradeauto-scribead-262-2.7.2-amd64/83/consoleFull on ne voit pas la mise à jour de netplan.io dans le conteneur alors qu'il est bien mis à jour sur le maitre.

Il faudrait faire une étude approfondit (savoir s'il est bien installé dans le conteneur avant, pourquoi il n'est pas mis à jour/installé, ...).

Travailler sur d'upgrade-auto sur ce scénario n'est pas possible en 1 point.

#2 Updated by Joël Cuissinat over 2 years ago

En 2.7.2 :

root@addc:~# dpkg -S /etc/netplan/
netplan.io: /etc/netplan
root@addc:~# dpkg -l netplan.io
   [ ... ]
ii  netplan.io                                     0.99-0ubuntu3~18.04.5        amd64                        YAML network configuration abstraction for various backends
root@addc:~# apt rdepends netplan.io 
netplan.io
Reverse Depends:
  Casse: initramfs-tools (<< 0.36.2)
  Dépend: nplan
  Casse: initramfs-tools (<< 0.36.2)
 |Dépend: cloud-init
  Dépend: nplan
  Dépend: nplan
root@addc:~# apt remove -s netplan.io 
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libnetplan0 python3-netifaces
Veuillez utiliser « apt autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  netplan.io* nplan* ubuntu-minimal*
0 mis à jour, 0 nouvellement installés, 3 à enlever et 0 non mis à jour.
Purg ubuntu-minimal [1.417.5]
Purg nplan [0.99-0ubuntu3~18.04.5]
Purg netplan.io [0.99-0ubuntu3~18.04.5]

#3 Updated by Joël Cuissinat over 2 years ago

En 2.6.2 (mode AD) :
Il n'y a ni ubuntu-minimal ni netplan dans le conteneur addc !

#4 Updated by Joël Cuissinat over 2 years ago

#5 Updated by Joël Cuissinat over 2 years ago

Après Upgrade et mise à jour :

root@addc:~# apt install -s ubuntu-minimal 
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  gnupg-agent libbind9-140 libboost-iostreams1.58.0 libboost-random1.58.0 libboost-system1.58.0 libboost-thread1.58.0 libcephfs1 libdns162 libicu55 libisc160 libisccc140 libisccfg140 libkadm5clnt-mit9
  liblwres141 libpython-stdlib libpython2.7 libpython2.7-minimal libpython2.7-stdlib libpython3.5 python python-crypto python-dnspython python-minimal python-talloc python2.7 python2.7-minimal sgml-base
  xml-core
Veuillez utiliser « apt autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés : 
  libnetplan0 netplan.io nplan python3-netifaces
Paquets suggérés :
  network-manager | wpasupplicant
Les NOUVEAUX paquets suivants seront installés :
  libnetplan0 netplan.io nplan python3-netifaces ubuntu-minimal
0 mis à jour, 5 nouvellement installés, 0 à enlever et 0 non mis à jour.
Inst libnetplan0 (0.99-0ubuntu3~18.04.5 Ubuntu:18.04/bionic-updates [amd64])
Inst python3-netifaces (0.10.4-0.1build4 Ubuntu:18.04/bionic [amd64])
Inst netplan.io (0.99-0ubuntu3~18.04.5 Ubuntu:18.04/bionic-updates [amd64])
Inst nplan (0.99-0ubuntu3~18.04.5 Ubuntu:18.04/bionic-updates [all])
Inst ubuntu-minimal (1.417.5 Ubuntu:18.04/bionic-updates [amd64])
Conf libnetplan0 (0.99-0ubuntu3~18.04.5 Ubuntu:18.04/bionic-updates [amd64])
Conf python3-netifaces (0.10.4-0.1build4 Ubuntu:18.04/bionic [amd64])
Conf netplan.io (0.99-0ubuntu3~18.04.5 Ubuntu:18.04/bionic-updates [amd64])
Conf nplan (0.99-0ubuntu3~18.04.5 Ubuntu:18.04/bionic-updates [all])
Conf ubuntu-minimal (1.417.5 Ubuntu:18.04/bionic-updates [amd64])

#6 Updated by Joël Cuissinat over 2 years ago

  • Status changed from Nouveau to En cours
  • Assigned To set to Joël Cuissinat

Proposition : ajouter ubuntu-minimal en tant que dépendance de eole-ad-pkg

#7 Updated by Joël Cuissinat over 2 years ago

  • Status changed from En cours to Résolu
  • % Done changed from 0 to 100

#8 Updated by Joël Cuissinat over 2 years ago

  • Status changed from Résolu to Fermé
  • Remaining (hours) set to 0.0

Test OK

Also available in: Atom PDF