Project

General

Profile

Tâche #32966

Scénario #32895: Corrections liées à l'Upgrade de 2.7.2 vers 2.8.1

Seth : ne pas tenter de supprimer une ancienne version d'apache et d'activer des modules apache

Added by Emmanuel GARETTE 2 months ago. Updated 19 days ago.

Status:
Fermé
Priority:
Normal
Assigned To:
Start date:
07/20/2021
Due date:
% Done:

100%

Remaining (hours):
0.0

Associated revisions

Revision 02bdfa95 (diff)
Added by Emmanuel GARETTE 2 months ago

Le post upgrade apache ne doit s'exécuter que si on a vraiment apache (ref #32966)

History

#1 Updated by Emmanuel GARETTE 2 months ago

  • Status changed from Nouveau to En cours
  • Start date set to 07/20/2021

#2 Updated by Emmanuel GARETTE 2 months ago

  • Assigned To set to Emmanuel GARETTE

#3 Updated by Emmanuel GARETTE 2 months ago

  • Status changed from En cours to À valider

#4 Updated by Emmanuel GARETTE 26 days ago

  • % Done changed from 0 to 100

#5 Updated by Ludwig Seys 26 days ago

  • Status changed from À valider to Résolu

#6 Updated by Joël Cuissinat 26 days ago

En réalité, c'est lié à ce qu'on a constaté dans #33037.

Un dc1 avec le paquet seth-education a beaucoup moins de dépendances en 2.7.2 qu'en 2.8 où notamment le paquet eole-web vient déclarer le conteneur "web"...

Mais j'ai encore un doute sur le code quand je vois passer la ligne suivante :

18:18:06             run-parts: executing /tmp/Upgrade-Auto/post_upgrade/10-apache
18:18:06             dpkg-query: aucun paquet ne correspond à *php7.2*

L'emplacement de ce dictionnaire m'interroge :

root@dc1:~# dpkg -S /usr/share/eole/creole/dicos/40_scribe_conteneurs.xml 
eole-ad-dc: /usr/share/eole/creole/dicos/40_scribe_conteneurs.xml

#7 Updated by Joël Cuissinat 19 days ago

  • Status changed from Résolu to Fermé
  • Remaining (hours) set to 0.0

Je suppose que cette modification est surtout pour Seth-Education et AmonEcole mais il vaut mieux ne pas toucher ;)

Also available in: Atom PDF