Project

General

Profile

Tâche #32822

Scénario #32145: Upgrade-Auto 2.7.2 vers 2.8 et 2.6.2 vers 2.7

Upgrade-Auto 2.6.2 vers 2.7, les scripts "post_upgrade" ne sont pas toujours exécutés

Added by Joël Cuissinat almost 3 years ago. Updated almost 3 years ago.

Status:
Fermé
Priority:
Normal
Assigned To:
Start date:
06/21/2021
Due date:
% Done:

100%

Estimated time:
0.00 h
Remaining (hours):
0.0

Description

Je viens de l’expérimenter avec un Zéphir 2.6.2, l'Upgrade se termine directement sur la suppression des derniers paquets de l'ancienne distribution (sans message spécifique) :

   [ ... ]
Suppression de python-zmq (16.0.2-2build2) ...
(Lecture de la base de donnes... 181679 fichiers et rpertoires dj installs.)
Suppression de python-zope.component (4.3.0-1) ...
Suppression de python-zope.event (4.2.0-1) ...
Suppression de python-zope.hookable (4.0.4-4build4) ...
Suppression de ttf-ubuntu-font-family (1:0.83-2) ...
root@zephir:~#

Si on en croit les tests Jenkins, le problème concernerait uniquement (?) les modules Seth et Zéphir !

Associated revisions

Revision 53de54b2 (diff)
Added by Emmanuel GARETTE almost 3 years ago

supprimer les autres /etc/update-manager/release-upgrades.d/*.cfg (ref #32822)

Revision 9c768c54 (diff)
Added by Emmanuel GARETTE almost 3 years ago

installer la dependance sur python-configparser (ref #32822)

Revision b0d44520 (diff)
Added by Emmanuel GARETTE almost 3 years ago

installer la dependance sur python-configparser (ref #32822)

Revision 33a2d29d (diff)
Added by Emmanuel GARETTE almost 3 years ago

installer la dependance sur python-configparser (ref #32822)

Revision 4db7cbce (diff)
Added by Emmanuel GARETTE almost 3 years ago

installer la dependance sur python-configparser (ref #32822)

Revision c7efcbe5 (diff)
Added by Emmanuel GARETTE almost 3 years ago

installer la dependance sur python-configparser (ref #32822)

Revision a9bd9b94 (diff)
Added by Emmanuel GARETTE almost 3 years ago

installer la dependance sur python-configparser (ref #32822)

Revision 7d74ba24 (diff)
Added by Emmanuel GARETTE almost 3 years ago

supprimer les autres /etc/update-manager/release-upgrades.d/*.cfg (ref #32822)

History

#1 Updated by Emmanuel GARETTE almost 3 years ago

  • Status changed from Nouveau to En cours
  • Assigned To set to Emmanuel GARETTE
  • % Done changed from 0 to 100

#2 Updated by Emmanuel GARETTE almost 3 years ago

  • Status changed from En cours to Résolu

#3 Updated by Joël Cuissinat almost 3 years ago

  • Status changed from Résolu to Fermé
  • Remaining (hours) set to 0.0

Upgrade OK (pb lxc mis à part #32857)

#4 Updated by Fabrice Barconnière almost 3 years ago

  • Subject changed from Upgrade-Auto 2.6.2 vers 2.7, les scripts "post_upgrade" ne sont pas troujours exécutés to Upgrade-Auto 2.6.2 vers 2.7, les scripts "post_upgrade" ne sont pas toujours exécutés
  • Estimated time set to 0.00 h

Also available in: Atom PDF