Anomalie #318
Bacula ne restaure pas les ACLs
100%
Description
En suivant la procédure mise dans la doc, les fichiers ou répertoires sont bien restaurés, mais pas les ACLs.
Demandes liées
Révisions associées
ré-adaptation de la configuration baculafichiers.d/fichiers.conf FIXES #318
ré-adaptation du fichier tmpl/baculafichiers.conf FIXES #318
add comment in dropdown titles; fix #318
missing title in flat dropdown; see #318
Historique
#1 Mis à jour par Emmanuel GARETTE il y a plus de 16 ans
Procédure utilisée :
- montage des supports : /usr/share/eole/bacula/montage.sh pre
- lancement de bconsole : bconsole c /etc/bacula/bconsole.conf restore fileset=Complete et choisir dans les options (généralement 5 ou 6)
- marquer les fichiers à sauvegarder avec la commande "mark nom_du_fichier"
- possibilité de lister les fichiers du répertoire courant avec "ls"
- possibilité de changer de répertoire courant avec "cd"
- démarquer avec la commande "unmark"
- lorsque c'est fini : "done"
- choisir "4 : Restore"
- OK pour le lancement ? : oui
- taper "messages" pour lire les messages
- jusqu'à : "AfterJob : * Restauration terminée *"
#2 Mis à jour par Klaas TJEBBES il y a plus de 16 ans
Après test, ceci ne se produit que sur AmonEcole (Scribe virtualisé).
Aucun message d'erreur n'apparait dans bacula.log
Les options dans /etc/mtab de Scribe-virt ne sont pas correctes, il manque les options "acl" et "user_xattr".
#3 Mis à jour par Luc Bourdot il y a plus de 16 ans
- Assigné à mis à Klaas TJEBBES
#4 Mis à jour par Joël Cuissinat il y a plus de 16 ans
- Projet changé de Scribe à conf-eolevz
#5 Mis à jour par Joël Cuissinat il y a plus de 16 ans
fichier en cause : ./virt/conf/scribe.conf
#6 Mis à jour par Joël Cuissinat il y a plus de 16 ans
- Projet changé de conf-eolevz à Distribution EOLE
#7 Mis à jour par Joël Cuissinat il y a plus de 16 ans
- Priorité changé de Normal à 6
J'ai utilisé le script /usr/share/eole/bacula/restauration-bacula.sh sur un Scribe normal et je n'ai pas retrouvé mes ACL, ce n'est donc pas spécifique à eoleVZ !!!
Il faudrait faire quelque chose, qui à être obligé de faire un getfacl > home.acl à l'ancienne.
#8 Mis à jour par Joël Cuissinat il y a presque 16 ans
- Version cible mis à Mises à jour 2.2.2 - 06 RC
Paquet bacula_5.0.1-0eole1 (lucid) mis à disposition en version de développement (Query-Auto -D)
=> tester si il résout le problème !
#9 Mis à jour par Joël Cuissinat il y a presque 16 ans
- % réalisé changé de 0 à 10
Encore faudrait-il que la mise à jour passe !
Paramétrage de bacula-director-sqlite3 (5.0.1-0eole1) ... config: Running dbc_go bacula-director-sqlite3 configure 3.0.3-1eole3 *** Checking type of existing DB at /var/lib/bacula/bacula.db: SQLite v3 dbconfig-common: writing config to /etc/dbconfig-common/bacula-director-sqlite3.conf detected upgrade from previous non-dbconfig version. creating database backup in /var/cache/dbconfig-common/backups/bacula-director-sqlite3_3.0.3-1eole3.sqlite3. applying upgrade sql for 3.0.3-1eole3 -> 5.0.0. SQL error near line 2: duplicate column name: HasCache SQL error near line 3: duplicate column name: Reviewed SQL error near line 4: duplicate column name: Comment SQL error near line 5: duplicate column name: HasCache SQL error near line 6: duplicate column name: Reviewed SQL error near line 7: duplicate column name: Comment SQL error near line 9: duplicate column name: Severity SQL error near line 17: table PathHierarchy already exists SQL error near line 24: index pathhierarchy_ppathid already exists SQL error near line 27: table PathVisibility already exists SQL error near line 36: index pathvisibility_jobid already exists SQL error near line 39: index basefiles_jobid_idx already exists SQL error near line 44: no such index: inx4 SQL error near line 46: index file_jpf_idx already exists error encountered processing /usr/share/dbconfig-common/data/bacula-director-sqlite3/upgrade/sqlite3/5.0.0: dbconfig-common: bacula-director-sqlite3 configure: aborted.
#10 Mis à jour par Jean-Marc MELET il y a presque 16 ans
- Statut changé de Nouveau à En attente d'informations
Oui on a eu aussi le même problème.
On a réussi à forcer la maj en faisant:
- suppression de toutes les sauvegardes effectuées et réinitialisation du catalogue (/usr/share/eole/bacula/regen_catalog.sh)
- suppression et purge de tous les paquets bacula (et donc horus-pkg avec)
- suppression de /usr/share/dbconfig-common/data/*, de /usr/share/eole/bacula/ et de /var/lib/bacula/
- modification du serveur de maj en test-eoleng.ac-dijon.fr
- Réinstallation de horus-pkg (et donc des nouveaux paquets bacula avec)
Sinon, une réinstallation complète de la distrib avec maj sur test-eoleng.ac-dijon.fr fonctionne aussi.
Cependant, nous avons à nouveau effectué un test de sauvegarde/restauration et nous avons toujours le même problème sur les ACLs... :(
#11 Mis à jour par Joël Cuissinat il y a presque 16 ans
- Version cible changé de Mises à jour 2.2.2 - 06 RC à 48
#12 Mis à jour par Joël Cuissinat il y a plus de 15 ans
- Version cible changé de 48 à Mises à jour 2.2.3 - 01 RC
#13 Mis à jour par Joël Cuissinat il y a plus de 15 ans
- Version cible changé de Mises à jour 2.2.3 - 01 RC à EOLE 2.3 Stable
#14 Mis à jour par Klaas TJEBBES il y a plus de 15 ans
- Projet changé de Distribution EOLE à conf-scribe
#15 Mis à jour par Klaas TJEBBES il y a plus de 15 ans
- Statut changé de En attente d'informations à Résolu
- % réalisé changé de 10 à 100
Appliqué par commit 0c24547ccc5aeb47a71848e621a2795107ca736e.
#16 Mis à jour par Klaas TJEBBES il y a plus de 15 ans
Appliqué par commit 2dc691a593c28c1b47187fdd0b35f0dfe345b910.
#17 Mis à jour par Joël Cuissinat il y a plus de 15 ans
- Statut changé de Résolu à Fermé
OK en candidate