Project

General

Profile

Scénario #31365

Impossible d’afficher le menu de démarrage des images ISO EOLE/Ubuntu sur Hâpy

Added by Fabrice Barconnière 10 months ago. Updated 9 months ago.

Status:
Terminé (Sprint)
Priority:
Normal
Assigned To:
Category:
-
Start date:
12/17/2020
Due date:
12/18/2020
% Done:

100%

Estimated time:
0.00 h
Story points:
-
Remaining (hours):
0.00 hour
Velocity based estimate:
Release:
Release relationship:
Auto

Description

Test Correction HP-001-02 - Test Pré paramétrage HAPY avec image EOLE (2.8.0-RC1)

Pas №12

graphics initialization failed
Error setting up gfxboot
boot:

Exécution Squash-TM


Subtasks

Tâche #31439: Utiliser l’interface SPICE pour les modèles EOLE initialisés durant instance/reconfigureFerméDaniel Dehennin


Related issues

Related to Distribution EOLE - Scénario #31222: Le déploiement de VM doit être fonctionnel sur Hâpy 2.8.0 Terminé (Sprint) 11/17/2020 12/18/2020

History

#1 Updated by Fabrice Barconnière 10 months ago

  • Subject changed from Correction HP-001-02 - Test Pré paramétrage HAPY avec image EOLE (2.8.0-RC1) to Correction HP-001-02 - Test Pré paramétrage HAPY avec image EOLE (2.8.0-RC1)

#2 Updated by Daniel Dehennin 10 months ago

J’ai fait un certain nombre de tests sur la machine physique igor.eole.lan :

  • Test avec d’autres images ISO
    • Démarrage de l’ISO officielle Ubuntu-20.04.1-dektop.iso ⮕ sans succès
    • Démarrage d’une debian-testing-live-gnome.iso ⮕ OK
    • Démarrage d’une debian-10.7.0-amd64-DVD-1.iso ⮕ OK
  • Test des ISO EOLE avec différent paramètres
    • Ajout d’une entrée pour définir la carte vidéo à vga ⮕ sans succès
    • Ajout d’une entrée pour définir la carte vidéo à qxl ⮕ sans succès
    • Ajout d’une entrée pour définir la carte vidéo avec vram=16384 ⮕ sans succès

#3 Updated by Daniel Dehennin 10 months ago

  • Subject changed from Correction HP-001-02 - Test Pré paramétrage HAPY avec image EOLE (2.8.0-RC1) to Impossible d’afficher le menu de démarrage des images ISO EOLE/Ubuntu sur Hâpy
  • Description updated (diff)
  • Parent task deleted (#31241)

#4 Updated by Daniel Dehennin 10 months ago

  • Tracker changed from Tâche to Scénario
  • Project changed from Distribution EOLE to EOLE OpenNebula
  • Due date set to 12/18/2020
  • Release set to EOLE 2.8.0

Je vais tester avec une Ubuntu Desktop 20.04 et gnome-boxes pour voir si le problème se reproduit tout le temps.

#5 Updated by Daniel Dehennin 9 months ago

Sur une Ubuntu desktop 20.04, l’application gnome-boxes arrive bien à afficher le menu de démarrage de nos images ISO mais utilise SPICE (qui fonctionne aussi sur Hâpy)

  12407 ?        Sl     2:31  \_ /usr/bin/qemu-system-x86_64 -name guest=boxes-unknown,debug-threads=on -S -object secret,id=masterKey0,format=raw,file=/home/eole/.config/libvirt/qemu/lib/domain-1-boxes-unknown/master-key.aes -machine pc-i440fx-focal,accel=kvm,usb=off,dump-guest-core=off -cpu host -m 5140 -overcommit mem-lock=off -smp 8,sockets=1,cores=4,threads=2 -uuid efb6ab59-92d5-45ab-a871-9e6a30a7ef18 -no-user-config -nodefaults -chardev socket,id=charmonitor,fd=28,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc,driftfix=slew -global kvm-pit.lost_tick_policy=delay -no-hpet -no-reboot -global PIIX4_PM.disable_s3=1 -global PIIX4_PM.disable_s4=1 -boot menu=on,strict=on -device ich9-usb-ehci1,id=usb,bus=pci.0,addr=0x5.0x7 -device ich9-usb-uhci1,masterbus=usb.0,firstport=0,bus=pci.0,multifunction=on,addr=0x5 -device ich9-usb-uhci2,masterbus=usb.0,firstport=2,bus=pci.0,addr=0x5.0x1 -device ich9-usb-uhci3,masterbus=usb.0,firstport=4,bus=pci.0,addr=0x5.0x2 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x6 -device usb-ccid,id=ccid0,bus=usb.0,port=1 -blockdev {"driver":"file","filename":"/home/eole/.local/share/gnome-boxes/images/boxes-unknown","node-name":"libvirt-2-storage","cache":{"direct":false,"no-flush":false},"auto-read-only":true,"discard":"unmap"} -blockdev {"node-name":"libvirt-2-format","read-only":false,"cache":{"direct":false,"no-flush":false},"driver":"qcow2","file":"libvirt-2-storage","backing":null} -device ide-hd,bus=ide.0,unit=0,drive=libvirt-2-format,id=ide0-0-0,bootindex=2,write-cache=on -blockdev {"driver":"file","filename":"/home/eole/Téléchargements/eole-2.8.0-rc1-alternate-amd64.iso","node-name":"libvirt-1-storage","auto-read-only":true,"discard":"unmap"} -blockdev {"node-name":"libvirt-1-format","read-only":true,"driver":"raw","file":"libvirt-1-storage"} -device ide-cd,bus=ide.1,unit=0,drive=libvirt-1-format,id=ide0-1-0,bootindex=1 -netdev user,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=52:54:00:ec:0a:6c,bus=pci.0,addr=0x3 -chardev spicevmc,id=charsmartcard0,name=smartcard -device ccid-card-passthru,chardev=charsmartcard0,id=smartcard0,bus=ccid0.0 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -chardev spicevmc,id=charchannel0,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.spice.0 -chardev spiceport,id=charchannel1,name=org.spice-space.webdav.0 -device virtserialport,bus=virtio-serial0.0,nr=2,chardev=charchannel1,id=channel1,name=org.spice-space.webdav.0 -spice port=0,disable-ticketing,image-compression=off,seamless-migration=on -device qxl-vga,id=video0,ram_size=67108864,vram_size=67108864,vram64_size_mb=0,vgamem_mb=16,max_outputs=1,bus=pci.0,addr=0x2 -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -chardev spicevmc,id=charredir0,name=usbredir -device usb-redir,chardev=charredir0,id=redir0,bus=usb.0,port=2 -chardev spicevmc,id=charredir1,name=usbredir -device usb-redir,chardev=charredir1,id=redir1,bus=usb.0,port=3 -chardev spicevmc,id=charredir2,name=usbredir -device usb-redir,chardev=charredir2,id=redir2,bus=usb.0,port=4 -chardev spicevmc,id=charredir3,name=usbredir -device usb-redir,chardev=charredir3,id=redir3,bus=usb.0,port=5 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x7 -sandbox on,obsolete=deny,elevateprivileges=deny,spawn=deny,resourcecontrol=deny -msg timestamp=on

#6 Updated by Daniel Dehennin 9 months ago

Pas mieux avec des paquets qemu plus récents.

  • J’ai installé qemu venant de hirsute
    root@hapy:~# cat > /etc/apt/sources.list.d/hirsute.list <<EOF
    # New version Hirsute
    deb [ arch=amd64 ] http://eole.ac-dijon.fr/ubuntu hirsute main universe multiverse restricted
    deb [ arch=amd64 ] http://eole.ac-dijon.fr/ubuntu hirsute-security main universe multiverse restricted
    deb [ arch=amd64 ] http://eole.ac-dijon.fr/ubuntu hirsute-updates main universe multiverse restricted
    EOF
    
  • J’ai configuré la version Hirsute pour ne pas tout mettre à jour
    root@hapy:~# cat /etc/apt/preferences.d/hirsute.pref 
    Package: *
    Pin: release n=hirsute
    Pin-Priority: 100
    
  • J’ai installé les paquets nécessaire au fonctionnement de qemu
    root@hapy:~# apt -t hirsute install qemu-system-x86
    […]
    

#7 Updated by Daniel Dehennin 9 months ago

  • Assigned To set to Daniel Dehennin

#8 Updated by Daniel Dehennin 9 months ago

J’ai ouvert une demande lauchpad

#9 Updated by Joël Cuissinat 9 months ago

  • Status changed from Nouveau to Terminé (Sprint)

#10 Updated by Joël Cuissinat 9 months ago

  • Related to Scénario #31222: Le déploiement de VM doit être fonctionnel sur Hâpy 2.8.0 added

Also available in: Atom PDF