Project

General

Profile

Tâche #31020

Scénario #31105: Correction des tests avant qualif 2.8.0 stable

Correction test HP-003-01 - Préparer les configurations Hâpy (2.8.0-beta1)

Added by Fabrice Barconnière 18 days ago. Updated about 6 hours ago.

Status:
Résolu
Priority:
Normal
Start date:
04/10/2020
Due date:
% Done:

100%

Estimated time:
0.00 h
Remaining (hours):
0.0

Description

  • Vérifier si les noms hapy1, hapy2 et hapy 3 sont bien résolus avant instance
  • Regarder pourquoi le serveur ne les résout pas pendant l'instance

Pas №20

Impossible de quitter gen_config en console VNC sur un module non instancié
Aucune fenêtre de confirmation pour quitter gen_config. Un onglet "mozilla.org/privacy/..." tourne sans cesse et semble tout bloquer
Arrêt des 2 autres VM hapy2 et 3 dans one.eole.lan, ssh sur hapy.ac-test.fr et pkill -f firefox pour pouvoir continuer le test

Pas №30

Erreur en posttemplate :

run-parts: executing /usr/share/eole/posttemplate/00-eole-common instance
Génération des règles de pare-feuiptables v1.8.4 (legacy): host/network `hapy1' not found
Try `iptables -h' or 'iptables --help' for more information.
iptables v1.8.4 (legacy): host/network `hapy3' not found
Try `iptables -h' or 'iptables --help' for more information.
iptables v1.8.4 (legacy): host/network `hapy1' not found
Try `iptables -h' or 'iptables --help' for more information.
iptables v1.8.4 (legacy): host/network `hapy3' not found
Try `iptables -h' or 'iptables --help' for more information.
run-parts: /usr/share/eole/bastion/data/60-one exited with return code 2
Erreur à l'exécution des scripts de firewall
Erreur à la génération des règles de pare-feu
run-parts: /usr/share/eole/posttemplate/00-eole-common exited with return code 1
Erreur : posttemplate

Pas №37

L'instance se termine mais une erreur iptables s'est également produite en posttemplace

Génération des règles de pare-feuiptables v1.8.4 (legacy): host/network `hapy?' not found

Exécution Squash-TM

Associated revisions

Revision 29d2525d (diff)
Added by Fabrice Barconnière about 12 hours ago

netplan-apply.service musts start openvswitch-switch.service if exists

ref #31020

History

#1 Updated by Fabrice Barconnière 18 days ago

  • Description updated (diff)

#2 Updated by Fabrice Barconnière 18 days ago

  • Description updated (diff)

#3 Updated by Fabrice Barconnière 18 days ago

  • Description updated (diff)

#4 Updated by Fabrice Barconnière 14 days ago

  • Subject changed from Correction HP-003-01 - Préparer les configurations Hâpy (2.8.0-beta1) to Correction test HP-003-01 - Préparer les configurations Hâpy (2.8.0-beta1)
  • Description updated (diff)

#5 Updated by Gilles Grandgérard 13 days ago

  • Parent task changed from #30862 to #31105

#6 Updated by Fabrice Barconnière 3 days ago

  • Status changed from Nouveau to En cours

#7 Updated by Fabrice Barconnière 3 days ago

  • Assigned To set to Fabrice Barconnière

#8 Updated by Fabrice Barconnière 3 days ago

Plusieurs problèmes :
  • Les 3 VM hapy1, hapy2 et hapy3 ont la même adresse IP, du coup les requêtes réseaux n'aboutissent pas correctement
  • Si ont désactives les 2 autres VM, les commandes host hapy1, host hapy2 et host hapy3 fonctionnent
    • Toutefois l'interface ens4 est à l'état down au moment de la génération des règles de firewall, donc pas de requête réseau possible. Si j'ajoute ip link set ens4 up juste avant la ligne . /usr/share/eole/firewall.start de posttemplate/00-eole-common, l'instance passe.

#9 Updated by Fabrice Barconnière 3 days ago

Trouvé : si openvswitch-switch n'est pas démarré :

root@hapy2:~# systemctl stop openvswitch-switch.service
root@hapy2:~# systemctl restart netplan-apply.service
Job for netplan-apply.service failed because the control process exited with error code.
See "systemctl status netplan-apply.service" and "journalctl -xe" for details.
root@hapy2:~# systemctl status netplan-apply.service
● netplan-apply.service - Apply netplan config
     Loaded: loaded (/lib/systemd/system/netplan-apply.service; enabled; vendor preset: enabled)
     Active: failed (Result: exit-code) since Fri 2020-11-20 15:39:16 CET; 1min 1s ago
    Process: 38658 ExecStart=/usr/sbin/netplan apply (code=exited, status=1/FAILURE)
   Main PID: 38658 (code=exited, status=1/FAILURE)

nov. 20 15:39:16 hapy2 netplan[38658]:   File "/usr/share/netplan/netplan/cli/ovs.py", line 128, in apply_ovs_cleanup
nov. 20 15:39:16 hapy2 netplan[38658]:     out = subprocess.check_output([OPENVSWITCH_OVS_VSCTL, '--columns=name,external-ids',
nov. 20 15:39:16 hapy2 netplan[38658]:   File "/usr/lib/python3.8/subprocess.py", line 411, in check_output
nov. 20 15:39:16 hapy2 netplan[38658]:     return run(*popenargs, stdout=PIPE, timeout=timeout, check=True,
nov. 20 15:39:16 hapy2 netplan[38658]:   File "/usr/lib/python3.8/subprocess.py", line 512, in run
nov. 20 15:39:16 hapy2 netplan[38658]:     raise CalledProcessError(retcode, process.args,
nov. 20 15:39:16 hapy2 netplan[38658]: subprocess.CalledProcessError: Command '['/usr/bin/ovs-vsctl', '--columns=name,external-ids', '-f', 'csv', '-d', 'bare', '--no-headings', 'list', 'Port']' returned non-zero exit status 1.
nov. 20 15:39:16 hapy2 systemd[1]: netplan-apply.service: Main process exited, code=exited, status=1/FAILURE
nov. 20 15:39:16 hapy2 systemd[1]: netplan-apply.service: Failed with result 'exit-code'.
nov. 20 15:39:16 hapy2 systemd[1]: Failed to start Apply netplan config.

#10 Updated by Fabrice Barconnière 3 days ago

Le problème n'est pas lié au mode HA. Il existe également sur instance-default-2.8.0 : https://dev-eole.ac-dijon.fr/jenkins/job/2.8.0/job/test-instance-acahapy-2.8.0-amd64/202/console
Ce problème n'existe pas en 2.7.2

#11 Updated by Fabrice Barconnière about 9 hours ago

https://dev-eole.ac-dijon.fr/squash/executions/11328

reconfigure hapy2 ou 3 :

run-parts: executing /usr/share/eole/postservice/99-one-hooks-manager reconfigure
[one.hook.update] Cannot process request, no leader found
Warning: vm-close_ports hook creation failed !
[one.hook.update] Cannot process request, no leader found
Warning: vm-close_ports_on_shutdown hook creation failed !

reconfigure hapy1, Erreur en postservice/30-one-mng :

Host default already present in cluster
[ERROR] [Host sync failed]

#12 Updated by Fabrice Barconnière about 6 hours ago

  • % Done changed from 0 to 100

J'ai tout recommencé en ajoutant la commande ip link set ens4 up en dernier pas du test HP-003-01 avant l'instance de hapy1 et là, les 2 tests sont passés.

#13 Updated by Fabrice Barconnière about 6 hours ago

  • Status changed from En cours to Résolu

Also available in: Atom PDF