Project

General

Profile

Tâche #30070

Scénario #29844: Préparer une ISO 2.8.0 alpha

Tester manuellement l'installation d'une Eolebase

Added by Daniel Dehennin 2 months ago. Updated 24 days ago.

Status:
Fermé
Priority:
Normal
Assigned To:
Start date:
05/06/2020
Due date:
% Done:

100%

Remaining (hours):
0.0

Description

Avant de lancer Jenkins sur la nouvelle ISO.

History

#1 Updated by Daniel Dehennin 2 months ago

  • Status changed from Nouveau to En cours
  • Assigned To set to Daniel Dehennin

#2 Updated by Daniel Dehennin 2 months ago

Impossible d'installer une eolebase depuis l'image ISO

May  6 11:08:48 in-target: Certains paquets ne peuvent être installés. Ceci peut signifier
May  6 11:08:48 in-target: que vous avez demandé l'impossible, ou bien, si vous utilisez
May  6 11:08:48 in-target: la distribution unstable, que certains paquets n'ont pas encore
May  6 11:08:48 in-target: été créés ou ne sont pas sortis d'Incoming.
May  6 11:08:48 in-target: L'information suivante devrait vous aider à résoudre la situation : 
May  6 11:08:48 in-target: 
May  6 11:08:48 in-target: Les paquets suivants contiennent des dépendances non satisfaites :
May  6 11:08:48 in-target:  eole-server : Dépend: creole (>= 2.5.0~1-6) mais ne sera pas installé
May  6 11:08:48 in-target:                Dépend: eole-ead mais ne sera pas installé
May  6 11:08:48 in-target:                Dépend: eole-ead3 mais ne sera pas installé
May  6 11:08:48 in-target:                Dépend: eole-genconfig mais ne sera pas installé
May  6 11:08:48 in-target:                Dépend: eole-nut mais ne sera pas installé
May  6 11:08:48 in-target: E: 
May  6 11:08:48 in-target: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Tentative d'installation manuelle de creole

May  6 11:11:57 in-target: Les paquets suivants contiennent des dépendances non satisfaites :
May  6 11:11:57 in-target:  creole : Dépend: python-creole (= 2.8.0-25) mais ne sera pas installé

Tentative d'installation de python-eole

May  6 11:12:16 in-target: Les paquets suivants contiennent des dépendances non satisfaites :
May  6 11:12:16 in-target:  python-creole : Dépend: python-tiramisu (>= 2.0~13-1) mais ne sera pas installé
May  6 11:12:16 in-target:                  Dépend: python-configobj mais il n'est pas installable
May  6 11:12:16 in-target:                  Dépend: python-pyeole (>= 2.5.0~1-5) mais ne sera pas installé
May  6 11:12:16 in-target:                  Dépend: python-cherrypy3 mais il n'est pas installable
May  6 11:12:16 in-target:                  Dépend: python-ipy mais il n'est pas installable
May  6 11:12:16 in-target:                  Dépend: python-requests mais il n'est pas installable
May  6 11:12:16 in-target:                  Dépend: python-eventlet mais il n'est pas installable
May  6 11:12:16 in-target:                  Dépend: python-systemd mais il n'est pas installable
May  6 11:12:16 in-target: E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

#3 Updated by Daniel Dehennin 2 months ago

Les paquets python marqués mais il n'est pas installable n'existent pas sur Focal.

Pour le développement, il faudrait une Focal sans les dépôts Bionic.

#4 Updated by Daniel Dehennin 2 months ago

  • Parent task deleted (#29844)

#5 Updated by Daniel Dehennin 2 months ago

#6 Updated by Daniel Dehennin 2 months ago

Voilà, en fait tout ceci est dû au fait qu’il n’y a plus de paquet python-, tout est en python3-

root@eolebase:~# apt policy python3-configobj python3-cherrypy3 python3-ipy python3-requests python3-eventlet python3-systemd
python3-configobj:
  Installé : 5.0.6-4
  Candidat : 5.0.6-4
 Table de version :
 *** 5.0.6-4 500
        500 http://test-eole.ac-dijon.fr/ubuntu focal/main amd64 Packages
        100 /var/lib/dpkg/status
python3-cherrypy3:
  Installé : 8.9.1-6
  Candidat : 8.9.1-6
 Table de version :
 *** 8.9.1-6 500
        500 http://test-eole.ac-dijon.fr/ubuntu focal/main amd64 Packages
        100 /var/lib/dpkg/status
python3-ipy:
  Installé : 1:1.00-1
  Candidat : 1:1.00-1
 Table de version :
 *** 1:1.00-1 500
        500 http://test-eole.ac-dijon.fr/ubuntu focal/universe amd64 Packages
        100 /var/lib/dpkg/status
python3-requests:
  Installé : 2.22.0-2ubuntu1
  Candidat : 2.22.0-2ubuntu1
 Table de version :
 *** 2.22.0-2ubuntu1 500
        500 http://test-eole.ac-dijon.fr/ubuntu focal/main amd64 Packages
        100 /var/lib/dpkg/status
python3-eventlet:
  Installé : 0.25.1-2build1
  Candidat : 0.25.1-2build1
 Table de version :
 *** 0.25.1-2build1 500
        500 http://test-eole.ac-dijon.fr/ubuntu focal/main amd64 Packages
        100 /var/lib/dpkg/status
python3-systemd:
  Installé : 234-3build2
  Candidat : 234-3build2
 Table de version :
 *** 234-3build2 500
        500 http://test-eole.ac-dijon.fr/ubuntu focal/main amd64 Packages
        100 /var/lib/dpkg/status

#7 Updated by Joël Cuissinat about 1 month ago

#8 Updated by Joël Cuissinat about 1 month ago

  • Status changed from En cours to Résolu
  • Parent task set to #30069

#9 Updated by Joël Cuissinat about 1 month ago

  • Parent task changed from #30069 to #29844

#10 Updated by Daniel Dehennin about 1 month ago

  • % Done changed from 0 to 100

#11 Updated by Gilles Grandgérard 24 days ago

  • Status changed from Résolu to Fermé
  • Remaining (hours) set to 0.0

Also available in: Atom PDF