Project

General

Profile

Scénario #29747

L’utilisation de kerberos doit dispenser de saisir un mot de passe sur Eole 2.8.0

Added by Benjamin Bohard about 1 year ago. Updated 10 months ago.

Status:
Terminé (Sprint)
Priority:
Normal
Assigned To:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Story points:
2.0
Velocity based estimate:
Release:
Release relationship:
Auto

Related issues

Related to EOLE AD DC - Scénario #29624: Erreur reconfigure sur Seth + eole-gpo-script Terminé (Sprint) 09/22/2016 05/22/2020
Follows Distribution EOLE - Scénario #29493: Passer nos outils "GPO" en python3 sur EOLE 2.8.0 Terminé (Sprint) 03/02/2020 03/20/2020

Associated revisions

Revision 8210b3e1 (diff)
Added by Joël Cuissinat about 1 year ago

monitor_eole_ci : ajout réponse (temporaire) pour les GPO

Ref: #29747

History

#1 Updated by Benjamin Bohard about 1 year ago

Il y a deux étapes où, malgré la volonté d’utiliser kerberos, un mot de passe est demandé :
  • samba-tool gpo del
  • gpo-tool policy add

Pour ce dernier, on peut forcer l’usage de kerberos comme c’est déjà fait dans le script d’importation.
Pour le premier…

#2 Updated by Benjamin Bohard about 1 year ago

  • Status changed from Nouveau to En cours

#3 Updated by Benjamin Bohard about 1 year ago

  • Status changed from En cours to Nouveau

Forcer l’utilisation de kerberos dans le code l’énorme désavantage de ne plus permettre des usages utilisant le compte (option -U). Ça impliquerait de réviser également le code contenu dans seth-ecologie.

Reste le problème de l’autre commande samba-tool pour laquelle je n’ai pas trouvé comment forcer l’usage de kerberos (ni pourquoi il ne l’utilise pas).

#4 Updated by Joël Cuissinat about 1 year ago

  • Parent task deleted (#29493)

#5 Updated by Joël Cuissinat about 1 year ago

  • Tracker changed from Tâche to Scénario
  • Subject changed from L’utilisation de kerberos doit dispenser de saisir un mot de passe to L’utilisation de kerberos doit dispenser de saisir un mot de passe sur Eole 2.8.0
  • Target version deleted (Prestation Cadoles MEN 10-12)
  • Start date deleted (03/02/2020)
  • Release set to EOLE 2.8.0
  • Story points set to 2.0

#6 Updated by Joël Cuissinat about 1 year ago

  • Follows Scénario #29493: Passer nos outils "GPO" en python3 sur EOLE 2.8.0 added

#7 Updated by Gilles Grandgérard about 1 year ago

  • Related to Scénario #29624: Erreur reconfigure sur Seth + eole-gpo-script added

#8 Updated by Gilles Grandgérard 10 months ago

A été corrigé pour ne pas utiliser kerberos

#9 Updated by Gilles Grandgérard 10 months ago

  • Status changed from Nouveau to Terminé (Sprint)

Also available in: Atom PDF