Project

General

Profile

Anomalie #2720

Le script upgrade_scribe.py ne fonctionne plus !

Added by Joël Cuissinat over 10 years ago. Updated over 10 years ago.

Status:
Fermé
Priority:
Normal
Assigned To:
Category:
-
Start date:
01/13/2012
Due date:
% Done:

100%

Estimated time:
0.75 h
Spent time:
Distribution:
EOLE 2.2

Description

Suite à l'ajout de l'attribut ldap ENTEleveStructRattachId, le script : /usr/share/eole/backend/upgrade_scribe.py ne fonctionne plus !

=> KeyError dans gen_enteleve_attrs sur la ligne suivante :

    attrs.append((MOD_REPLACE, 'ENTEleveStructRattachId', args['rattachid']))

Associated revisions

Revision 3a8a355f (diff)
Added by Joël Cuissinat over 10 years ago

Correction pour le script upgrade_scribe.py (fixes #2720 @15m)
  • scribe/eleves.py : initialisation de l'argument obligatoire : "rattachid"

History

#1 Updated by Joël Cuissinat over 10 years ago

  • Status changed from Nouveau to Résolu
  • % Done changed from 0 to 100

#2 Updated by Fabrice Barconnière over 10 years ago

  • Status changed from Résolu to Fermé

Also available in: Atom PDF