Project

General

Profile

Tâche #23641

Scénario #23541: Traitement express MEN (17-19)

Problème de dépendances de paquets pour eole-proftpd

Added by samuel morin almost 3 years ago. Updated almost 3 years ago.

Status:
Fermé
Priority:
Normal
Assigned To:
Start date:
04/17/2018
Due date:
% Done:

100%

Estimated time:
3.00 h
Spent time:
Remaining (hours):
0.0

Description

Bonjour,
j'utilise un module EoleBase pour construire des machines. En voulant installer un service ftp (avec proftpd), je tombe sur des "problèmes" de dépendances.
Le paquet eole-proftpd -pkg ne tire pas le paquet eole-proftpd.
Lorsqu'on installe les deux paquets et qu'on lance gen_config, on a une erreur de variable manquante.
il faut installer le paquet eole-antivirus pour la résoudre.
Ce serait peut-être bien que le paquet eole-proftpd -pkg installe directement tout ce dont il a besoin pour être configuré via gen_config...
Pourquoi cette dépendance à l'antivirus ?

Merci

Associated revisions

Revision 4921a962 (diff)
Added by Joël Cuissinat almost 3 years ago

eole-proftpd nécessite de eole-antivirus

Ref: #23641

Revision 226568b4 (diff)
Added by Joël Cuissinat almost 3 years ago

eole-proftpd nécessite de eole-antivirus

Ref: #23641

Cherry-picked from eole-proftpd:4921a962

History

#1 Updated by Joël Cuissinat almost 3 years ago

  • Assigned To set to Joël Cuissinat
  • Parent task set to #23657

#2 Updated by Joël Cuissinat almost 3 years ago

  • Description updated (diff)
  • Status changed from Nouveau to En cours

Le paquet à installer est bien eole-proftpd et il est censé tirer le paquet eole-proftpd-pkg à l'instance/au reconfigure grâce à la balise <package> présente dans le dictionnaire 25_proftpd.xml : http://eole.ac-dijon.fr/documentations/2.6/partielles/HTML/Eolebase/co/eole-proftpd.html

Ceci dit, je confirme qu'en l'état ce n'est pas fonctionnel :

Erreur - 500 - INTERNAL SERVER ERROR
option activer_clam inconnue
Il faut donc :
  • soit ajouter la dépendance sur eole-antivirus (NB : lié à la fonctionnalité Anti-virus temps réel sur FTP (le plus simple)
  • soit modifier le dictionnaire pour qu'il ne nécessite pas cette variable... (mais cela n'apporte pas grand chose car cela n'empêchera pas l'installation des paquets clamav)

#3 Updated by Joël Cuissinat almost 3 years ago

  • Subject changed from problème de dépendances de paquets (cosmétique) to Problème de dépendances de paquets pour eole-proftpd
  • Estimated time set to 3.00 h
  • Remaining (hours) set to 3.0

#4 Updated by Joël Cuissinat almost 3 years ago

  • Parent task changed from #23657 to #23541

#5 Updated by Joël Cuissinat almost 3 years ago

  • Status changed from En cours to Résolu
  • % Done changed from 0 to 100
  • Remaining (hours) changed from 3.0 to 0.25

Dépendance ajoutée pour EOLE>=2.6.2.

#6 Updated by Joël Cuissinat almost 3 years ago

Vérifié en 2.7.0 :

root@eolebase:~# apt-eole install eole-proftpd 
Action install pour root
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
Les paquets supplémentaires suivants seront installés : 
  clamav clamav-base clamav-freshclam eole-antivirus libclamav7 libcurl4 libllvm3.9 libmspack0 libnghttp2-14 librtmp1 libtfm1
Paquets suggérés :
  clamav-docs libclamunrar7
Les NOUVEAUX paquets suivants seront installés :
  clamav clamav-base clamav-freshclam eole-antivirus eole-proftpd libclamav7 libcurl4 libllvm3.9 libmspack0 libnghttp2-14 librtmp1 libtfm1

#7 Updated by Joël Cuissinat almost 3 years ago

  • Status changed from Résolu to Fermé
  • Remaining (hours) changed from 0.25 to 0.0

Also available in: Atom PDF