Tâche #2312
Distribution EOLE - Scénario #9345: Vérification de la sauvegarde complète sans Zéphir
Résolution DNS pour montage distant dans Bacula
100%
Description
Sur Horus 2.3 le montage distant dans bacula nécessite une résolution DNS alors que sur Eole 2.2 cela n'est pas nécessaire.
Révisions associées
Better reporting for TestCase assertions.
Fixes #2312
Author: mithrandi
Reviewer: oubiwann
Assertions now use a repr() like helper for displaying the values being
asserted; previously, due to the poor default string conversion in JavaScript,
the output was highly ambigous and thus extremely susceptible to
misinterpretation.
Historique
#1 Mis à jour par Joël Cuissinat il y a presque 15 ans
La commande appelée est la même qu'en 2.2 (avec des options de montage en plus) :
/bin/mount -t smbfs -o username=user,password=pass,ip=1.1.1.1 //machine/partage /mnt/sauvegardes
Visiblement l'option "-o 'ip=xxx'" ne suffit plus à éviter la résolution DNS en 2.3 !
mount error: could not resolve address for machine: Name or service not known
Nb : il est possible de tricher en mettant l'adresse IP dans le champ "Nom machine distante" mais ce n'est bien sûr pas très satisfaisant ;)
#2 Mis à jour par Emmanuel GARETTE il y a presque 15 ans
#3 Mis à jour par Nicolas Bergandi il y a environ 13 ans
Nous avons également constaté le problème dans notre académie (Limoges)
constaté par mon collègue :
Montage impossible:
root@h0870022b:~# /bin/mount -t smbfs -o username=user,password=pass,ip=10.87.15.3 //NAS-0870022B-03/Horus /mnt/sauvegardes
mount error: could not resolve address for NAS-0870022B-03: Name or service not known
Montage possible:
root@h0870022b:~# /bin/mount -t smbfs -o username=user,password=pass,ip=10.87.15.3 //10.87.15.3/Horus /mnt/sauvegardes
Password:
root@h0870022b:~#
Montage possible:
root@h0870022b:~# /bin/mount -t smbfs -o username=user,password=pass, //10.87.15.3/Horus /mnt/sauvegardes
Password:
root@h0870022b:~#
Donc le Horus n’implémentant pas de DNS, le problème n'étant pas résolu par Samba, il faudrait demander une correction de la manière suivante:
Si résolution DNS Fonctionne
Faire /bin/mount -t smbfs -o username=user,password=pass,ip=10.87.15.3 //NAS-0870022B-03/Horus /mnt/sauvegardes
Si résolution DNS ne fonctionne pas
Faire /bin/mount -t smbfs -o username=user,password=pass,ip=10.87.15.3 //10.87.15.3/Horus /mnt/sauvegardes
Ou
Faire /bin/mount -t smbfs -o username=user,password=pass, //10.87.15.3/Horus /mnt/sauvegardes
#4 Mis à jour par Fabrice Barconnière il y a plus de 12 ans
- Projet changé de Horus à eole-bacula
- Sujet changé de Horus 2.3 : Résolution DNS pour montage distant dans Bacula à Résolution DNS pour montage distant dans Bacula
- Statut changé de Nouveau à A étudier
- Distribution changé de EOLE 2.3 à EOLE 2.4
Pas de solution en 2.3. Juste vérifier ce comportement en 2.4.
#5 Mis à jour par Emmanuel GARETTE il y a presque 12 ans
- Tracker changé de Anomalie à Tâche
- Tâche parente mis à #9345
#6 Mis à jour par Joël Cuissinat il y a presque 12 ans
- Statut changé de A étudier à Nouveau
- Temps estimé mis à 2.00 h
- Restant à faire (heures) mis à 2.0
#7 Mis à jour par Emmanuel GARETTE il y a presque 12 ans
- Echéance mis à 05/12/2014
- Statut changé de Nouveau à Résolu
- Assigné à mis à Emmanuel GARETTE
- Restant à faire (heures) changé de 2.0 à 0.0
Sur 2.4 le problème n'existe plus.
Exemple si je ne spécifie pas l'IP le montage ne se fait pas :
root@amonecole:~# /bin/mount -t smbfs -o username=admin,password=eole //NAS/admin /mnt/sauvegardes mount error: could not resolve address for NAS: Unknown error
En spécifiant l'IP mais en laissant le nom du serveur cela fonctionne (contrairement à 2.3) :
root@amonecole:~# /bin/mount -t smbfs -o username=admin,password=eole,ip=192.168.0.26 //NAS/admin /mnt/sauvegardes root@amonecole:~# ls /mnt/sauvegardes/ perso
Le montage fonctionne sans domaine mais avec une IP :
root@amonecole:~# /bin/mount -t smbfs -o username=admin,password=eole //192.168.0.26/admin /mnt/sauvegardes root@amonecole:~# ls /mnt/sauvegardes/ perso
#8 Mis à jour par Joël Cuissinat il y a presque 12 ans
- Statut changé de Résolu à Fermé
- % réalisé changé de 0 à 100