Project

General

Profile

Tâche #22730

Scénario #22604: Étude Seth/Scribe - option 1 : utilisation d'Eole-AD

Faire un signalement sur la forge LSC

Added by Gérald Schwartzmann over 3 years ago. Updated over 3 years ago.

Status:
Fermé
Priority:
Normal
Start date:
01/15/2018
Due date:
% Done:

100%

Estimated time:
3.00 h
Spent time:
Remaining (hours):
0.0

Description

Signaler que LSC 2.4.1 ne fonctionne pas avec la version 9 d'openJDK-jre en standard sur Ubuntu 16.04


Related issues

Related to Distribution EOLE - Tâche #23184: S'assurer que la version 8 de java est celle utilisée Fermé 03/02/2018

Associated revisions

Revision a05e2426 (diff)
Added by Fabrice Barconnière over 3 years ago

Adapt lsc.xml template for java 8

ref #22730

Revision 25358f6c (diff)
Added by Fabrice Barconnière over 3 years ago

LSC works up to java 8

ref #22730

History

#1 Updated by Fabrice Barconnière over 3 years ago

  • Estimated time set to 3.00 h
  • Remaining (hours) set to 3.0

Question posée sur le canal IRC du projet #lsc-project de freenode :

<barco> hello, i use LSC 2.1.4-1 on Ubuntu 16.04. Only openjdk-8-jre and openjdk-9-jre packages are available on his version but it doesn't work. Is there any way to make it works with these versions of java ?
<barco> if i install open-jdk-7-jre from ppa.launchpad.net, it works.
<barco> With openjdk-8-jre, i obtains this error : ERROR - Fail to compute expression: "CN=" + java.lang.String(srcBean.getDatasetFirstValueById
<barco> Reason: javax.script.ScriptException: TypeError: java.lang.String is not a function in <eval> at line number 5
<barco> with openjdk-9-jre : ERROR - Fail to compute expression: "CN=" + java.lang.String(srcBean.getDatasetFirstValueById
<barco> Reason: javax.script.ScriptException: ReferenceError: "importPackage" is not defined in <eval> at line number 3

#2 Updated by Scrum Master over 3 years ago

  • Status changed from Nouveau to En cours

#3 Updated by Scrum Master over 3 years ago

  • Assigned To set to Fabrice Barconnière

#4 Updated by Fabrice Barconnière over 3 years ago

  • Status changed from En cours to Résolu
  • % Done changed from 0 to 100
  • Remaining (hours) changed from 3.0 to 0.1

#5 Updated by Fabrice Barconnière over 3 years ago

LSC fonctionnel avec java 8 sur Scribe 2.6.2

#6 Updated by Scrum Master over 3 years ago

  • Status changed from Résolu to Fermé
  • Remaining (hours) changed from 0.1 to 0.0

#7 Updated by Gérald Schwartzmann over 3 years ago

  • Related to Tâche #23184: S'assurer que la version 8 de java est celle utilisée added

Also available in: Atom PDF