Project

General

Profile

Tâche #22204

Scénario #22222: Corriger les dysfonctionnement rencontrés à l'upgrade 2.5.2 vers 2.6.2

Upgrade Amon : e2guardian doit se mettre à jour sans erreur

Added by Gérald Schwartzmann over 3 years ago. Updated over 3 years ago.

Status:
Fermé
Priority:
Normal
Assigned To:
Start date:
11/28/2017
Due date:
% Done:

100%

Estimated time:
2.00 h
Spent time:
Remaining (hours):
0.0

Description

Paramétrage de e2guardian (4.1.3) ...

chown: impossible d'accéder à '/var/log/e2guardian': Aucun fichier ou dossier de ce type
dpkg: erreur de traitement du paquet e2guardian (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg: des problèmes de dépendances empêchent la configuration de eole-proxy-pkg :
 eole-proxy-pkg dépend de e2guardian (>= 3.2.0-3) ; cependant :
 Le paquet e2guardian n'est pas encore configuré.

dpkg: erreur de traitement du paquet eole-proxy-pkg (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de eole-amon-all :
 eole-amon-all dépend de eole-proxy-pkg ; cependant :
 Le paquet eole-proxy-pkg n'est pas encore configuré.

dpkg: erreur de traitement du paquet eole-amon-all (--configure) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 e2guardian
 eole-proxy-pkg
 eole-amon-all
l'appel à apt-get (-c /etc/apt/apt-eole.conf remove ufw) a retourné une erreur (code 100). Voir /var/log/apt/term.log
E: Sub-process /usr/bin/dpkg returned an error code (1)

root@amon:~# gen_config 
root@amon:~# tail -f /var/log/apt/term.log
 eole-amon-all dépend de eole-proxy-pkg ; cependant :
 Le paquet eole-proxy-pkg n'est pas encore configuré.

dpkg: erreur de traitement du paquet eole-amon-all (--configure) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 e2guardian
 eole-proxy-pkg
 eole-amon-all
Log ended: 2017-11-28  10:06:58


Related issues

Related to Distribution EOLE - Tâche #22206: Upgrade Amon : le script doit se terminer en erreur lorsque l'installation d'un paquet est en échec Ne sera pas résolu 11/28/2017

Associated revisions

Revision d8b6da5d (diff)
Added by Joël Cuissinat over 3 years ago

Upgrade-Auto : fix e2guardian update on Amon

Ref: #22204

Revision 38e249aa (diff)
Added by Joël Cuissinat over 3 years ago

Fix for e2guardian upgrade en preinstall

Ref: #22204

History

#1 Updated by Gérald Schwartzmann over 3 years ago

  • Related to Tâche #22206: Upgrade Amon : le script doit se terminer en erreur lorsque l'installation d'un paquet est en échec added

#2 Updated by Gérald Schwartzmann over 3 years ago

Solution pour l'erreur de mise à jour

root@amon:~# mkdir /var/log/e2guardian
root@amon:~# apt install -f

#3 Updated by Gérald Schwartzmann over 3 years ago

  • Parent task changed from #21803 to #22222

#4 Updated by Joël Cuissinat over 3 years ago

  • Status changed from Nouveau to En cours

#5 Updated by Joël Cuissinat over 3 years ago

  • Assigned To set to Joël Cuissinat
  • Estimated time set to 2.00 h
  • Remaining (hours) set to 2.0

#6 Updated by Joël Cuissinat over 3 years ago

  • Remaining (hours) changed from 2.0 to 1.0

#7 Updated by Joël Cuissinat over 3 years ago

  • % Done changed from 0 to 50

#8 Updated by Scrum Master over 3 years ago

  • Status changed from En cours to Résolu

#9 Updated by Joël Cuissinat over 3 years ago

  • % Done changed from 50 to 100
  • Remaining (hours) changed from 1.0 to 0.25

#10 Updated by Emmanuel GARETTE over 3 years ago

  • Status changed from Résolu to Fermé
  • Remaining (hours) changed from 0.25 to 0.0

OK :

root@amon:~# dpkg -l e2guardian
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom             Version      Architecture Description
+++-===============-============-============-====================================
ii  e2guardian      4.1.3        amd64        Web content filtering

Also available in: Atom PDF