Project

General

Profile

Anomalie #2093

Ne s'installe pas sur mon poste

Added by Thierry Chich about 11 years ago. Updated almost 11 years ago.

Status:
Fermé
Priority:
Normal
Assigned To:
Gwenael Remond
Category:
-
Start date:
09/22/2011
Due date:
% Done:

100%

Distribution:

Description

Je suis sur une ubuntu 64 11.04. J'ai inclus les sources suivants :

deb http://eoleng.ac-dijon.fr/eoleng/ eole-2.2/all/
deb http://eoleng.ac-dijon.fr/eoleng/ eole-2.2-dev/all/
deb http://eoleng.ac-dijon.fr/eoleng/ eole-2.2-proposed/all/
deb http://eoleng.ac-dijon.fr/eoleng/ eole-2.2-updates/
deb http://eoleng.ac-dijon.fr/eoleng/ eole-2.2-security/all/

apt-get install era m'installe bien era, mais :
tchich@cia-tchich:~$ era
Traceback (most recent call last):
File "/usr/share/era/era", line 28, in <module>
from era.ihm import matrix
File "/usr/share/era/ihm/matrix.py", line 23, in <module>
from era.backend.nufw_acl_plaintext import gen_acls as gen_nufw_acl_plaintext
File "/usr/share/era/backend/nufw_acl_plaintext.py", line 28, in <module>
from creole.parsedico import parse_dico
ImportError: No module named creole.parsedico

Si j'essaie sudo apt-get install creole :

Les paquets suivants contiennent des dépendances non satisfaites :
creole : Dépend: eolebase mais ne sera pas installé ou
eolebase-openvz mais ne sera pas installé ou
eolebase-client-common mais ne sera pas installé
E: Paquets défectueux

Associated revisions

Revision 691c32ea (diff)
Added by Joël Cuissinat about 11 years ago

dépendance explicite sur creole (fixes #2093)

Revision cc749ec4 (diff)
Added by Joël Cuissinat about 11 years ago

suppression des dépendances sur eolebase afin d'installer era indépendamment d'Eole (ref #2093)

History

#1 Updated by Joël Cuissinat about 11 years ago

  • Status changed from Nouveau to Résolu
  • % Done changed from 0 to 100

#2 Updated by Gwenael Remond about 11 years ago

Era est maintenant fortement dépendant de Créole, l'erreur provenait des dépendances du paquet Créole
=> http://dev-eole.ac-dijon.fr/gitweb/?p=creole;a=commit;h=cc749ec485a23bad7bd02fdc6d2ae3a635f6f6cb

#3 Updated by Joël Cuissinat about 11 years ago

  • Target version set to Mises à jour 2.2.3 - 02 Stable

#4 Updated by Joël Cuissinat about 11 years ago

  • Status changed from Résolu to Fermé
  • Assigned To set to Gwenael Remond

OK :

root@jojo:~# apt-get install era
...
Les paquets supplémentaires suivants seront installés :
  creole python-pyeole
...

=> à vérifier sur 2.3

#5 Updated by Joël Cuissinat almost 11 years ago

Sur 2.3 (era 2.3-eole25~1.gbp72d790) : aucune dépendance ne semble nécessaire ;)

Also available in: Atom PDF