Project

General

Profile

Tâche #19966

Préparer un texte d'explication

Added by Joël Cuissinat about 3 years ago. Updated about 3 years ago.

Status:
Fermé
Priority:
Normal
Assigned To:
Start date:
03/27/2017
Due date:
% Done:

100%

Estimated time:
2.00 h
Spent time:
Remaining (hours):
0.0

diagnose-kernel-OK.png View (38.5 KB) Daniel Dehennin, 03/28/2017 03:48 PM

agent-zephir-kernel-OK.png View (39.5 KB) Daniel Dehennin, 03/28/2017 03:48 PM

diagnose-kernel-new-package.png View (39.9 KB) Daniel Dehennin, 03/28/2017 03:48 PM

agent-zephir-kernel-new-package.png View (40.5 KB) Daniel Dehennin, 03/28/2017 03:48 PM

diagnose-kernel-reboot.png View (39.9 KB) Daniel Dehennin, 03/28/2017 03:48 PM

agent-zephir-kernel-reboot.png View (40.6 KB) Daniel Dehennin, 03/28/2017 03:49 PM

History

#1 Updated by Scrum Master about 3 years ago

  • Status changed from Nouveau to En cours

#2 Updated by Scrum Master about 3 years ago

  • Assigned To set to Daniel Dehennin

#3 Updated by Daniel Dehennin about 3 years ago

Proposition de texte :

TITRE : Mise à jour corrective EOLE 2.4 et 2.5 et nouvelle image ISO 2.5.2.2

Résumé : Un nouveau test diagnose et un nouvel agent Zéphir permet de connaître l’état de maintenance du noyau.
Une nouvelle image ISO 2.5.2.2 utilise le dernier noyau Xenial Xerus pour Trusty Tahr.

Message :

Depuis la version Lucid Lynx, Ubuntu a mis en place la politique « LTS Enablement Stacks » appelé aussi HWE (Hardware Enablement).

Cela permet aux publications intermédiaires « point releases (12.04.1, 12.04.2, …) » de supporter du matériel plus récent en intégrant un rétroportage des noyaux des versions non LTS à l’image ISO d’installation et ce jusqu’à l’apparition de la « point release .5 », qui elle, fournie le noyau de la version LTS suivante.

Ces noyaux intermédiaires sont aussi ceux sélectionnés automatiquement lors d’une migration d’une version plus ancienne, chez EOLE la présence d'un noyau intermédiaire vient d’un Upgrade-Auto depuis la version 2.3.

Le problème de ces noyaux intermédiaires c'est qu'il ne sont jamais migrés vers une version supérieure pour éviter de modifier l'état de la machine lors d’une mise à jour, en effet un noyau plus récent pourrait mal supporter un type donné de matériel.

Or ces noyaux intermédiaires ne sont pas des noyaux LTS (malgré la présence du mot lts dans le nom du paquet), leur durée de support est bien inférieur à ceux dit LTS, il est donc possible d'avoir des serveurs avec un noyau qui n'est plus maintenu !

Depuis la version 16.04, Ubuntu a corrigé ce fonctionnement, les images ISO d’installation, y compris les versions intermédiaires, n’installe plus que la version LTS du noyau (celui publié à la version de la 16.04.0), c’est à l’administrateur d’installer des versions plus récentes si le besoin se fait sentir.

Nous avons généré une nouvelle image ISO 2.5.2.2 qui est livrée avec un noyau maintenu pour toute la durée de vie de la version 2.5.

Pour déterminer si le noyau de vos serveurs est maintenu par Ubuntu, nous fournissons deux outils de diagnostique :

Si votre noyau n’est plus maintenu, les outils vous indiquent quel paquet installer afin de migrer vers un noyau maintenu par Ubuntu :

#4 Updated by Gérald Schwartzmann about 3 years ago

  • % Done changed from 0 to 50
  • Remaining (hours) changed from 2.0 to 1.0

#5 Updated by Scrum Master about 3 years ago

  • Status changed from En cours to Résolu

#6 Updated by Daniel Dehennin about 3 years ago

  • % Done changed from 50 to 100

#7 Updated by Daniel Dehennin about 3 years ago

  • Private changed from Yes to No

#8 Updated by Scrum Master about 3 years ago

  • Status changed from Résolu to Fermé
  • Remaining (hours) changed from 1.0 to 0.0

Also available in: Atom PDF