Project

General

Profile

Tâche #17654

Distribution EOLE - Scénario #17459: Implémenter Upgrade-Auto 2.5.2 => 2.6.0

Nettoyer les scripts pre/post utilisés par Upgrade-Auto

Added by Joël Cuissinat over 3 years ago. Updated over 3 years ago.

Status:
Fermé
Priority:
Normal
Assigned To:
Start date:
10/25/2016
Due date:
% Done:

100%

Estimated time:
4.00 h
Spent time:
Remaining (hours):
0.0

Description

Scripts présents dans les répertoires :
  • /usr/share/eole/upgrade/pre_download
  • /usr/share/eole/upgrade/post_upgrade

Associated revisions

Revision 5ddb432a (diff)
Added by Joël Cuissinat over 3 years ago

Suppression scripts pre/post upgrade obsolètes liés à Amon

Ref: #17654 @20m

Revision 900f9ce9 (diff)
Added by Joël Cuissinat over 3 years ago

Suppression scripts pre/post upgrade obsolètes liés à Bacula

Ref: #17654 @10m

Revision 141f8a04 (diff)
Added by Joël Cuissinat over 3 years ago

Suppression scripts pre/post upgrade obsolètes liés à Sympa

Ref: #17654 @20m

Revision a5c331b0 (diff)
Added by Joël Cuissinat over 3 years ago

Suppression scripts pre/post upgrade obsolètes liés à Apache (2.2)

Ref: #17654 @20m

History

#1 Updated by Joël Cuissinat over 3 years ago

/usr/share/eole/upgrade/pre_download :
  • 00-common : OK
  • 00-dpkg_options : ajoute les options "force-confdef" et "force-confmiss" => OK
  • 01-amon : à supprimer (#8621)
  • 01-bacula : à supprimer (#14933)
  • 01-horus : OK pour #11070, vérifier si l'upgrade peut être réalisé avec un mot de passe désynchronisé ?
  • 03-zephir-client : OK (pourrait être fusionné avec 00-common ?)
  • 10-rsyslog : OK
  • 10-sympa : plus utile (#14682) ?
  • 90-fill-apt-cache : OK

#2 Updated by Joël Cuissinat over 3 years ago

/usr/share/eole/upgrade/post_upgrade :
  • 00-common : conserver la suppression des pyc ?
  • 01-amon : à supprimer (#8621, #14608, #15760, #16147)
  • 01-bacula : à supprimer (#14933)
  • 01-horus : OK
  • 03-zephir-client : OK
  • 10-apache : à étudier (#14682)
  • 90-delete-iso : OK
  • 99-grub : à étudier mais une partie sera forcément à conserver (#14068)
  • 99-unlock : OK mais à étudier et mettre à jour (#14711) ???
  • 99-upgrade_eole : OK

#3 Updated by Joël Cuissinat over 3 years ago

  • Project changed from Distribution EOLE to creole

#4 Updated by Joël Cuissinat over 3 years ago

  • % Done changed from 0 to 30
  • Remaining (hours) changed from 4.0 to 2.0

#5 Updated by Joël Cuissinat over 3 years ago

  • % Done changed from 30 to 80
  • Remaining (hours) changed from 2.0 to 0.5

#6 Updated by Joël Cuissinat over 3 years ago

post_upgrade/10-apache
  • les paquets listés ne sont pas installés sur un Scribe 2.5.2
    root@scribe:~# dpkg -l apache2-mpm-prefork apache2-utils apache2.2-bin
    Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
    | État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
    |/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
    ||/ Nom                                             Version                      Architecture                 Description
    +++-===============================================-============================-============================-=====================================
    un  apache2-mpm-prefork                             <aucun>                      <aucune>                     (aucune description n'est disponible)
    un  apache2-utils                                   <aucun>                      <aucune>                     (aucune description n'est disponible)
    un  apache2.2-bin                                   <aucun>                      <aucune>                     (aucune description n'est disponible)
    
  • les modules listés sont déjà activés sur un Scribe 2.5.2 instancié
    root@scribe:~# a2enmod alias auth_basic authn_file authz_host authz_user autoindex deflate dir env negotiation status 
    Module alias already enabled
    Considering dependency authn_core for auth_basic:
    Module authn_core already enabled
    Module auth_basic already enabled
    Module authn_file already enabled
    Considering dependency authz_core for authz_host:
    Module authz_core already enabled
    Module authz_host already enabled
    Considering dependency authz_core for authz_user:
    Module authz_core already enabled
    Module authz_user already enabled
    Module autoindex already enabled
    Considering dependency filter for deflate:
    Module filter already enabled
    Module deflate already enabled
    Module dir already enabled
    Module env already enabled
    Module negotiation already enabled
    Module status already enabled
    

#7 Updated by Joël Cuissinat over 3 years ago

  • Status changed from En cours to Résolu

#8 Updated by Joël Cuissinat over 3 years ago

  • Status changed from Résolu to Fermé
  • % Done changed from 80 to 100
  • Remaining (hours) changed from 0.5 to 0.0

Also available in: Atom PDF