Tâche #17180
Scénario #17455: Traitement express MEN (42-44)
Droits unix modifiés suite à Upgrade-Auto
100%
Description
Suite à la migration d'un Scribe 2.4.2 en 2.5.2 via Upgrade-Auto, les droits d'exécution des scripts personnalisés dans le netlogon ont sauté.
On obtient, à la connexion, des messages du type :
"Une erreur s'est produite lors du traitement du fichier `\\scribe\netlogon \tony.martinVista.txt (5, 'CreateProcess', 'Acc\xe8s refus\xe9.') cmd,\\scribe\netlogon\scripts\user.bat,HIDDEN,NOWAIT
Dans les fichiers log, on trouve :
2016-09-01 12:14:04,421 (3692) INFO "parse_line" cmd : \\10.147.22.231\netlogon\scripts\ext_ggb.bat HIDDEN=True NOWAIT=True 2016-09-01 12:14:04,467 (3692) ERROR "error" Une erreur s'est produite lors du traitement du fichier \\scribe\netlogon\vfraicheWinXP.txt (5, 'CreateProcess', 'Acc\xe8s refus\xe9.') cmd,\\10.147.22.231\netlogon\scripts\ext_ggb.bat,HIDDEN,NOWAIT 2016-09-01 12:14:04,500 (3692) DEBUG "traitefich" Erreur Traceback (most recent call last): File "logon.py", line 223, in traitefich File "logon.py", line 254, in parse_line File "eole\lance_cmd.pyo", line 30, in lancecmd error: (5, 'CreateProcess', 'Acc\xe8s refus\xe9.')
Remettre les droits d'exécution unix résout le problème.
A quel moment ces droits ont été modifiés ? Est-il possible de les restaurer tels qu'ils étaient une fois l'upgrade terminé ?
Demandes liées
Révisions associées
smb.conf : ajout de l'option "acl allow execute always = Yes" REF #17646 @2h
smb.conf : déplacement de l'option "acl allow execute always = Yes" REF #17646
Historique
#1 Mis à jour par Klaas TJEBBES il y a presque 10 ans
Scribe 2.4 > Samba 3
Scribe 2.5 > Samba 4
Depuis Samba4, il faut que les fichiers exécutables (.exe, .bat, .cmd, etc.) aient le droit "chmod +x", sinon Samba4 refuse l'exécution.
Le plus simple, en attendant un correctif dans Upgrade-Auto :
find /home/ -type f \( -iname '*exe' -o -iname '*msi' -o -iname '*cmd' -o -iname '*bat' \) -exec chmod +x {} \;
Vérifier si ça applique bien les +x sur toutes les ACLs et pas uniquement sur les droits POSIX...
#2 Mis à jour par Bruno Debeve il y a presque 10 ans
Sur les fichiers concernés, en faisant un
chmod 755 fichier.batça refonctionne, donc y'a pas de raison.
Ceci dit, je suis presque sur que les fichiers de départ (avant upgrade-auto) étaient déjà en +x.
#3 Mis à jour par Klaas TJEBBES il y a presque 10 ans
En fait un fichier .bat sans le bit d'exécution (+x) fonctionne normalement :
root@scribek25:/home/netlogon/scripts/groups# cat DomainUsers.txt cmd,\\scribek25\netlogon\scripts\groups\toto.bat,HIDDEN,NOWAIT root@scribek25:/home/netlogon/scripts/groups# getfacl toto.bat # file: toto.bat # owner: admin # group: professeurs user::rw- group::rw- other::r--
########## SESSION ########## 2016-10-25 11:00:31,217 (164) INFO "logon" Ouverture de session de admin sur domscrk25 2016-10-25 11:00:31,240 (164) INFO "test_logon_type" domaine : domscrk25, dom_scribe : domscrk25 2016-10-25 11:00:31,894 (164) INFO "traitefich" Traitement de \\scribek25\netlogon\adminWinXP.txt 2016-10-25 11:00:31,959 (164) INFO "parse_line" cmd : \\scribek25\netlogon\scripts\groups\toto.bat HIDDEN=True NOWAIT=True 2016-10-25 11:00:32,187 (164) INFO "parse_line" lecteur : R: \\scribek25\icones$ [...] 2016-10-25 11:00:42,301 (164) DEBUG Userinit 0
#4 Mis à jour par Klaas TJEBBES il y a presque 10 ans
Que pour admin, pour un eleve :
########## SESSION ########## 2016-10-25 11:37:47,948 (1980) INFO "logon" Ouverture de session de eleve1 sur domscrk25 2016-10-25 11:37:47,959 (1980) INFO "test_logon_type" domaine : domscrk25, dom_scribe : domscrk25 2016-10-25 11:37:48,579 (1980) INFO "traitefich" Traitement de \\scribek25\netlogon\eleve1WinXP.txt 2016-10-25 11:37:48,619 (1980) INFO "parse_line" cmd : \\scribek25\netlogon\scripts\groups\toto.bat HIDDEN=True NOWAIT=True 2016-10-25 11:37:48,640 (1980) ERROR "error" Une erreur s'est produite lors du traitement du fichier \\scribek25\netlogon\eleve1WinXP.txt (5, 'CreateProcess', 'Acc\xe8s refus\xe9.') cmd,\\scribek25\netlogon\scripts\groups\toto.bat,HIDDEN,NOWAIT 2016-10-25 11:37:48,700 (1980) DEBUG "traitefich" Erreur Traceback (most recent call last): File "logon.py", line 223, in traitefich File "logon.py", line 254, in parse_line File "eole\lance_cmd.pyo", line 30, in lancecmd error: (5, 'CreateProcess', 'Acc\xe8s refus\xe9.') 2016-10-25 11:37:48,720 (1980) INFO "parse_line" lecteur : R: \\scribek25\icones$
#5 Mis à jour par Klaas TJEBBES il y a presque 10 ans
Solution, utiliser l'option :
acl allow execute always = Yes
#6 Mis à jour par Klaas TJEBBES il y a presque 10 ans
- Tracker changé de Demande à Tâche
#7 Mis à jour par Klaas TJEBBES il y a presque 10 ans
- Tâche parente mis à #17455
#8 Mis à jour par Klaas TJEBBES il y a presque 10 ans
#9 Mis à jour par Klaas TJEBBES il y a presque 10 ans
- Statut changé de Nouveau à Résolu
- Assigné à mis à Klaas TJEBBES
#10 Mis à jour par Joël Cuissinat il y a presque 10 ans
- % réalisé changé de 0 à 100
- Temps estimé mis à 2.00 h
- Restant à faire (heures) mis à 0.5
#11 Mis à jour par Joël Cuissinat il y a presque 10 ans
- Description mis à jour (diff)
#12 Mis à jour par Joël Cuissinat il y a presque 10 ans
- Statut changé de Résolu à Fermé
- Restant à faire (heures) changé de 0.5 à 0.0