Project

General

Profile

Tâche #16850

Scénario #16726: Traitement express (28-35)

Le zephir remonte un dictionnaire eole-db installé manuellement

Added by Thierry Bertrand about 3 years ago. Updated about 3 years ago.

Status:
Fermé
Priority:
Normal
Assigned To:
Start date:
01/05/2015
Due date:
% Done:

100%

Estimated time:
1.00 h
Spent time:
Remaining (hours):
0.0

Associated revisions

Revision d6d4c629 (diff)
Added by Thierry Bertrand about 3 years ago

Ajout d'eole-db comme paquet module pour l'esbl 2.5.2 Ref: #16850 @10min

History

#1 Updated by Thierry Bertrand about 3 years ago

Depuis la 2.5.2, la gestion des bases de données passe par eole-db et plus eole-mysql.

Or eole-mysql nécessite eole-db et donc l'installe sur le serveur par jeu de dépendance.
Du coup, Zephir le voit comme un paquet supplémentaire installé manuellement.

=> inclure eole-db dans la gestion des paquets eole-zephir-medde

#2 Updated by Thierry Bertrand about 3 years ago

  • Status changed from Nouveau to En cours

#3 Updated by Thierry Bertrand about 3 years ago

  • Status changed from En cours to Résolu
  • % Done changed from 0 to 100

modification faite pour la gestion des esbl 2.5.2
déployé et testé sur Zdev

NB : TODO creuser la dépendance entre eole-db & eole-mysql
Sur un 2.5.2 à jour, j'avais :

root@sbl250-139:/etc/apt/apt.conf.d# apt-cache policy eole-db
eole-db:
  Installé : (aucun)
  Candidat : 2.5.2-3
 Table de version :
     2.5.2-3 0
        500 http://test-eole.ac-dijon.fr/eole/ eole-2.5.2-updates/main amd64 Packages
     2.5.2-1 0
        500 http://test-eole.ac-dijon.fr/eole/ eole-2.5.2/main amd64 Packages
root@sbl250-139:/etc/apt/apt.conf.d# apt-cache policy eole-mysql
eole-mysql:
  Installé : 2.5.2-2
  Candidat : 2.5.2-2
 Table de version :
 *** 2.5.2-2 0
        500 http://test-eole.ac-dijon.fr/eole/ eole-2.5.2/main amd64 Packages
        100 /var/lib/dpkg/status
root@sbl250-139:/etc/apt/apt.conf.d# apt-eole install eole-db
Action install pour root
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libgnome-keyring-common libgnome-keyring0 libhdb9-heimdal libkdc2-heimdal
  libntdb1 python-ntdb
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés : 
  libyaml-0-2 python-eoledb python-termcolor python-yaml
Les NOUVEAUX paquets suivants seront installés :
  eole-db libyaml-0-2 python-eoledb python-termcolor python-yaml
0 mis à jour, 5 nouvellement installés, 0 à enlever et 0 non mis à jour.

#4 Updated by Emmanuel IHRY about 3 years ago

  • Status changed from Résolu to Fermé
  • Remaining (hours) changed from 1.0 to 0.0

Also available in: Atom PDF