Project

General

Profile

Tâche #16660

Distribution EOLE - Scénario #16516: Traitement express (25-27)

gen_config ne valide plus les "slave" obligatoires en 2.6

Added by Joël Cuissinat over 3 years ago. Updated over 3 years ago.

Status:
Fermé
Priority:
Normal
Assigned To:
Start date:
06/29/2016
Due date:
% Done:

100%

Estimated time:
2.00 h
Spent time:
Remaining (hours):
0.0

Description

En 2.6, gen_config permet d'enregistrer des configurations avec des variables esclaves obligatoires non renseignées et forcément ça coince au reconfigure :

Erreur creole 3 : Toutes les variables obligatoires ne sont pas renseignées, veuillez configurer votre système: creole.test.vmaster.vslave

Avec le même dico joint, on ne peut pas enregistrer la configuration avec vslave non renseignée en 2.5.2.

Je propose de commencer par écrire le test unitaire correspondant ;)

99_master.xml View (457 Bytes) Joël Cuissinat, 06/29/2016 10:09 AM

Associated revisions

Revision 581e38f1 (diff)
Added by Joël Cuissinat over 3 years ago

Test unitaire pour vérifier les mandatory dans gen_config

Ref: #16660 @45m

History

#1 Updated by Joël Cuissinat over 3 years ago

  • % Done changed from 0 to 40
  • Remaining (hours) changed from 2.0 to 1.5

Test unitaire test_obligatoire() ajouté dans /usr/share/creole/tests/test_genconfig.py

#2 Updated by Scrum Master over 3 years ago

  • Status changed from Nouveau to En cours

#3 Updated by Scrum Master over 3 years ago

  • Status changed from En cours to Résolu

#4 Updated by Scrum Master over 3 years ago

  • Assigned To set to Joël Cuissinat

#5 Updated by Joël Cuissinat over 3 years ago

  • % Done changed from 40 to 100
  • Remaining (hours) changed from 1.5 to 0.25

=> paquet tiramisu 2.0.14-1

#6 Updated by Joël Cuissinat over 3 years ago

testé OK

#7 Updated by Joël Cuissinat over 3 years ago

  • Status changed from Résolu to Fermé
  • Remaining (hours) changed from 0.25 to 0.0

Also available in: Atom PDF