Project

General

Profile

Tâche #15826

Scénario #15825: Mettre à niveau la configuration de PHP sur EOLE 2.6

Mettre à niveau le template php.ini

Added by Joël Cuissinat over 5 years ago. Updated about 5 years ago.

Status:
Fermé
Priority:
Normal
Assigned To:
Start date:
04/11/2016
Due date:
% Done:

100%

Estimated time:
4.00 h
Spent time:
Remaining (hours):
0.0

php.ini View - /etc/php/7.0/apache2/php.ini sur Xenial (67.6 KB) Joël Cuissinat, 04/11/2016 02:09 PM


Related issues

Copied to Distribution EOLE - Tâche #16920: OCS - OCS ne devrait pas activer "allow_url_fopen" globalement Fermé 02/13/2017

Associated revisions

Revision 67097942 (diff)
Added by Joël Cuissinat about 5 years ago

Mise à niveau du php.ini pour EOLE 2.6

Ref: #15826 @2.5h

Revision 0c483de0 (diff)
Added by Joël Cuissinat about 5 years ago

html_errors et allow_url_fopen de nouveau désactivés

Ref: #15826 @20m

History

#1 Updated by Joël Cuissinat about 5 years ago

  • Assigned To set to Joël Cuissinat

#2 Updated by Joël Cuissinat about 5 years ago

  • Status changed from Nouveau to En cours

Je suis reparti du fichier de configuration fourni sur la 16.04 sur lequel j'ai ré-appliqué les 10 variables Creole en vérifiant que nos valeurs par défaut sont toujours cohérentes.

J'ai analysé les autres différences notables entre les deux fichiers, voila quelques unes des modifications apparues :
  • html_errors : Off => On
  • default_charset : (vide) => "UTF-8"
  • allow_url_fopen : Off => On
  • session.gc_probability : 1 => 0
  • short_open_tag : proposé à Off mais volontairement laissé à On

#3 Updated by Joël Cuissinat about 5 years ago

  • % Done changed from 0 to 100
  • Remaining (hours) changed from 4.0 to 0.25

#4 Updated by Joël Cuissinat about 5 years ago

  • Status changed from En cours to Résolu

#5 Updated by Emmanuel GARETTE about 5 years ago

  • Status changed from Résolu to En cours
  • Remaining (hours) changed from 0.25 to 1.0

On veut vraiment :

allow_url_fopen : Off => On

??

Moi je ne ferais pas cela si aucune application n'en a besoin.

Dans une moindre mesuse je pense que c'est une mauvaise idée le "html_errors : Off => On".

Sinon le template est bien à jour sur 2.6.

#6 Updated by Joël Cuissinat about 5 years ago

Après discussion, nous allons remettre les anciennes valeurs sur ces 2 paramètres.

#7 Updated by Joël Cuissinat about 5 years ago

  • Status changed from En cours to Résolu
  • Remaining (hours) changed from 1.0 to 0.25

#8 Updated by Emmanuel GARETTE about 5 years ago

  • Status changed from Résolu to Fermé
  • Remaining (hours) changed from 0.25 to 0.0

Ok :

root@scribe:~# grep allow_url_fopen /etc/php/7.0/apache2/php.ini 
allow_url_fopen = Off
root@scribe:~# grep html_errors /etc/php/7.0/apache2/php.ini 
html_errors = Off

Also available in: Atom PDF