Project

General

Profile

Tâche #15761

Scénario #15554: Traitement express (13-15)

La procédure de génération de migration ne fonctionne pas pour un eSBL 2.4.1 => vers 2.5.1

Added by Thierry Bertrand over 3 years ago. Updated over 3 years ago.

Status:
Fermé
Priority:
Normal
Assigned To:
Start date:
10/20/2015
Due date:
% Done:

100%

Estimated time:
1.00 h
Spent time:
Remaining (hours):
0.0

Associated revisions

Revision 9eac0818 (diff)
Added by Bruno Boiget over 3 years ago

Mise à jour des options de migration pour les modules MEDDE

  • plus de migration 2.3 vers 2.4.2 (abandonnée)
  • ajout de la migration 2.4.1 vers 2.5.1

ref #15761 @40m

Revision d7f2868e (diff)
Added by Bruno Boiget over 3 years ago

Ajout de la migration 2.4.1 vers 2.5.2 pour les modules MEDDE

ref #15761 @10m

History

#1 Updated by Thierry Bertrand over 3 years ago

Contexte :
module à migrer : eSBL 2.4.1
zephir 2.5.1

Depuis le Zephir, migration, générer
=> variante de migration : esbl-2.5.1 - production (163)

sur le serveur hébergeant l'eSBL 2.4.1, installation de la 2.5.1 puis :

root@esbl:~# enregistrement_zephir
Procédure d'enregistrement sur le serveur Zéphir 
Voulez-vous établir une configuration réseau minimale (O/N) : N 
Entrez l'adresse du serveur Zéphir : zephir-ddi-4x.eole.e2.rie.gouv.fr 
Entrez votre login pour l'application Zéphir (rien pour sortir) : thierry.bertrand 
Mot de passe pour l'application Zéphir pour thierry.bertrand : 
créer le serveur dans la base du serveur Zéphir (O/N) : N 
** utilisation d'un serveur existant dans la base du serveur Zéphir ** 
entrez le RNE de l'établissement correspondant au serveur (rien pour saisir directement un n° de serveur) : 
entrez le n° identifiant le serveur l'application Zéphir : 6434 
Vérification des informations sur le matériel 
!! Vous êtes actuellement sur un module esbl-2.5.1 !! 
Le module du serveur choisi est esbl-2.4.1, Voulez vous migrer le serveur vers le module esbl-2.5.1 dans l'application Zéphir (O/N) ? O 
matériel (PowerEdge R730 (SKU=NotProvided;ModelName=PowerEdge R730) par défaut) : 
processeur ( Intel(R) Xeon(R) CPU E5-2609 v3 @ 1.90GHz 1895 MHz par défaut) : 
disque dur (8378 Go par défaut) : 
nom de l'installateur (thierry.bertrand par défaut) : 
!! erreur lors de la migration : la migration vers le module demandé n'est pas gérée !! 
entrez le RNE de l'établissement correspondant au serveur 

#2 Updated by Thierry Bertrand over 3 years ago

jojo2024> Icephale, teebee44 : 'esbl':{4:[7], 5:[7,8,10,11]},
jojo2024> Icephale: avec la liste des chevaux https://dev-eole.ac-dijon.fr/projects/zephir-parc/repository/entry/python/zephir/config.py?utf8=%E2%9C%93&rev=#L80
jojo2024> si je comprends bien il manque au minimum 7:[10] (pour 2.4.1 vers 2.5.1)

#3 Updated by Bruno Boiget over 3 years ago

  • Assigned To set to Bruno Boiget
  • % Done changed from 0 to 100
  • Remaining (hours) changed from 1.0 to 0.25

Mise à jour des paramètres de migration pour eSBL/eCDL :

  • migration vers les version 2.5.1 et 2.5.2 autorisées
  • suppression de la migration 2.3 vers 2.4.2 (non déployée)

#4 Updated by Thierry Bertrand over 3 years ago

  • Status changed from Nouveau to Fermé
  • Remaining (hours) changed from 0.25 to 0.0

sur Zephir 2.5.2RC,
création eSBL 2.4.1
génération données migration vers 2.5.1
lancement VM 2.5.1
enregistrement_zephir

=> basculement sur conf 2.5.1 ok

#5 Updated by Thierry Bertrand over 3 years ago

Au passage, 2.4.1 => 2.5.2 fonctionne aussi

Also available in: Atom PDF