Project

General

Profile

Tâche #14139

Distribution EOLE - Scénario #14084: Assistance aux utilisateurs (49-51)

Si on désactive les VLAN dans l'interface, ils doivent être désactivés sur le serveur

Added by Joël Cuissinat over 5 years ago. Updated over 5 years ago.

Status:
Fermé
Priority:
Normal
Start date:
11/30/2015
Due date:
% Done:

100%

Estimated time:
3.00 h
Spent time:
Remaining (hours):
0.0

Description

En voulant fermer #1114 qui proposait notamment de documenter la commande vconfig rem <ethX.vlanID> quand les VLAN n'étaient pas supprimés, j'ai vu que le problème avait été résolu depuis #710.

Par acquis de conscience, j'ai testé en déclarant un VLAN sur eth0 puis reconfiguré. Ensuite CreoleSet vlan_eth0 non puis reconfigure ... le VLAN est toujours là :

root@amonecole:~# ifconfig | grep eth0
eth0      Link encap:Ethernet  HWaddr 02:00:c0:a8:00:6a  
eth0.55   Link encap:Ethernet  HWaddr 02:00:c0:a8:00:6a

Les "bricolages" avaient été supprimés dans les commits liés à #4444.


Related issues

Copied from eole-common - Evolution #710: pb avec les vlans en cas de changement des id Fermé 06/23/2010

Associated revisions

Revision f2d2baaa (diff)
Added by Fabrice Barconnière over 5 years ago

Ajout de toutes les interfaces au fichier /var/run/network/ifstate

preservice/99-ifupdown :
  • en cas de création manuelle de VLAN, le fichiers ifstate ne contient pas cette interface.
    En preservice, alimentation de ce fichier avec toutes les interfaces réseau disponibles sur le serveur pour que ifupdown puisse gérer leur supression.

ref #14139 @3h

History

#1 Updated by Scrum Master over 5 years ago

  • Assigned To set to Fabrice Barconnière

#2 Updated by Fabrice Barconnière over 5 years ago

Testé sur un Eolebase et Amonecole 2.5.1 : je n'ai pas constaté cette anomalie en appliquant cette méthode.

#3 Updated by Fabrice Barconnière over 5 years ago

  • Tracker changed from Demande to Tâche
  • Estimated time set to 3.00 h
  • Parent task set to #14084
  • Remaining (hours) set to 3.0
J'ai réussi à reproduire le problème de la façon suivante :
  • Eolebase Aca 2.5.1 instance default
  • Ajout manuel de VLAN :
    • ip link add link eth0 name eth0.110 type vlan id 110
    • ip a add 192.168.0.25/24 dev eth0.110
    • ip link set eth0.110 up
  • la commande ifconfig ou ip a renvoie bien l'adresse ip
  • lancer reconfigure
  • la commande ifconfig ou ip a renvoie toujours l'adresse ip

Testé avec les alias, pas de problème, ils sont bien supprimés.

#4 Updated by Fabrice Barconnière over 5 years ago

  • Assigned To deleted (Fabrice Barconnière)

#5 Updated by Fabrice Barconnière over 5 years ago

  • Status changed from Nouveau to En cours
  • Start date set to 11/30/2015

#6 Updated by Fabrice Barconnière over 5 years ago

  • Assigned To set to Fabrice Barconnière

#7 Updated by Fabrice Barconnière over 5 years ago

  • Remaining (hours) changed from 3.0 to 0.25

#8 Updated by Scrum Master over 5 years ago

  • Status changed from En cours to Résolu

#9 Updated by Fabrice Barconnière over 5 years ago

  • % Done changed from 0 to 100

#10 Updated by Joël Cuissinat over 5 years ago

  • Remaining (hours) changed from 0.25 to 0.0

#11 Updated by Joël Cuissinat over 5 years ago

  • Status changed from Résolu to Fermé

Testé OK

Also available in: Atom PDF