Project

General

Profile

Tâche #12085

Scénario #11902: Passer php-xapian en 2.4

Fournir un paquet .deb avec une version à jour de php-xapian

Added by Gérald Schwartzmann almost 6 years ago. Updated almost 6 years ago.

Status:
Fermé
Priority:
Normal
Assigned To:
Start date:
06/22/2015
Due date:
% Done:

100%

Estimated time:
4.00 h
Spent time:
Remaining (hours):
0.0

History

#1 Updated by Scrum Master almost 6 years ago

  • Status changed from Nouveau to En cours

#2 Updated by Scrum Master almost 6 years ago

  • Assigned To set to Daniel Dehennin

#3 Updated by Daniel Dehennin almost 6 years ago

  • % Done changed from 0 to 100
  • Remaining (hours) changed from 4.0 to 0.5

Paquet disponible sur envole-4-unstable.

#4 Updated by Scrum Master almost 6 years ago

  • Status changed from En cours to Résolu

#5 Updated by Emmanuel GARETTE almost 6 years ago

  • Status changed from Résolu to En cours
  • % Done changed from 100 to 80

Sauf erreur de ma part, le paquet n'est pas installable :

root@scribe:~# Maj-Auto -D
Mise à jour le jeudi 25 juin 2015 11:26:02
*** scribe 2.4.2 (00000001) ***

Maj-Auto - Augmenter le niveau de mise à jour peut empêcher de revenir au niveau de mise à jour stable.
Voulez-vous continuer ? [oui/non]
[non] : o
Configuration du dépôt Ubuntu avec la source test-eole.ac-dijon.fr
Configuration du dépôt EOLE avec la source test-eole.ac-dijon.fr
Configuration du dépôt Envole avec la source test-eole.ac-dijon.fr
Action update pour root                                                                                                                                     
Action list-upgrade pour root
Mise à jour OK
Aucun paquet à installer.
root@scribe:~# apt-get install php5-xapian
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 php5-xapian : Dépend: libxapian22 (>= 1.2.8+eole1) mais 1.2.8-1 devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
root@scribe:~# 

#6 Updated by Daniel Dehennin almost 6 years ago

OK, le suffix de version EOLE était pris en compte pour les dépendances.

Le paquet est corrigé avec la version 1.2.8+eole1-2 en envole-4-unstable.

#7 Updated by Daniel Dehennin almost 6 years ago

  • % Done changed from 80 to 100

#8 Updated by Emmanuel GARETTE almost 6 years ago

  • Status changed from En cours to Fermé
  • Remaining (hours) changed from 0.5 to 0.0

#9 Updated by Emmanuel GARETTE almost 6 years ago

OK :

root@scribe:~# Maj-Auto -D
Mise à jour le jeudi 25 juin 2015 14:18:15
*** scribe 2.4.2 (00000001) ***

Maj-Auto - Augmenter le niveau de mise à jour peut empêcher de revenir au niveau de mise à jour stable.
Voulez-vous continuer ? [oui/non]
[non] : o
Configuration du dépôt Ubuntu avec la source test-eole.ac-dijon.fr
Configuration du dépôt EOLE avec la source test-eole.ac-dijon.fr
Configuration du dépôt Envole avec la source test-eole.ac-dijon.fr
Action update pour root                                                                                                                                     
Action list-upgrade pour root
Mise à jour OK
Aucun paquet à installer.
root@scribe:~# apt-get install php5-xapian
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Paquets suggérés :
  xapian-doc
Les NOUVEAUX paquets suivants seront installés :
  php5-xapian
0 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 259 ko dans les archives.
Après cette opération, 859 ko d'espace disque supplémentaires seront utilisés.
Réception de : 1 http://test-eole.ac-dijon.fr/envole/ envole-4-unstable/main php5-xapian amd64 1.2.8+eole1-2 [259 kB]
259 ko réceptionnés en 0s (12,2 Mo/s)
Sélection du paquet php5-xapian précédemment désélectionné.
(Lecture de la base de données... 118633 fichiers et répertoires déjà installés.)
Dépaquetage de php5-xapian (à partir de .../php5-xapian_1.2.8+eole1-2_amd64.deb) ...
Traitement des actions différées (« triggers ») pour « libapache2-mod-php5 »...
 * Reloading web server config apache2                                                                                                                 [ OK ] 
Paramétrage de php5-xapian (1.2.8+eole1-2) ...
root@scribe:~# dpkg -L php5-xapian
/.
/etc
/etc/php5
/etc/php5/conf.d
/etc/php5/conf.d/xapian.ini
/usr
/usr/lib
/usr/lib/php5
/usr/lib/php5/20090626
/usr/lib/php5/20090626/xapian.so
/usr/share
/usr/share/doc
/usr/share/doc/php5-xapian
/usr/share/doc/php5-xapian/copyright
/usr/share/doc/php5-xapian/index.html
/usr/share/doc/php5-xapian/changelog.gz
/usr/share/doc/php5-xapian/changelog.Debian.gz
/usr/share/doc/php5-xapian/examples
/usr/share/doc/php5-xapian/examples/simpleexpand.php5
/usr/share/doc/php5-xapian/examples/simplesearch.php5
/usr/share/doc/php5-xapian/examples/simplematchdecider.php5
/usr/share/doc/php5-xapian/examples/simpleindex.php5
/usr/share/php
/usr/share/php/xapian.php
/usr/share/doc-base
/usr/share/doc-base/xapian-php5-docs
root@scribe:~# 

Also available in: Atom PDF