Project

General

Profile

Tâche #10704

Scénario #10602: Mise à jour du script Upgrade-Auto 2.3 vers 2.4(.1)

Adapter le script d'upgrade 2.3 vers 2.4 dans le cas d'un cluster haute dispo

Added by Fabrice Barconnière almost 5 years ago. Updated over 2 years ago.

Status:
Fermé
Priority:
Normal
Target version:
Start date:
03/24/2017
Due date:
% Done:

0%

Estimated time:
3.00 h
Spent time:
Remaining (hours):
0.0

Related issues

Copied to Distribution EOLE - Tâche #10815: Valider le script d'upgrade 2.3 vers 2.4 dans le cas d'un cluster haute dispo Fermé 03/24/2015

Associated revisions

Revision 7e2aeb63 (diff)
Added by Fabrice Barconnière almost 5 years ago

eole/upgrade/pre_download/04-corosync : un premier jet mais ne semble
pas suffisant

Le noeud ne se remet pas online
corosync sur le noeud esclave encore en 2.3 s'arrête en gardant les VIP

ref #10704 @2h

Revision 08ee9d2c (diff)
Added by Fabrice Barconnière almost 5 years ago

eole/upgrade/pre_download/04-corosync : gestion du changement du
fingerprint ssh

ref #10704 @2h

Revision 009b7313 (diff)
Added by Bruno Boiget almost 5 years ago

upgrade_distrib.py: message spécifique pour la haute dispo

  • indique qu'il faut mettre à niveau du noeud esclave avant instance

ref #10704 @15m

Revision 3eeee0bd (diff)
Added by Bruno Boiget almost 5 years ago

upgrade_distrib.py: message spécifique pour la haute dispo

  • indique qu'il faut mettre à niveau du noeud esclave avant instance

ref #10704 @15m

Revision 3f418819 (diff)
Added by Emmanuel GARETTE almost 5 years ago

vérifier si la variable activer_haute_dispo existe (ref #10704 @1h)

History

#1 Updated by Fabrice Barconnière almost 5 years ago

  • Status changed from Nouveau to En cours

#2 Updated by Fabrice Barconnière almost 5 years ago

  • Assigned To set to Fabrice Barconnière

#3 Updated by Fabrice Barconnière almost 5 years ago

  • % Done changed from 0 to 50
  • Remaining (hours) changed from 3.0 to 2.0
  • Distribution changed from EOLE 2.4 to EOLE 2.3

#4 Updated by Fabrice Barconnière almost 5 years ago

  • % Done changed from 50 to 80
  • Remaining (hours) changed from 2.0 to 1.0

zephir_client (master) : data/scripts/upgrade_distrib.py --> si /etc/ha.d/.hdinitialized présent, mettre un message "Lancer la procédure d'upgrade sur le noeud esclave avant d'instancier"

#5 Updated by Bruno Boiget almost 5 years ago

modification effectuée dans Zéphir-client pour afficher le message. Ne sachant pas si il reste autre chose à faire, je ne passe pas la demande en état résolu.

#6 Updated by Emmanuel GARETTE almost 5 years ago

Sur un autre module que Sphynx on a l'erreur suivante :

run-parts: executing /tmp/Upgrade-Auto-7250/upgrade/pre_download/04-corosync
/tmp/Upgrade-Auto-7250/upgrade/pre_download/04-corosync: line 15: crm : commande introuvable
/tmp/Upgrade-Auto-7250/upgrade/pre_download/04-corosync: line 16: /etc/init.d/corosync: Aucun fichier ou dossier de ce type
corosync: aucun processus trouvé
corosync: aucun processus trouvé

#7 Updated by Gilles Grandgérard almost 5 years ago

  • Status changed from En cours to Fermé
  • Remaining (hours) changed from 1.0 to 0.0

#8 Updated by Gilles Grandgérard almost 5 years ago

  • % Done changed from 80 to 100

a valider sur un prochain sprint

Also available in: Atom PDF